Subject: Re: full working example

From: Jeff Weisberg <[email-masked]>
Date: Mon, 15 Aug 2005 14:09:30 -0400

On 14 Aug, 2005, at 20:21, Carlos Alperin wrote:
>
> I got it working, but when I modified the config file, it stop working
> again.
>
> This is the /var/argus/config
> [...]
> # enable built in resolver
> Resolv
>
> #added by hand
> chmod_control: 777
> [...]
> This is the last part of the log, showing when it stop working
>
> [2005/8/13 23:22:26] [2853] WARNING: in file '/var/argus/config' on 
> line 31
> - additional data not permitted here (ignored)

you cannot put 'data' (parameter: value) after the 'Resolv'. move
the chmod_control line before the Resolv line.

your config should be in an order similar to:

     data
     Method, Resolv, DARP
     Group, Service

---

From: "Carlos Alperin" <[email-masked]>
Date: Mon, 15 Aug 2005 17:21:09 -0400

Jeff,

Thanks for your answer, I moved the chmod_control as you asked, but still I
get Error 500 Internal Server Error on the web page.

Any idea?

Thanks again,

Carlos Alperin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Jeff Weisberg
Sent: Monday, August 15, 2005 2:10 PM
To: Discussion about Argus
Subject: Re: full working example

     data
     Method, Resolv, DARP
     Group, Service

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: "Carlos Alperin" <[email-masked]>
Date: Mon, 15 Aug 2005 17:37:37 -0400

This is what show up on the httpd, error_log		

[Mon Aug 15 16:55:52 2005] [notice] Apache/2.0.54 (Fedora) configured --
resuming normal operations
[Mon Aug 15 17:14:29 2005] [error] [client 192.168.1.9] attempt to invoke
directory as script: /var/www/cgi-bin/
[Mon Aug 15 17:14:37 2005] [error] [client 192.168.1.9] ERROR: could not
connect to argusd on unix socket '/var/argus
/control': Permission denied
[Mon Aug 15 17:14:37 2005] [error] [client 192.168.1.9] ERROR: could not
connect to argusd on unix socket '/var/argus
/control': Permission denied
[Mon Aug 15 17:14:37 2005] [error] [client 192.168.1.9] cannot tie auth
'/var/argus/auth': Permission denied
[Mon Aug 15 17:14:37 2005] [error] [client 192.168.1.9] Premature end of
script headers: arguscgi
[Mon Aug 15 17:18:21 2005] [error] [client 192.168.1.9] ERROR: could not
connect to argusd on unix socket '/var/argus
/control': Permission denied
[Mon Aug 15 17:18:21 2005] [error] [client 192.168.1.9] ERROR: could not
connect to argusd on unix socket '/var/argus
/control': Permission denied
[Mon Aug 15 17:18:21 2005] [error] [client 192.168.1.9] cannot tie auth
'/var/argus/auth': Permission denied
[Mon Aug 15 17:18:21 2005] [error] [client 192.168.1.9] Premature end of
script headers: arguscgi
[root@Fedora httpd]#

This is the access_log

192.168.1.9 - - [15/Aug/2005:17:14:29 -0400] "GET /cgi-bin HTTP/1.1" 301 346
"-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR
2.0.50215)"
192.168.1.9 - - [15/Aug/2005:17:14:29 -0400] "GET /cgi-bin/ HTTP/1.1" 403
326 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR
2.0.50215)"
192.168.1.9 - - [15/Aug/2005:17:14:36 -0400] "GET /cgi-bin/arguscgi
HTTP/1.1" 500 658 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1;
SV1; .NET CLR 2.0.50215)"
192.168.1.9 - - [15/Aug/2005:17:18:20 -0400] "GET /cgi-bin/arguscgi
HTTP/1.1" 500 658 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1;
SV1; .NET CLR 2.0.50215)"
[root@Fedora httpd]#

And this is the log on /var/argus

[2005/8/14 20:41:09] [2645] successful restart - Argus running
[2005/8/15 16:53:24] [2645] child caught signal SIGTERM - exiting
[2005/8/15 16:53:24] [2644] parent caught signal SIGTERM - exiting
[2005/8/15 17:14:19] [2986] successful restart - Argus running
[2005/8/15 17:18:08] [2986] shutting down - rc.argusd stop
[2005/8/15 17:18:08] [2986] child caught signal SIGTERM - exiting
[2005/8/15 17:18:08] [2985] parent caught signal SIGTERM - exiting
[2005/8/15 17:18:15] [3081] successful restart - Argus running

It looks like there is a problem with permissions, even when argus says that
everything looks fine.

Seems to be a problem with Apache, more than Argus itself.

-----Original Message-----

     data
     Method, Resolv, DARP
     Group, Service