Subject: Argus / Qmail / Sprint - Return-Path set incorrectly

From: Scott Hiemstra <[email-masked]>
Date: Fri, 13 Jul 2012 13:28:37 -0000

This may be a qmail question and not an Argus question but I know many of you are talented in the ways of both.  I just started having an issue last night where Sprint has started rejecting SMS (via email) messages sent from Argus.  The rejection is stating sender was rejected.

2012-07-13 09:06:10.605155500 delivery 1745: failure: Connected_to_198.101.198.88_but_sender_was_rejected./Remote_host_said:_550_5.1.0_<[email-masked]>_sender_rejected/

Fair enough, I would reject a message coming from [email-masked] as well so I understand the rejection.  The problem is, I am setting my from address to a valid address using the mail_from Argus directive and I have verified this works by looking at the message headers but I am seeing the anonymous address set in the Return-Path even though the from is set correctly.

Any recommendations,
Scott

--
Scott Hiemstra
H2
1817 East Carson Street
Pittsburgh, PA 15203
www.h2.com
E-mail: [email-masked]

Phone:  412.481.2055
Fax:    412.481.2705

---

From: Jeremy Kister <[email-masked]>
Date: Mon, 03 Sep 2012 04:45:09 -0400

> Fair enough, I would reject a message coming from [email-masked] as well so I understand the rejection.  The problem is, I am setting my from address to a valid address using the mail_from Argus di…

Looks like this message has been delayed for quite some time - but, for 
the archives:

just make your own notify method:

Method "mail" {
     command: /usr/sbin/sendmail -f %F -t
     send:    To: %R\nFrom: %F\nSubject: Argus%E\n\n%M
     nolotsmsgs:  yes
     qtime:   0
}

the above method is rather MTA agnostic, but vanilla qmail-1.03's 
"sendmail" doesnt support the -f flag.  use netqmail 1.05 or the 
sendmail-flagf.patch