Subject: how to use crypt for your users file

From: "Jonathan Carpenter" <[email-masked]>
Date: Fri, 12 Dec 2008 22:25:55 -0600

How can you use crypt for your users file? Is there a perl script that I can
use to generate an encrypted version of my own password?

Thanks,

---

From: Andrew D Kirch <[email-masked]>
Date: Sat, 13 Dec 2008 00:30:51 -0500

I usually cheat, set it as a bogus user's password and copy it out of
/etc/shadow.

Andrew

Jonathan Carpenter wrote:
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist
>

---

From: Jeremy Kister <[email-masked]>
Date: Sat, 13 Dec 2008 12:08:00 -0500

> use to generate an encrypted version of my own password?

there's a script inside the contrib directory that comes with argus that's 
called mkpasswd.  it'll help you out.

 > ./mkpasswd foo
HclGZLlEdATyU

-- 

Jeremy Kister
http://jeremy.kister.net./