Subject: notification period

From: "Marquis Thibodeau" <[email-masked]>
Date: Tue, 4 Aug 2009 00:27:14 -0400

Hi,

Is there a way to specify a time range for the notification to be send.?

Thanks

---

From: <[email-masked]>
Date: Mon, 17 Aug 2009 12:19:15 +0200

We have the same problem in our organisation. (On-call technicians only work from 07-22)

We have solved the problem by creating a small external application for queing and dispatching notifications. Argus is configured to call the external application by a cli-call to a thin front which calls a daemon over RPC and queues the message to a given target. Messages are then delivered only during certain time-ranges.

Today smartsms.com and email is supported as delivery mechanisms.
The systems also features a method of "resolvers", which can perform routing-functions, such as ldap lookup or on-call-schedule resolution. For example,  "email:ldap(joe)" sends the message over email to joe, as resolved from his ldap-record.

Resolvers and delivery-mechanisms are added as pluggable modules, implemented in Ruby. There is a plugin for resolving on-call schedules, by looking up a MySQL-db. There is also a small external web-app for viewing and editing the MySQL schedule-db.

If there is interest in this, I may be able to convince my employer to releaser this under a suitable open-source license, but without any form of support. If so, please contact me.

Regards
/ Ulrik

> -----Original Message-----
> From: [email-masked] [mailto:arguslist-
> [email-masked]] On Behalf Of Marquis Thibodeau
> Sent: den 4 augusti 2009 06:27
> To: [email-masked]
> Subject: notification period
> 
> Hi,
> 
> 
> 
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist