Subject: Re: multiple emails [Was: Argus?]

From: Jeff Weisberg <[email-masked]>
Date: Fri, 19 May 2006 13:34:32 -0400 (EDT)

| Subject: Re: Argus?

since this is an argus mailing list, it is assumed
that the message will be regarding argus. so, a subject
of "argus" isn't very useful. perhaps there is a better
subject?

| I am running argus on two different box with the same config file.
|
| One box is sending 3 E-mails out when a host changes state and an
| other box is sending one E-mail out.
|
| It happens to be the box in Production that is sending 3 E-mails out
| and i have not been able to get fix it.
|
| Any suggestions?
|
| Below is a sample of my config file:

this config does not contain any 'notify' parameters, and therefore
will not send any emails at all.

either you are not getting any emails at all, or this
is not your entire config file.

hint: there is nothing in the config file you sent
which will cause argus to send 3 emails. the problem
is somewhere else.

hint 2: if 2 boxes do something different, then the reason
they do something different will be due to something which
is different between the 2 boxes.

your job as troubleshooter, is now to figure out what is
different between your 2 boxes.

if they are using the same argus config file, (not different)
then you can rule that out.

if your sendmail config different on the 2 boxes?
what do you see in your sendmail logs?
what do you see in your argus logs?

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Sun, 21 May 2006 14:43:26 -0400

> what do you see in your argus logs?

Another possible reason may be that there are multiple instance of Argus
running.  I had that problem here a few times and tracked it down to
having one copy running as root and another as a user..  Fixed that up
and poof, no more multiple emails.  :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."