Subject: Host name resolution problem

From: "John Mire" <[email-masked]>
Date: Sat, 28 Feb 2004 12:59:58 -0600

I'm running v3.2.1 on FreeBSD 5.1-RELEASE-p13 with perl-5.6.1_15 and
apache-2.0.48_3.
Everything works well with the exception of using FQDN in the configuration
i.e.,
This is what I originally configured:
	Host "SH-ACIUS" {
		hostname:	acius.lsuhsc-s.edu
		Service Ping
	}
But end up having to use:
	Host "SH-ACIUS" {
		hostname:	10.1.200.9
		Service Ping
	}

I have:
1.	Placed an entry in etc/hosts
2.	ensured that there is an entry in the primary DNS zone with PTR

Can ping from the system with name resolution i.e.:
%ping -c 3 acius.lsuhsc-s.edu
PING acius.lsuhsc-s.edu (10.1.200.9): 56 data bytes
64 bytes from 10.1.200.9: icmp_seq=0 ttl=126 time=1.194 ms
64 bytes from 10.1.200.9: icmp_seq=1 ttl=126 time=1.119 ms
64 bytes from 10.1.200.9: icmp_seq=4 ttl=126 time=1.125 ms

--- acius.lsuhsc-s.edu ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.119/1.157/1.194/0.030 ms

The error log shows:
[2004/2/27 16:04:35] [52739] successful restart - Argus running
[2004/2/27 16:04:34] [52739] ERROR: in file 'cfg/050_servers.cfg' on line 362 -
cannot resolve host acius.lsuhsc-s.edu

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 1 Mar 2004 12:27:37 -0500 (EST)

| I'm running v3.2.1 on FreeBSD 5.1-RELEASE-p13 with perl-5.6.1_15 and
| apache-2.0.48_3.
| Everything works well with the exception of using FQDN in the configuration
| i.e.,
| This is what I originally configured:
| 	  Host "SH-ACIUS" {
| 		  hostname:       acius.lsuhsc-s.edu
| 		  Service Ping
| 	  }
| But end up having to use:
| 	  Host "SH-ACIUS" {
| 		  hostname:       10.1.200.9
| 		  Service Ping
| 	  }
| 
| I have:
| 1.      Placed an entry in etc/hosts
| 2.      ensured that there is an entry in the primary DNS zone with PTR

is it only this one hostname that isn't working or is it
all hostnames that don;t work?

argus 3.2.1 uses the standard gethostbyname function to do lookups,
so I can't imagine what could be wrong.

	--jeff

---

From: "Mire, John" <[email-masked]>
Date: Wed, 3 Mar 2004 13:03:39 -0600

>so I can't imagine what could be wrong.

 None of the hostnames in the configs work.  
 I am not a Perl programmer, but I do write quite a few Csh and Bourne shell
scripts 
 and they resolve names fine for my sysadm chores.  FreeBSD ships with perl
5.005 and
 I use the perl port for 5.6.1_15.
 Do you know of a way I could test if the all of the perl 5.6.1
libaries/routines get set in
 the path?

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 3 Mar 2004 14:30:56 -0500 (EST)

| >argus 3.2.1 uses the standard gethostbyname function to do lookups,
| >so I can't imagine what could be wrong.
| 
|  None of the hostnames in the configs work.  
|  I am not a Perl programmer, but I do write quite a few Csh and Bourne shell
| scripts 
|  and they resolve names fine for my sysadm chores.  FreeBSD ships with perl
| 5.005 and
|  I use the perl port for 5.6.1_15.
|  Do you know of a way I could test if the all of the perl 5.6.1
| libaries/routines get set in
|  the path?

I can imagine what could be wrong.

you probably have Socket6 (a version more recent than 0.10)
installed:
	perl -MSocket6 -e 'print "yep\n"'

there is an incompatibility btwn argus 3.2.1 and newer
versions of Socket6.

either:
	- upgrade argus
	- remove Socket6
	- delete the Socket6 line in argus's 'misc.pl'

	--jeff