Subject: DARP Problems?

From: Andy <[email-masked]>
Date: Mon, 15 Dec 2008 10:43:58 +0000

I'm just trying to test DARP mode in a very simple setup, and I am getting
the following error in the logs

"master machine error"  WARNING: in file '/var/argus/config' on line 15 -
additional data not permitted here (ignored)

"slave machine error" WARNING: in file '/var/argus/config' on line 13 -
additional data not permitted here (ignored)

No firewall between the two machines, no iptables rules either, configs
included below just in case I'm missing something blindingly obvious?

Is DARP mode still only available when you purchase support?

Master config

icon:           /arguscss/smile.gif
icon_down:      /arguscss/sadred.gif
style_sheet:    /arguscss/argus.css
javascript:     /arguscss/argus.js

Method "isg_mail" {
        command:        sendmail -t
        send: From: [email-masked]\nTo: [email-masked] \nSubject:
Argus %O %S\n \n%M %T %C \n\n\n
        }

darp_mode: failover

DARP "master1" {

        slave "slave1" {
                hostname: 192.168.3.56
                secret: testing
        }
}

Group "Darp Slaves" {
        Service DARP/WATCH/slave1
}

  Group "Argus" {
        graph: yes
        Service Self/idle {
            title:  Percent Idle
            calc:   ave-rate
            scale:  0.01
            # let someone know when it is time to upgrade h/w
            minvalue:  20
            messagedn: time to buy faster server
        }

        Service Self/tested {
            title:  Monitoring Rate
            ylabel: tests per second
            calc:   ave-rate
        }

        Service Prog {
            # how much memory is argus using?
            # your ps may be different
            command:        ps -p $ARGUS_PID -o vsz | tail -1
            uname:          VSZ
            title:          Memory Use
            ylabel:         kBytes
        }
   }

Group   "Special Monitor" {
        notify: isg_mail:
        renotify:       1200
        overridable:    yes
        messagedn:      %i %r %s %t %o
        Include "/var/argus/special"
}

output of argusctl status on master

ARGUS/2.0 200 OK
status:    running
version:   3.5
perlver:   118.53.46.49.48.46.48
osinfo:    Linux 2.6.25.16-0.1-pae i686
darpmode:  master
objects:   56
services:  28
notifies:  2
uptime:    0:01:42
idle:      99.21%
monrate:   0.44 tests per second

Slave config

icon:           /arguscss/smile.gif
icon_down:      /arguscss/sadred.gif
style_sheet:    /arguscss/argus.css
javascript:     /arguscss/argus.js

Method "isg_mail" {
        command:        sendmail -t
        send: From: [email-masked]\nTo: [email-masked] \nSubject:
Argus %O %S\n \n%M %T %C \n\n\n
        }

darp_mode:      failover

DARP "slave1" {

        master "master1" {
                hostname:       192.168.3.50
                secret:         testing
        }
}

output of argusctl status on slave

ARGUS/2.0 200 OK
status:    running
version:   3.5
perlver:   118.53.46.49.48.46.48
osinfo:    Linux 2.6.25.18-0.2-pae i686
darpmode:  slave
objects:   2
services:  1
notifies:  0
uptime:    0:02:10
idle:      99.90%
monrate:   0.01 tests per second

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 15 Dec 2008 10:54:12 -0500

> Argus %O %S\n \n%M %T %C \n\n\n

this line needs to be moved above the Method block.
otherwise, it will be ignored and you will get a warning.

> output of argusctl status on master

this means that darp is working.
for more details, you can:

% argusctl darp_status

ARGUS/2.0 200 OK
master0:        DARP:up
slave1: 	Slave:up