Subject: sendnotify vs sendnotify2

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 20 Sep 2004 01:57:12 -0400

I'm confused about why I was not send a notification when Argus detected a
particular service down.

I can assume the problem is related to what sendnotify2 can do, that
sendnotify can not.
docs say sendnotify is for objects, and sendnotify2 is for services.  in the
end, arent services objects ?

the following config did not send a notify when the SNMP service failed.
Group "Upstream" {
   sendnotify: no
   [...]
   Group "Sprint OC3" {
      [...]
      Service UDP/SNMP {
         sendnotify: yes
         overridable:    no
         hostname:   man-core-12000-01
         label:      BGP
         minvalue:   6
         oid:     .1.3.6.1.2.1.15.3.1.2.10.0.0.1
      }
   }
}

would 'sendnotify2: yes' have worked instead of 'sendnotify: yes' ?

Jeremy Kister
http://jeremy.kister.net/

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 20 Sep 2004 12:17:00 -0400 (EDT)

| I'm confused about why I was not send a notification when Argus detected a
| particular service down.
| 
| I can assume the problem is related to what sendnotify2 can do, that
| sendnotify can not.

not from what I see.

| docs say sendnotify is for objects, and sendnotify2 is for services.  in the
| end, arent services objects ?

yes. services are objects.
'sendnotify' applies to all objects and is not inherited,
'sendnotify2' applies only to services and is inherited.

you can safely ignore 'sendnotify2'.

| the following config did not send a notify when the SNMP service failed.
| Group "Upstream" {
|    sendnotify: no
|    [...]
|    Group "Sprint OC3" {
| 	[...]
| 	Service UDP/SNMP {
| 	   sendnotify: yes
| 	   overridable:    no
| 	   hostname:   man-core-12000-01
| 	   label:      BGP
| 	   minvalue:   6
| 	   oid:     .1.3.6.1.2.1.15.3.1.2.10.0.0.1
| 	}
|    }
| }
| 
| would 'sendnotify2: yes' have worked instead of 'sendnotify: yes' ?

it would not have changed anything.
unless there is something fishy somewhere else you have
notifications enabled on the service.

you have 'overridable: no' on the service, is it possible that
a co-worker put an override on the 'Sprint OC3' or 'Upstream'
groups?

	--jeff

---

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 20 Sep 2004 14:04:06 -0400

> notifications enabled on the service.

you're right.  upon looking at the ntfydetail, i see a page was sent, for
both up and down.
the problem clearly exists in some other configuration on my part.  sorry
for the noise.

Jeremy Kister