Subject: SNMP Gauge32

From: Mark <[email-masked]>
Date: Wed, 14 Sep 2011 08:30:51 -0700 (PDT)

I'm having trouble getting correct results from SNMP queries sending back Gauge32 values. With snmpwalk I get the following:

snmpwalk -v2c -c public nasusb1 .1.3.6.1.2.1.25.1.6 
HOST-RESOURCES-MIB::hrSystemProcesses.0 = Gauge32: 77

So, the number of processes on nasusb1 is 77. However, Argus graph shows this value as 0. Debugging shows:

srvc::result_valid	1
srvc::retries	2
srvc::showreason	0
srvc::showresult	0
srvc::starts	16
srvc::state	done
srvc::status	up

My config is:

Service UDP/SNMP {
community:	public
debug:	yes
drawgrid:	yes
graph:	yes
label:	processes
maxvalue:	200
oid:	.1.3.6.1.2.1.25.1.6
}

Debug log shows:

Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [] Service start 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] UDP Start: connecting - udp/161, nasusb1, try 1 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] binding to port 24274 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] UDP sent data 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] SNMP recv data 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] SNMP result found: 1.3.6.1.2.1.25.1.6 => 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] SNMP recv - raw value 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] SNMP TEST value 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] SNMP TEST result 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [6] Service - UP 
Sep 14 10:23:59 admin Argus[8141]: DEBUG - Top:Servers:nasusb1:cpu:SNMP_.1.3.6.1.2.1.25.1.6_nasusb1 - [] Service done 

So, it appears that Argus simply fails to process correctly SMNP response, since "result found" is blank instead of 77.

Any suggestions?

Artur

---

From: jeff weisberg <[email-masked]>
Date: Wed, 14 Sep 2011 12:44:12 -0400

On 14 Sep 2011, at 11:30, Mark wrote:

> I'm having trouble getting correct results from SNMP queries sending  
> back Gauge32 values. With snmpwalk I get the following:
>
                                         ^
                                         |

snmpwalk started at the oid you gave on the command line,
and returned data for all of the oids that follow it.

oid ".1.3.6.1.2.1.25.1.6.0" has a value of 77
oid ".1.3.6.1.2.1.25.1.6"   does not have a value, and is not  
displayed by snmpwalk.