Subject: "check_now" link, statistics?

From: yary <[email-masked]>
Date: Mon, 19 May 2008 13:04:22 -0700

After setting up the config file with a must-fail test:

Group "must fail" {
 Service Prog {
  command: fail
  expect: OK-Wonderful
 }
}

I ran argusctl hup, and saw "must fail" come up "green" (since it hadn't run
yet). I clicked down to the Service Prog object and then clicked
"check_now". It refreshed, but still came back green. Is "check_now"
supposed to force the argus daemon to recheck the service, or just reload
the page?

A few minutes later, the page did refresh itself and come up "red".

Also the statistics seem to be incorrect, after it ran the test and came up
red it says 100% up, 0% down, and no times run. And in fact none of my
regular, non-test entries show the total number of times run, they are
always blank. This is with argus 3.5 downloaded from tcp4me just this
weekend. Here's what the "must fail" Prog status page shows:

nameProg statusdown commandfail
------------------------------
*Status: down since Mon 19 May 13:12:03 2008*
 startelapsed time% up% downtimes down Today   Mon 19 May 13:11:42
20080:00:21
100.0  0.00 1 This Month   Mon 19 May 13:11:42 2008 0:00:21   100.0
0.00 1 This
Year   Mon 19 May 13:11:42 2008 0:00:21   100.0  0.00 1
... and now:

*Status: down since Mon 19 May 13:12:03 2008*
 startelapsed time% up% downtimes down Today   Mon 19 May 13:06:50
20080:09:32
54.55  45.45 1 This Month   Mon 19 May 13:06:50 2008 0:09:32   54.55
45.451 This
Year   Mon 19 May 13:06:50 2008 0:09:32   54.55  45.45 1
how could it ever have been up? That statistic should say 0% up, 100% down.

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 19 May 2008 20:33:23 -0400 (EDT)

| I ran argusctl hup, and saw "must fail" come up "green" (since it hadn't run
| yet). I clicked down to the Service Prog object and then clicked
| "check_now". It refreshed, but still came back green. Is "check_now"
| supposed to force the argus daemon to recheck the service, or just reload
| the page?

it causes argus to retest the service (once).

depending on the value of the 'retries' parameter,
one failed test may not be enough for argus to declare
the service down.

| Also the statistics seem to be incorrect, after it ran the test and came up
| red it says 100% up, 0% down,

argus does not update these numbers each time the web page
reloads, only when something "interesting" happens.

the most recent "interesting" thing was when it went down,
up to which point it had been up for 100% of the time.

| and no times run. And in fact none of my
| regular, non-test entries show the total number of times run, they are
| always blank.

argus does not keep track of, or report on, the number of times a test runs.