Subject: Downtime reports with argus

From: jay alvarez <[email-masked]>
Date: Mon, 20 Feb 2006 20:04:00 -0800 (PST)

Hi,

Currently we have a nagios-running server used for
monitoring the health of our network services as well
as hosts through check_ping. I haven't played with
nagios reports though, as I am only concerned about
the alert from nagios. We use mrtg for monitoring the
network traffic trend. Before, we are using a custom
script to parse these mrtg logs and output it into a
report like this:

Link Description: link1
Overall Downtime: 16.68 hour/s

Time Down   Time Up    Total     Reference No.

Mon Aug 29 15:03:08 PHT 2005    Mon Aug 29 15:13:11
PHT 2005    0.17 hours      9399
Fri Aug 26 02:03:08 PHT 2005    Fri Aug 26 17:43:12
PHT 2005    15.67 hours     9297
Wed Aug 24 17:43:09 PHT 2005    Wed Aug 24 18:23:09
PHT 2005    0.67 hours      9273
Fri Aug 19 07:22:43 PHT 2005    Fri Aug 19 07:32:44
PHT 2005    0.17 hours      9086

Hours Down: 16.68
Days Down: 0
Monthly Total in Hours: 16.68

We need these reports so that we can compute in case
the customer asks for some rebates, with their
bandwidth usage.

Now the one who created the program went away and when
something went wrong, we weren't able to fix it. Now,
we are just looking for opensource tools that can do
the same. Note, that since the program uses mrtg, mrtg
uses snmp to monitor if the link is down for a certain
period of time. Most of the devices on remote sites of
our customers are snmp-enabled... Someone suggested
using argus.

Can I use argus to produce reports that look exactly
like that above?

Thanks!
-jay

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Scott Hiemstra" <[email-masked]>
Date: Mon, 20 Feb 2006 23:41:54 -0500

> Currently we have a nagios-running server used for monitoring 
> the health of our network services as well as hosts through 
> check_ping. I haven't played with nagios reports though, as I 
> am only concerned about the alert from nagios. We use mrtg 
> for monitoring the network traffic trend. Before, we are 
> using a custom script to parse these mrtg logs and output it 
> into a report like this:
> 
> Link Description: link1

Argus by default will give you something like this:

Top:World_Reachability:Major_Web_Sites:Ping_www.google.com User: scotth  
 
name Ping 
status up 

Status: up since Mon 9 Jan 02:52:51 2006
  start elapsed time % up % down times down 
Today    Mon 20 Feb 00:00:00 2006 23:00:00    100.0   0.00 0 
Yesterday    Sun 19 Feb 00:00:00 2006 1d 0:00:00    100.0   0.00 0 
2 Days Ago    Sat 18 Feb 00:00:00 2006 1d 0:00:00    100.0   0.00 0 
This Month    Wed 1 Feb 00:00:00 2006 19d 22:59:58    100.0   0.00 0 
Last Month    Sun 1 Jan 00:00:00 2006 30d 23:58:54    99.87   0.13 1 
2 Months Ago    Thu 1 Dec 00:00:00 2005 1m 0:00:00    100.0   0.00 0 
This Year    Sun 1 Jan 00:00:00 2006 1m 19d 22:58:52    99.92   0.08 1 
Last Year    Sat 1 Jan 00:00:00 2005 11m 29d 13:05:14    99.68   0.32 9 
2 Years Ago    Thu 4 Nov 21:23:11 2004 1m 26d 1:07:37    100.0   0.00 0 

> We need these reports so that we can compute in case the 
> customer asks for some rebates, with their bandwidth usage.
> 
> something went wrong, we weren't able to fix it. Now, we are 
> just looking for opensource tools that can do the same. Note, 
> that since the program uses mrtg, mrtg uses snmp to monitor 
> if the link is down for a certain period of time. Most of the 
> devices on remote sites of our customers are snmp-enabled... 
> Someone suggested using argus.
> 
> Can I use argus to produce reports that look exactly like that above?
> 
> 

Dunno how much customization you can do but others may be able to shed more
light on it.

Scott