Subject: timeout, frequency, and retries are not working properly for ping service

From: "Rionel.J Jeudy" <[email-masked]>
Date: Thu, 8 Jun 2006 10:31:57 -0400

Based on my config could someone tells me why
frequency, retries, and timeout are not working?
I am thinking argus should check a down node
for approximately 5 minutes.
I've been getting E-mail ( Up and Down)
every 2 minutes.
I would like to increase the time argus check
before an E-mail is sent to take in account slow traffic,
lost ping and so on...

Sample of my config:

# locations of various items on web pages
sirensong:      /sound/whoopwhoop.wav
bkgimage:       /img/argus.logo.gif
icon:           /img/smile.gif
icon_down:      /img/sad.gif
nospkr_icon:    /img/nospkr.gif
style_sheet:    /argus.css

# send messages to syslog
syslog:         daemon

# who should be notified when things break?
#notify:                mail:[email-masked]
notify:                        mail:[email-masked]

# don't summarize notifications
nolotsmsgs:     yes

# enable built in tcp test port
test_port:      3075

# enable built in resolver
Resolv

######################################################################################
#####
#####                                MAIL FORMAT
######################################################################################

 Method "mail" {
              command:        sendmail -t
              send:           To: %R\nFrom:%F\nSubject: %O{note} is %S\n\%M\n
             }

######################################################################################
Group "Terminal Servers" {
frequency: 60
retries: 5
timeout: 30
renotify: 86400

 Host "term01 10.205.1.228 UNITED STATES" {
 label: term01 10.205.1.228 UNITED STATES
  hostname: 10.205.1.228
 note: term01
 service Ping
 }

 Host "term01 10.205.1.229 UNITED STATES" {
 label: term02 10.205.1.229 UNITED STATES
  hostname: 10.205.1.229
 note: term02
 service Ping
}
}

---

From: [email-masked]
Date: Thu, 8 Jun 2006 08:36:21 -0700

You probably also want to set retrydelay.  I'm not sure what the default
is, but apparently the default is lower than you are expecting.  I believe
that the frequency setting does not come into play when doing retries, only
for initial tests.

...Matt Cleveland
...Web Architect
...Health Net Inc
...916.935.1248
[email-masked]

* There's no place like 127.0.0.1

             "Rionel.J Jeudy"                                              
             <[email-masked]                                             
             m>                                                         To 
             Sent by:                  Discussion about Argus              
             arguslist-bounces         <[email-masked]>              
             @tcp4me.com                                                cc 
                                                                           
                                                                   Subject 
             06/08/2006 07:31          timeout, frequency, and retries are 
             AM                        not working properly for ping       
                                       service                             
                                                                           
             Please respond to                                             
             Discussion about                                              
                   Argus                                                   
             <arguslist@tcp4me                                             
                   .com>                                                   

Sample of my config:

#####
#####                                MAIL FORMAT

 Method "mail" {
              command:        sendmail -t
              send:           To: %R\nFrom:%F\nSubject: %O{note} is
%S\n\%M\n
             }

 Host "term01 10.205.1.229 UNITED STATES" {
 label: term02 10.205.1.229 UNITED STATES
  hostname: 10.205.1.229
 note: term02
 service Ping
}
}
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

This  message,together  with  any  attachments, is
intended only for the use of the individual or entity
to which it is addressed. It may contain information
that is confidential and prohibited from disclosure.
If you are not the intended recipient, you are hereby
notified that  any dissemination  or copying of this
message or any attachment is strictly prohibited. If
you have received this message in error, please notify
the  original  sender immediately by telephone or by
return e-mail and delete this message, along with any
attachments, from your computer.  Thank you.