Subject: Re: expect parameter

From: Jeff Weisberg <[email-masked]>
Date: Fri, 15 Oct 2004 16:04:44 -0400 (EDT)

|     Just a quick question...  Does the expect parameter use a full regex
| expression?  I'm trying to monitor the replication status on my MySQL

it is a full perl regular expression.

| server and I want to ensure that Slave_IO_Running and Slave_SQL_Running
| are both Yes.  I believe I can do this by checking for the string "|
| Yes        | Yes" in the return of "show slave status;" ...  I just need
| to figure out how to get that into Argus :)  I was thinking something
| along the lines of  | Yes/s+| Yes   ...  Maybe?

you probably mean \s not /s

and you would need to say \| since | is special

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 15 Oct 2004 16:56:44 -0400

>and you would need to say \| since | is special
So, this then?  :

\| Yes\s+\| Yes

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 15 Oct 2004 21:40:05 -0400

>and you would need to say \| since | is special
Is there any way to debug this?  The expect expression I'm using isn't 
working and I'm not sure yet why ...

>	--jeff
Thanks!