Subject: Built-in resolver hides DNS errors

From: yary <[email-masked]>
Date: Mon, 19 May 2008 12:47:32 -0700

I was trying to test out notification by putting in the config file a
group I knew would fail:

Host "Fail.notopdomain.xyz" {
  Service Ping
}

... and yet, Fail.notopdomain.xyz always came up "green", regardless
of the services I tried.

After commenting out the built-in resolver "Resolv", Argus
appropriately complains "Errors detected during startup", and
highlights the error log.

The built-in resolver should also complain if it can't resolve a hostname!

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 19 May 2008 20:32:04 -0400 (EDT)

| I was trying to test out notification by putting in the config file a
| group I knew would fail:
| 
| Host "Fail.notopdomain.xyz" {
|   Service Ping
| }
| 
| ... and yet, Fail.notopdomain.xyz always came up "green", regardless
| of the services I tried.
| 
| After commenting out the built-in resolver "Resolv", Argus
| appropriately complains "Errors detected during startup", and
| highlights the error log.
| 
| The built-in resolver should also complain if it can't resolve a hostname!

it does.

if you do not use 'Resolv', the dns error will be reported right away;
if you do use 'Resolv', the error will be reported sometime later.