Subject: Argus Problem

From: "piresg" <[email-masked]>
Date: Wed, 31 Dec 2003 09:56:45 -0000

Hi There,

I've instaled argus but i a got a problem when i'm trying to access him.

When i go to http:\\localhost\cgi-bin\arguscgi

I put my user and pass that i've already creat in users file and i enter in the main site but i get the next message

------------------------------------------
Warning     
Unable to contact server - using cached data - please investigate
Cached: Wed 31 Dec 09:36:31 2003

Examine the Error Log for details
Warning     
Errors detected during startup
Attempting to run anyway
Examine the Error Log for details
--------------------------------------------

The error log is empty and i've got my daemon (argusd) running.

This situation happen when i'm login for the 2nd time.

Can you help me out

Thanks in advance,
Gonçalo Pires

---

From: "Jeremy Kister" <[email-masked]>
Date: Wed, 31 Dec 2003 05:19:12 -0500

> The error log is empty and i've got my daemon (argusd) running.

If argus is still starting up, it may not be able to show you the error log
via the web cgi.

try tailing the "log" file (located where you configured argus's data dir)
# tail /home/software/argus/log

look for "successful restart - Argus running" after all references of
"shutting down" or "child caught signal SIGHUP".  hints as to what the
problem is could be in the log file, too.

also, how much CPU is argusd using ? (the top program can help answer)

> This situation happen when i'm login for the 2nd time.

so when you log in with no other users logged in, all is fine?  starting
with no logged in users, what if you log in, log out, and log in again?

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 31 Dec 2003 10:28:04 -0500 (EST)

| The error log is empty and i've got my daemon (argusd) running.

if the error log is empty, then argusd is not running.

if argusd was running the error log would say:
	'successful restart - Argus running'

how did you try to start argusd?
did it complain?
why do you think it is running?

if argusd is running (and the log says so), and you are
seeing:

|   Warning     
|   Unable to contact server - using cached data - please investigate
|   Cached: Wed 31 Dec 09:36:31 2003
|   
|   Examine the Error Log for details
|   Warning     
|   Errors detected during startup
|   Attempting to run anyway
|   Examine the Error Log for details

then you need check your web server error_log for additional
details on why it cannot connect. 

	--jeff