Subject: Argus Init file for Redhat

From: Fire Eater <[email-masked]>
Date: Fri, 05 Nov 2004 04:52:55 -0700

Maybe this will help someone. I use it on RHEL3 but I assume it will
work on all Redhat variants.

#!/bin/sh
#
# Argusd init script
#
# chkconfig: 2345 99 10
# description: starts, stops, restarts, and reloads config 
# probe: true
# Provides: $argusd
#

case "$1" in
    
	start)
        /usr/local/sbin/argusd -a /var/argus
        echo "Argus Monitor Started !"
        #/usr/local/sbin/argusd -u apache -g apache
        ;;

	stop)
        /usr/local/sbin/argusctl shutdown reason="rc.argusd stop"
        echo "Argus Monitor Shutdown !"
        ;;

        restart)
        /usr/local/sbin/argusctl shutdown reason="rc.argusd stop"
        /usr/local/sbin/argusd -a /var/argus
        echo "Argus Monitor Restarted !"
        ;;

        reload)
        /usr/local/sbin/argusctl hup
        echo "Argus Monitor Reloaded !"
        ;;

    *)
        echo usage: $0 'start|stop|restart|reload'
        exit 1
        ;;

esac
exit 0

### set file ownership, permissions and enable service at boot###
#chown root /etc/rc.d/init.d/argusd; chmod 744 /etc/rc.d/init.d/argusd;
chkconfig argusd on

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Mon, 08 Nov 2004 13:45:36 -0500

>work on all Redhat variants.
This is quite useful, thanks..  :)  Perhaps this can be added to the 
.tar.gz?  :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."