Subject: Javascript

From: Scott Hiemstra <[email-masked]>
Date: Tue, 17 Sep 2013 12:32:04 -0400

We run an ad server which we use to serve out flash, image and text ads for some of our clients; the ads are delivered via a javascript snippet.  I know how to test end to end functionality of a normal PHP/Perl type process using expect but I need to be able to actually execute javascript and then expect something on that page.  Any recommendations on how to actually execute the javascript on a page and read the page output as something I can process through Argus?  I've been looking into running it through links but the javascript support seems to be so minimal that I can't even get it to load the remote ad.

Thanks in advance,
Scott

---

From: Scott Hiemstra <[email-masked]>
Date: Tue, 17 Sep 2013 13:25:33 -0400

Disregard, we figured out to make the adserver deliver a text ad without the javascript wrapper.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Hiemstra
Sent: Tuesday, September 17, 2013 12:32 PM
To: Discussion about Argus ([email-masked])
Subject: Javascript

Thanks in advance,
Scott

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist