Subject: Alert siren in Mozilla...

From: Tom Lisjac <[email-masked]>
Date: Tue, 27 Sep 2005 14:32:14 -0600

I'm sorry if this has been asked before but the link to the full list
archive is broken:

http://www.tcp4me.com/pipermail/arguslist.mbox/arguslist.mbox

Our school district is very happy with Argus! I've set up dual, cross
checking installs and a dedicated monitor in our operations center so
all of our network engineers can see and hear the alerts.

The problem is that we're a Linux shop and the siren only works with
IE. I've tried adding a helper app in Mozilla 1.7 for the audio/wav
type that calls /usr/bin/play... but it never executes.

The audio alarms are *very* useful for us... but I'm not sure I can
accept the idea of IE being used to support our Linux infrastructure!
:o)

Has anyone on the list had this problem? Any suggestions would be
*greatly* appreciated!

Best regards,

-Tom Lisjac

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Tue, 27 Sep 2005 20:45:09 -0400

>all of our network engineers can see and hear the alerts.

Yeah, I agree..  Argus rules..  :)

>type that calls /usr/bin/play... but it never executes.

Hrm..  I didn't have to do that..  ?

>accept the idea of IE being used to support our Linux infrastructure!

Eww... IE in a Linux shop?  Never!

Nice to see a full Linux shop in a school..  :)

>Has anyone on the list had this problem? Any suggestions would be

I *swear* I ran into this..  I'm not sure what I changed, but when I
have an alert, it looks like this in the html :

<OBJECT DATA="/argus/nx01-redalert.wav" TYPE="audio/x-wav" HEIGHT=0></OBJECT>

Yeah.. I changed the sound..  :)  I *think* you need to change it from
audio/wav to audio/x-wav ...  Do that and you should be golden. :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."

---

From: Tom Lisjac <[email-masked]>
Date: Thu, 29 Sep 2005 15:18:01 -0600

On 9/27/05, Jason 'XenoPhage' Frisvold <[email-masked]> wrote:
> Tom Lisjac wrote:
>
> >Our school district is very happy with Argus!

> Nice to see a full Linux shop in a school..  :)

There is still a lot of Redmond on the desktops... but the Penguin
rules our server room! :)

> audio/wav to audio/x-wav ...  Do that and you should be golden. :)

I did have the mime type set as audio/x-wav and I can play the file
with Mozilla if I directly load it with a url. I don't think the
OBJECT DATA tag is being recognized Mozilla 1.7. Looked on Mozilla
site. All I could find were lectures about what a bad idea it is to
use sound on a website... not very useful!

Thanks for the reply, Jason. I'm going to keep pluggin'... can't abide
IE watching my Linux boxes. :)

-Tom

---

From: Paulus Tanudjaja <[email-masked]>
Date: Thu, 13 Oct 2005 10:35:47 +1000

Hi,

I just wanted to know how to unhush the siren in Argus 3.4

Thanks,

Paulus Tanudjaja

Systems Analyst 
Nighthawk Radiology Services
Level 11, Suite 1101
Grosvenor Place
225 George Street
Sydney NSW 2000
Australia
 
T:  612 - 8211 2300
F:  612 - 8211 2333
M:  61  - 405829009
USA Toll free:  866 241 6635
E: [email-masked]
I: www.nighthawkrad.net
 
CONFIDENTIALITY NOTICE:   This email, including any attachments, contains information from Nighthawk Radiology Services, which may be confidential or privileged. The information is intended to be for the use of the individual or entity named above. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this email in error, please notify Nighthawk Radiology Services immediately by forwarding message to [email-masked] and destroy all electronic and hard copies of the communication, including attachments.