Subject: error log - child caught SIGHUP

From: "Drew Thomson" <[email-masked]>
Date: Tue, 13 Dec 2005 23:03:08 +1100

Can someone explain the following errors that are showing up in my log?
 
[2005/12/13 22:10:20] [21644] successful restart - Argus running
[2005/12/13 22:10:35] [21301] config file '/var/argus/config' changed -
restarting
[2005/12/13 22:10:35] [21301] child caught signal SIGHUP - exiting
[2005/12/13 22:10:35] [21647] Cannot bind TestPort to tcp/3074: Address
already in use
[2005/12/13 22:10:35] [21647] successful restart - Argus running

Thanks,
 
Drew

---

From: Jeff Weisberg <[email-masked]>
Date: Tue, 13 Dec 2005 11:28:30 -0500 (EST)

| Can someone explain the following errors that are showing up in my log?
|
 > [2005/12/13 22:10:35] [21647] successful restart - Argus running

at 22:10:35 argus noticed that someone changed your config file,
so it sent itself a signal and restarted with the new config.
this is normal.

it also tried to attach to port 3074, but failed because
the port was in use by something else.

that line 1 and line 2 have different process-ids, and the fact
that your port was already in use, cause me to wonder whether you
might have started argus twice?

---

From: "Drew Thomson" <[email-masked]>
Date: Wed, 14 Dec 2005 06:36:51 +1100

Ah okay so 2 is normal.  That's good!  I will keep an eye on it today and see how it goes.  -drew

No wonder why I was getting so many notify msgs when something went down. Hehe

Thanks guys.  

Regards,
 
Drew Thomson
Network/IT Support
Ace Communications Group Pty Ltd
 
T: 1300 668 562
T: +61 3 9562 1433
F: 1300 304 672
F: +61 3 9562 1466
E: [email-masked]
A: Suite 8, 2 Compark Circuit, Mulgrave VIC 3170 (Mel Ref: 71 A12)
 
NOTICE - This communication contains information which is confidential and the copyright of Ace Communications Group Pty Ltd or a third party. If you are not the intended recipient of this communication please delete and destroy all copies and telephone Ace Communications Group Pty Ltd +61 3 9562 1433 immediately. If you are the intended recipient of this communication you should not copy, disclose or distribute this communication without the prior authority of Ace Communications Group Pty Ltd.

Any views expressed in this communication are those of the individual sender, except where the sender specifically states them to be the views of Ace Communications Group Pty Ltd. Except as required by law, Ace Communications Group Pty Ltd does not represent, warrant and/or guarantee that the integrity of this communication has been maintained nor that the communication is free of errors, virus, interception or interference.

-----Original Message-----
From: [email-masked] <[email-masked]>
To: 'Discussion about Argus' <[email-masked]>
Sent: Wed Dec 14 06:31:40 2005
Subject: RE: error log - child caught SIGHUP

One watches the other.

Chris S
[email-masked]
www.Jynx.net 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Drew Thomson
Sent: Tuesday, December 13, 2005 2:28 PM
To: [email-masked]
Subject: Re: error log - child caught SIGHUP

Yea I just noticed that.  When I run argusd it spawns two threads.  

Any ideas?

Regards,
 
Drew Thomson
Network/IT Support
Ace Communications Group Pty Ltd
 
T: 1300 668 562
T: +61 3 9562 1433
F: 1300 304 672
F: +61 3 9562 1466
E: [email-masked]
A: Suite 8, 2 Compark Circuit, Mulgrave VIC 3170 (Mel Ref: 71 A12)
 
NOTICE - This communication contains information which is confidential and
the copyright of Ace Communications Group Pty Ltd or a third party. If you
are not the intended recipient of this communication please delete and
destroy all copies and telephone Ace Communications Group Pty Ltd +61 3 9562
1433 immediately. If you are the intended recipient of this communication
you should not copy, disclose or distribute this communication without the
prior authority of Ace Communications Group Pty Ltd.

Any views expressed in this communication are those of the individual
sender, except where the sender specifically states them to be the views of
Ace Communications Group Pty Ltd. Except as required by law, Ace
Communications Group Pty Ltd does not represent, warrant and/or guarantee
that the integrity of this communication has been maintained nor that the
communication is free of errors, virus, interception or interference.

-----Original Message-----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>
Sent: Wed Dec 14 03:28:30 2005
Subject: Re: error log - child caught SIGHUP

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist