Subject: monitor free disk space

From: Roger Fishwick <[email-masked]>
Date: Thu, 11 May 2006 16:47:42 +0100

Hi,

I am doing a bit of tidy up on my argus setup, one of the things I have 
intended to change for a while is how I monitor free disk space on a number 
of servers, currently I have a small script that calculates the free space 
and returns a code if there is a problem I make this available via the web 
interface, and call this from argus.

I was wondering if any one had a better solution they would be willing to 
share with me ?

BTW Argus is still the 'best' (most usable,most reliable, most performant) 
of the many monitoring solutions I have used !

Regards,
Roger

-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.1.392 / Virus Database: 268.5.6/336 - Release Date: 10/05/2006

---

From: [email-masked]
Date: Thu, 11 May 2006 08:53:36 -0700

I do system testing such as this via script invoked by SSH.

...Matt Cleveland
...Web Architect
...Health Net Inc
...916.935.1248
[email-masked]

* There's no place like 127.0.0.1

             Roger Fishwick                                                
             <roger@keyslider.                                             
             co.uk>                                                     To 
             Sent by:                  Discussion about Argus              
             arguslist-bounces         <[email-masked]>              
             @tcp4me.com                                                cc 
                                                                           
                                                                   Subject 
             05/11/2006 08:47          monitor free disk space             
             AM                                                            

             Please respond to                                             
             Discussion about                                              
                   Argus                                                   
             <arguslist@tcp4me                                             
                   .com>                                                   

Hi,

Regards,
Roger

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

This  message,together  with  any  attachments, is
intended only for the use of the individual or entity
to which it is addressed. It may contain information
that is confidential and prohibited from disclosure.
If you are not the intended recipient, you are hereby
notified that  any dissemination  or copying of this
message or any attachment is strictly prohibited. If
you have received this message in error, please notify
the  original  sender immediately by telephone or by
return e-mail and delete this message, along with any
attachments, from your computer.  Thank you.

---

From: [email-masked]
Date: 11 May 2006 16:05:14 +0000

On 11 May 2006 16:47:42 +0100,
> I was wondering if any one had a better solution they would be willing to 

Hi!

We are using SNMP for that purpose.

E.g.:

   Service: UDP/SNMP {
      hostname: raman.epigenomics.epi
      community: public
      label: /var space
      comment: /var
      oid: .1.3.6.1.2.1.25.2.3.1.6.10
      maxvalue: 1998016
      messagedn: raman /var space too low - %r %v
      messageup: raman /var space enough again
   }

Greetings
-- 
Robert Sander                     Senior Manager Information Systems
Epigenomics AG    Kleine Praesidentenstr. 1    10178 Berlin, Germany
phone:+49-30-24345-330                          fax:+49-30-24345-555
http://www.epigenomics.com             [email-masked]

---

From: "Alexandru E. Ungur" <[email-masked]>
Date: Thu, 11 May 2006 19:20:58 +0300

>>> sender: "[email-masked]" date: "Thu, May 11, 2006 at 08:53:36AM -0700" <<<EOQ
I used to do that too, but I found it way too CPU expensive.
Probably what I use now it's not the best, but works much better 
then using SSH:

1. On argus config I have:

Service Prog {
    severity: major
    label: Storage
    command: /usr/bin/nc $DOMAINNAME $PORT
    expect: OK
}

2. on the monitored host I have netcat listening for connections:

    monitoring_script.sh | nc -l -p $PORT

running in a 'infinite' cycle. You can achieve the cycle with plain 
old while:

--- beware: untested code ---
    while :; do
        monitoring_script.sh | nc -l -p $PORT
    done &
--- end ---

or better from [x]inetd or daemontools. I do prefer daemontools for
the job, but that's just me, use what you feel comfortable with.

The entire setup works like a charm :)
and saved me from learning SNMP ;)

Good luck!
Alex

---

From: Roger Fishwick <[email-masked]>
Date: Thu, 11 May 2006 17:26:07 +0100

> I do system testing such as this via script invoked by SSH.
I don't know why I did not think of that, I do lots of other non argus 
stuff that way.
That would be a simple change. I think I might have been distracted by 
trying to find something worked simply across linux/unix/and NT...

Thanks,
Roger