Subject: Re: How do I get more descriptive message in the subject line

From: Jeff Weisberg <[email-masked]>
Date: Wed, 30 Jun 2004 13:30:46 -0400 (EDT)

| I'm a tad confused...
| 
| The message{up,dn} fields are put within the object configuration and
| are for the message body, or subject?

the message* field becomes %M in your Method definition.

your Method definition uses %M however and wherever you want.

| And the send field in the Method object, is that the subject or body?

argus knows nothing about "subjects" and "bodies".

argus runs the command you specify (command) and gives it
what you specify (send) over stdin.

how (or if) that becomes subject or body depends on
the command and your config.

the default builtin methods look like:

	Method "mail" {
		command:	sendmail -t
		send:		To: %R\nFrom:%F\nSubject: Argus %E\n\n%M\n
	}

	Method "qpage" {
		command:	qpage %R
		send:		%M%E
	}

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 30 Jun 2004 14:14:17 -0400

> 		send:		To: %R\nFrom:%F\nSubject: Argus %E\n\n%M\n

Perfect.. that's what I was lookin for :)

Can you override the defaults?  ie, can I create a Method called mail
and have it override the existing one?

> 	--jeff
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist
-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."