Subject: Re: Fresh argus install...graphs not working

From: "Jeremy Kister" <[email-masked]>
Date: Sat, 27 Mar 2004 15:57:25 -0500

On Friday, March 26, 2004 10:22 PM, Scott Hiemstra wrote:
> picasso: ERROR 'Top:Myself:VSZ' is stubborn and refuses to open: No such
> file or directory

instead of hoping argus has ps and tail in your path, try statically setting
it
Service Prog {
  comand:  /usr/bin/ps -p $ARGUS_PID -o vsz | /usr/bin/tail -1
  uname:    VSZ
  title:   Memory Use
  ylabel:  kByes
 }

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: "Scott Hiemstra" <[email-masked]>
Date: Sat, 27 Mar 2004 16:05:53 -0500

I was hopeful is was something like that but no luck.  The other 2 "Self"
entries behave in the same manner.  Does gdata get populated during the
monitoring or on load of a graph?  From what I am reading in src it appears
to me it gets populated during testing but I may be mistaken.

Complete "self" config:
Group "Myself" {
        Service Self/idle {
            graph:  yes
            title:  Percent Idle
            calc:   ave-rate
            scale:  0.01
            # let someone know when it is time to upgrade h/w
            minvalue:  20
            messagedn: time to buy faster server
        }

        Service Self/tested {
            graph:  yes
            title:  Monitoring Rate
            ylabel: tests per second
            calc:   ave-rate
        }

        Service Prog {
            graph:          yes
            # how much memory is argus using?
            # your ps may be different
            command:        /usr/bin/ps -p $ARGUS_PID -o vsz |
/usr/bin/tail -1
            uname:          VSZ
            title:          Memory Use
            ylabel:         kBytes
        }
}

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jeremy Kister
Sent: Saturday, March 27, 2004 3:57 PM
To: Discussion about Argus
Subject: Re: Fresh argus install...graphs not working

Jeremy Kister

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist