Subject: Re: Authentication in argus-dev-2007010[67] broken?

From: Jeff Weisberg <[email-masked]>
Date: Mon, 8 Jan 2007 23:12:19 -0500

On 8 Jan, 2007, at 16:25, Falk Stern wrote:
> I just upgraded our (test) argus from 3.4 to dev-20070107 and  
> noticed that authentication might be broken..
>
> Using the same config/users file as from previously installed 3.4  
> dev-20070107 gave me "You do not have page permission on the  
> requested object" after login (even with "argus any Top root" in  
> users file)
>
> dev-20070104 works without problems.
>
> Known problem or am I doing anything wrong here?

I've been working on the acl code to make it easier to mix and
match between simple and extended mode acls. apparently, I got
it wrong. now fixed.

thanks.

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 10 Jan 2007 09:06:17 -0500

> match between simple and extended mode acls. apparently, I got

Wow..  You read my mind.  I had just updated to the latest (20070107)
and was gonna send an email this morning about this exact problem..  :)

Just installed 20070108 and it seems to be working fine now..  Thanks!

> thanks.

- --
- ---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
- ---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."