Subject: Monitoring Hierarchies

From: Stephan Buys <[email-masked]>
Date: Fri, 22 Apr 2005 14:23:52 +0200

Hi all,

Is there a way to configure hierarchies or dependencies in Argus?

An example of what I would like to do is to disable/override all monitors as 
long as my monitoring stations' connection to the network is down.

Thinking about it, I could possible write a notification Method that overrides
certain groups for the duration of the downtime?
What would this string look like using argusctl?

Regards,
-- 
Stephan  Buys
Code Fusion cc.
Tel: +27 11 673 0411
Mobile: +27 83 294 1876
Email: [email-masked]

E-mail Solutions, Kolab Specialists.
http://www.codefusion.co.za

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 22 Apr 2005 10:00:08 -0400

>Is there a way to configure hierarchies or dependencies in Argus?

Absolutely!  Check out the depends: configuration option...  A quick
example :

Host "Router" {
   hostname: my.example.com
   Service Ping
   Service UDP/SNMP {
      # insert snmp stuff here
      depends: Top:Router:Ping_my.example.com
   }
}

>What would this string look like using argusctl?

Hrm..  I *think* this is possible..  Not sure how it would be done though..

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."