Subject: Re: Monitoring a CVS server

From: Jeff Weisberg <[email-masked]>
Date: Thu, 4 Dec 2003 21:51:00 -0500 (EST)

you are looking for:
|
|                         expect:   ^Server: Concurrent Versions System

but you got:
| 
| PROG TEST value
| Client: Concurrent Versions System (CVS) 1. 11.2 (client/server)
| Server: Concurrent Versions System (CVS) 1.11.5 [mch1] (client/server)

and thus:
|
| PROG TEST did not match expected regex

you probably want:

	expect:    Server: Concurrent Versions System

| >       syslog: daemon
| 
| Already there. The error I sent was from the httpd error_log. I see
| nothing else in /var/log/*. argusctl -k console did show debug info
| though.

if the syslog line is in your argus config, but you aren't seeing any
of argus's messages in your log files, you may need to update your
syslog config files (usually /etc/syslog.conf (check your man pages)).

	--jeff

---

From: Matthew Doar <[email-masked]>
Date: 05 Dec 2003 09:03:14 -0800

> 	expect:    Server: Concurrent Versions System

Ah yes, I was expecting matching with Perl's /m modifier, where ^
matches after newlines too. A few examples of working regexes wouldn't
go amiss in the documentation.

Anyway, it's working nicely now, thanks.

~Matt

> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist