Subject: Re: Ignoring Downs during certain times

From: Jeff Weisberg <[email-masked]>
Date: Mon, 18 Oct 2004 13:59:56 -0400 (EDT)

| Is this legal?  Argus didn't choke on it, but I want to make sure it
| does what I think it does...  It should set the maxvalue to 35 except
| between the hours of 1am and 4am where it would be set to 40.  Will this
| work ok when argus starts up, or do I need to put a maxvalue outside of
| the crons?

if you want argus to use a maxvalue when it starts up,
then yes, you need to specify it.

| 	      cron "0 1 * * * *" {
| 		 func: setparam
| 		 param: maxvalue
| 		 value: 40
| 	      }

but, for the param you need to use the name that argus knows
it by, not the name that you use in the config file.
you will need to say:

		param: test::maxvalue

Click the 'Debugging' link to see the params as argus
knows them.

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Mon, 18 Oct 2004 14:13:32 -0400

>then yes, you need to specify it.
Cool, thanks..

>Click the 'Debugging' link to see the params as argus
Yup.. I just figured this out using the debugging link as indicated in 
your other post..

I appreciate the help!  This program is awesome ...  :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."