Subject: pluck succeeds where expect fails?

From: yary <[email-masked]>
Date: Wed, 21 May 2008 12:10:50 -0700

I'm scratching my head over this one. I'm plucking a value
successfully, but the service is failing because the expect doesn't
match, only the expect DOES match...

in my config:
service: Prog {
    uname: Rec
    label: Rec
    command: netstat -ssp ip
    expect: total packets received
    pluck: (\d+) total packets received
    calc: rate
}

I have data, but the service is listed as being down from due to
"expect" not matching. Interesting lines from the debug:

srvc::reasonPROG TEST did not match expected regex
srvc::resultip:~x0A ____ 731741145 total packets received~x0A ____
7084 fragments received~x0A~x. . .
status	down
test::calcdata::lastdv	1849
test::calcdata::lastt	1211397647
test::calcdata::lastv	731741145
test::expect	total packets received
test::pluck	(\d+) total packets received
test::rawvalue	ip:~x0A ____ 731741145 total packets received~x0A ____
7084 fragments received~x0A~x. . .

I tried replacing the spaces in the regexps with \s, same behavior.

Is it "bad" to use expect and pluck in the same service? Am I missing
something simple?

---

From: yary <[email-masked]>
Date: Wed, 21 May 2008 12:26:53 -0700

Never mind- expect tests the value after pluck- my config should have
expect: \d+

sorry for the bandwidth