Subject: Suggestion - Notify detail

From: "McKinnon, Joe" <[email-masked]>
Date: Fri, 18 Mar 2005 12:02:13 +1000

Hi,

With the notification detail pages, is it possible to add in the details of exactly the failure reason.  Eg perhaps what the "test::rawvalue:" results.  This way the entire contents of the notification file could be emailed to the on call person, and therefore they get the full error messages, etc.  The Debugging view on the webpages is only one line.......and this generally not enough if you are playing with web page outputs, etc.

Cheers Joe.
/**************************************************\
*                                                  *
* Joseph McKinnon BSc.                             *
* Systems/Database Administrator                   *
* Royal Automobile Club of Queensland              *
* Member, System Administrators Guild of Australia *
*                                                  *
* Phone: (07) 3361 2876                            *
*                                                  *
\**************************************************/ 

Please Note:

This communication has been sent on behalf of The Royal Automobile Club of
Queensland Limited (RACQ).  The information contained in this communication
may be privileged and confidential.  If you are not the intended recipient,
any use, disclosure or copying of this communication is expressly
prohibited.  If you have received this communication in error, please delete
it immediately.  RACQ and its associated entities do not warrant or
represent that this communication (including any enclosed files) is free
from electronic viruses, faults or defects.

If this is a commercial electronic message within the meaning of the Spam 
Act(2003), you may indicate that you do not wish to receive any further 
commercial electronic messages from RACQ by sending an e-mail to 
[email-masked] with your details or by contacting RACQ on 131905

---

From: Jeff Weisberg <[email-masked]>
Date: Sat, 19 Mar 2005 16:53:39 -0500 (EST)

| With the notification detail pages, is it possible to add in the details of 
| exactly the failure reason.  Eg perhaps what the "test::rawvalue:" results. 
|  This way the entire contents of the notification file could be emailed to t
| he on call person, and therefore they get the full error messages, etc.  The
|  Debugging view on the webpages is only one line.......and this generally no
| t enough if you are playing with web page outputs, etc.

hmm. It should be fairly simple to put the "reason" (%v)
on the detail web page. I can see that possibly being
useful.

	--jeff

---

From: "McKinnon, Joe" <[email-masked]>
Date: Sun, 20 Mar 2005 08:25:17 +1000

Hi Jeff,

That should be okay, as long as it's not a truncated output like in the debug area.  Reason being we are running some in house made specific web calls that are web programmers have created......they test cold fusion/ISS/transaction engine stuff.

When it breaks, you can get back lines of html code, with their embedded error message, and about the only way we can get these details out at present is doing an argusctl about Object=blahBlah, and giving them the RAW output.  It's a pain in the rear, as they aren't Unix people, and they are happy to blame everyone else, for the problems.  At present I've written an extension to our paging/alerting functions to email them the full about list, but would like to include it on the web pages.

Also if the reason stuff was dumped to the notify files, then we could go back in time and show them their errors.

BTW is there a way to specify how long to keep the notify files or better yet is there a way to say don't delete them?  As it would be a nifty extension that for a tool that allows you to look a event history.  A bit like your un-acked screen, but search able, to allow us to search for specific event types and generate a frequency of occurrence associated with the type of outage.....eg 5 Oracle Type issues, 10 unable to ping serverY.....

Cheers Joe.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jeff Weisberg
Sent: Sunday, 20 March 2005 7:54 AM
To: [email-masked]
Subject: Re: Suggestion - Notify detail

	--jeff
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

Please Note: