Subject: improving the graphs

From: "Andrew Kirch" <[email-masked]>
Date: Wed, 06 Dec 2006 14:57:11 -0000

I've been testing some environmental monitoring equipment with Argos'
Graphing functionality, and I think the graphs could really be improved.
I've seen what newer versions of jpgraph can do, and I wonder if maybe
this could be improved.  I'd be happy to test, and certainly could make
suggestions:

* Scale the graph 
If a graph is dealing with a dataset range of 800-900 we should  see
something which displays this range clearly, instead of showing 0-800 in
every graph.  
* weird polygons
Argus' graphs have always displayed weird polygons, usually in blue, but
on a graph monitoring many services, the graph ends up being difficult
to read at a glance.

Andrew

---

From: "Andrew Kirch" <[email-masked]>
Date: Mon, 8 Jan 2007 16:14:49 -0500

So I guess talking you into new graphs using say perl's jpgraph is out
of the question then? :)

Andrew D Kirch - All Things IT
Office: 317-755-0202
Cell: 317-507-1192
"si hoc legere scis nimium eruditiones habes." 
> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Jeff Weisberg
> Sent: Saturday, January 06, 2007 7:32 PM
> To: [email-masked]
> Subject: Re: improving the graphs
> 
> 
> | If a graph is dealing with a dataset range of 800-900 we should  see
> | something which displays this range clearly, instead of showing
0-800 in
> | every graph.
> 
> unless you've specified a range in your config file, the graphs
> do auto-adjust the range based on the data.
> 
> 
> 
> | Argus' graphs have always displayed weird polygons, usually in blue,
but
> | on a graph monitoring many services, the graph ends up being
difficult
> | to read at a glance.
> 
> 
> by default, the graphs display the min/max range in blue.
> 
> you can disable this by saying:
> 
> 	barstyle: none
> 
> 
> 
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist