Subject: How messagedn and messageup work? I'D like to have them in the body of theE-mails

From: "Rionel.J Jeudy" <[email-masked]>
Date: Wed, 31 May 2006 14:33:09 -0400

Why messagedn and messageup is not working for me
I'D like to have messagedn and messageup to be in the body of the E-mail.
So far i've been unsuccessful.(See config below)

sirensong:      /sound/whoopwhoop.wav
bkgimage:       /img/argus.logo.gif
icon:           /img/smile.gif
icon_down:      /img/sad.gif
nospkr_icon:    /img/nospkr.gif
style_sheet:    /argus.css

# send messages to syslog
syslog:         daemon

# who should be notified when things break?
#notify:                mail:[email-masked]
notify:                mail:[email-masked]

# don't summarize notifications
nolotsmsgs:     yes

# enable built in tcp test port
test_port:      3075

# enable built in resolver
Resolv

######################################################################################
#####
#####                                MAIL FORMAT
######################################################################################

 Method "mail" {
               command:        sendmail -t
               send:           To: %R\nFrom:%F\nSubject: %O{note} is %S\n\n%s

              }

######################################################################################

Group "Terminal Servers" {
frequency: 32
sendnotify: yes
renotify: 86400

Host "fw01 172.16.8.222" {
  hostname: 172.16.8.222
  note: fw01
  messagedn: IP:64.191.218.4 Host:FW Outside Interface to vlan is %s
  messagedn: IP:64.191.218.4 Host:FW Outside Interface to vlan is %s
  service Ping
  }
}

---

From: Jeremy Kister <[email-masked]>
Date: Wed, 31 May 2006 17:21:30 -0400

> I'D like to have messagedn and messageup to be in the body of the E-mail.

you spelled messageup incorrectly, and i think you have them in the 
wrong place.

> frequency: 32

interesting, but OK :)

> Host "fw01 172.16.8.222" {

Host "foo" and then hostname: bar is contradicting.  You should use Host 
"hostname" -- or -- Group "groupname" and hostname: hostname

Group "fw01 172.16.8.222" {
   hostname: 172.16.8.222
   note: fw01
   Service Ping {
     messagedn: IP:64.191.218.4 Host:FW Outside Interface to vlan is DOWN
     messageup: IP:64.191.218.4 Host:FW Outside Interface to vlan is UP
   }
}

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: "Rionel.J Jeudy" <[email-masked]>
Date: Wed, 31 May 2006 17:49:36 -0400

Hi Jeremy
cold you elaborate further, i am confused by your answer.

See config below:
I'D like to have (messageup and messagedn) as the body of the E-mail
should the host is unreacheable.
so far I've not been able to do so.

i was able to get note: fw01 is down as my subject like,
not I'd like to have an explicit body for my E-mail.

what is wrong with my config?
how should i fix it?
Do you have an example, when you have an explicit subject and body for
the E-mail?

I want to use messageup and message down for each host

Host "fw01 172.16.8.222" {
  hostname: 172.16.8.222
 note: fw01
  messagedn: IP:172.16.8.222 is %s
  messagedn: IP:172.16.8.222 is %s
 service Ping
 }
}

On 5/31/06, Jeremy Kister <[email-masked]> wrote:
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist
>