Subject: Re: How do I get more descriptive message in the subject line

From: Jeff Weisberg <[email-masked]>
Date: Wed, 30 Jun 2004 11:49:16 -0400 (EDT)

|    How do I get more descriptive message in the email
| subject line of argus. Currently we olny get Argus and
| Argus Resent. I would like to get the following
| 
| 1. Hostname that was check
| 
| 2. host status 
| 
| 3.  The  state of the value that was checked. For
| example if was diskspace what is the current value of
| the diskspace.

see:
  http://argus.tcp4me.com/notif.html

scroll down to "Adding Other Notification Methods"

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 30 Jun 2004 12:24:34 -0400

> scroll down to "Adding Other Notification Methods"

I'm a tad confused...

The message{up,dn} fields are put within the object configuration and
are for the message body, or subject?

And the send field in the Method object, is that the subject or body?

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."

---

From: Jared Crapo <[email-masked]>
Date: Wed, 30 Jun 2004 11:50:28 -0600

> And the send field in the Method object, is that the subject or body?

One way to make sure you get the behavior you want is to fix up your own
method, and put the %M where you want the message to go.  This one puts
it in the subject:

Method "msginsubj" {
	command: echo "`uname -n` %O is %S\nTest value is: %v" | mail -s "%M"
%R
}

while this one puts it in the message body:

Method "msginbody" {
	command: echo "%M\n`uname -n` %O is %S\nTest value is: %v" | mail -s
"Argus notification" %R
}

Then add this notify line:

notify: msginsubj:[email-masked] msginbody:[email-masked]

There are more escape sequences on the
http://argus.tcp4me.com/notif.html page.

J