Subject: Proposed patch to allow checknow via the web interface

From: [email-masked]
Date: Mon, 9 May 2005 07:33:48 -0700

I have been configuring Argus in our environment here for a couple of
weeks, and I'm really pleased with it.  I like the new checknow function in
3.4, but I would like to have it exposed via the web pages and I have done
a bit of coding to expose it.  Here is a set of patch files for my changes.
These patches are against the code in version 3.4 RC-20050419.  Can this be
added to the source, and can we have a new RC build with this in it?
(See attached file: Web.pm.patch)(See attached file: MonEl.pm.patch)(See
attached file: Service.pm.patch)(See attached file: cgi.patch)

Matt Cleveland
Sr. Web Developer
HealthNet Inc.
916.935.1248
[email-masked]

This  message,together  with  any  attachments, is
intended only for the use of the individual or entity
to which it is addressed. It may contain information
that is confidential and prohibited from disclosure.
If you are not the intended recipient, you are hereby
notified that  any dissemination  or copying of this
message or any attachment is strictly prohibited. If
you have received this message in error, please notify
the  original  sender immediately by telephone or by
return e-mail and delete this message, along with any
attachments, from your computer.  Thank you.

---

From: "McKinnon, Joe" <[email-masked]>
Date: Tue, 10 May 2005 08:37:29 +1000

Hi Matt,

Excellent idea, Jeff are you going to include this feature in the 3.4 release?  I often like the idea of checking servers especially after taking corrective actions, plus it gives my different user groups the power to test it themselves, rather than waiting or bugging me :-).

Cheers Joe.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, 10 May 2005 12:34 AM
To: [email-masked]
Subject: Proposed patch to allow checknow via the web interface

Matt Cleveland
Sr. Web Developer
HealthNet Inc.
916.935.1248

Please Note:

This communication has been sent on behalf of The Royal Automobile Club of
Queensland Limited (RACQ).  The information contained in this communication
may be privileg
If you are not the intended recipient,
any use, disclosure or copying of this communication is expressly
prohibited.  If you have received this communication in error, please delete
it immediately.  RACQ and its associated entities do not warrant or
represent that this communication (including any enclosed files) is free
from electronic viruses, faults or defects.

If this is a commercial electronic message within the meaning of the Spam 
Act(2003), you may indicate that you do not wish to receive any further 
commercial electronic messages from RACQ by sending an e-mail to 
[email-masked] with your details or by contacting RACQ on 131905

---

From: [email-masked]
Date: Thu, 12 May 2005 08:08:05 -0700

Sorry about that, here is the patch for Web.pm.

--- src/Web.pm    Wed Apr 20 17:55:30 2005
+++ /usr/local/argus/lib/Web.pm     Mon Apr 25 12:57:54 2005
@@ -347,6 +347,12 @@
     print $fh $me->web_button('Debugging', undef, 'func=about');
     print $fh "<!-- END AUTHORIZATION DEBUG NEEDED -->\n";

+    if ( $me->{web_checknow} ){
+        print $fh "<!-- START AUTHORIZATION DEBUG NEEDED
$me->{acl_checknow} -->\n";
+        print $fh $me->web_button('Check Now', undef, 'func=checknow');
+        print $fh "<!-- END AUTHORIZATION DEBUG NEEDED -->\n";
+    }
+
     # paging...
     print $fh "<!-- START AUTHORIZATION RW NEEDED $me->{acl_ntfylist}
-->\n";
     print $fh $me->web_button_no('Un-Acked Notifies', undef,
'func=ntfylsua');

Matt Cleveland
Sr. Web Developer
HealthNet Inc.
916.935.1248

                      Jason 'XenoPhage'                                                                                      
                      Frisvold                 To:       Discussion about Argus <[email-masked]>                       
                      <[email-masked]        cc:                                                                           
                      m>                       Subject:  Re: Proposed patch to allow checknow via the web interface          
                      Sent by:                                                                                               
                      arguslist-bounces                                                                                      
                      @tcp4me.com                                                                                            

                      05/12/2005 07:47                                                                                       
                      AM                                                                                                     
                      Please respond to                                                                                      
                      Discussion about                                                                                       
                      Argus                                                                                                  

[email-masked] wrote:

>I see that attachments don't make it through the list server, so here is
>the text of the patches.
>
>

Excellent..  One problem though..  You pasted the wrong patch for Web.pm
(see below) ... Can you paste the correct one please??

>Last for Web.pm
>
>--- src/Service.pm      Wed Apr 20 17:55:29 2005
>+++ /usr/local/argus/lib/Service.pm Mon Apr 25 13:24:35 2005
>@@ -303,6 +303,7 @@
>     unless( $me->{notify}{sendnotify2} ){
>      $me->{notify}{sendnotify} = 0;
>     }
>+    $me->{web_checknow} = 1 unless defined $me->{web_checknow};
>
>     $cf->warning( "test frequency is less than retrydelay" )
>      if $me->{srvc}{retrydelay} && $me->{srvc}{frequency} <
>$me->{srvc}{retrydelay};
>
>

Thanks!

--
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and
unmoving, it is at once still and yet in constant motion. It is the source
of all programs. I do not know its name, so I will call it the Tao of
Programming."

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: Jeff Weisberg <[email-masked]>
Date: Thu, 12 May 2005 15:26:16 -0400 (EDT)

| Excellent idea, Jeff are you going to include this feature in the 3.4 release?

no, 3.4 has been feature frozen for some time and should
be out any day now. already on the list for 3.5 though.

	--jeff