Subject: 'depends' directive in config files

From: Ivan <[email-masked]>
Date: Wed, 21 Oct 2009 17:12:05 -0700 (PDT)

Hello,

I cannot seem to find and examples or explanations of
the use of the  'depends'  directive in  argus config files.

the docfiles and example-configs online seem to have nothing there.

Can anyone provide me any simple working examples, or the link that
has the argus docfile for using this directive ?

Thanks
-IvanG.

---

From: Scott Hiemstra <[email-masked]>
Date: Wed, 21 Oct 2009 21:21:25 -0400

The only real documentation I ever found for it was http://argus.tcp4me.com/config-details.html but it is very simple to use.

Service TCP/URL {
     url:            http://someurl.somedomain.com
     label:          Some Friendly URL Name
     browser:        Mozilla/5.0 (compatible; Argus - just testing)
     depends:        Top:Servers:ServerName:Ping_servername.somedomain.com
}

This would assume that http://someurl.somedomain.com was hosted on a server named servername.somedomain.com.  It basically says the URL will only be considered down if the Ping for the depends object is up.  You can get the depends line from the top bar of any argus page or just grab the relevant parts from the address bar.

Hope that helps,
Scott

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ivan [[email-masked]]
Sent: Wednesday, October 21, 2009 8:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: 'depends' directive in config files

Hello,

Thanks
-IvanG.

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: Gonzalo Perez Brun <[email-masked]>
Date: Mon, 26 Oct 2009 20:32:24 -0200

Mr. Scott:
          Sorry for asking this but, i need to figureout how this works. If I have a test1 for example, and test1 depends on test2. If the test1 falldown, test2 stop being tested and assume that is down too?
          Thanks.

Gonzalo.

> From: [email-masked]
> To: [email-masked]
> Date: Wed, 21 Oct 2009 21:21:25 -0400
> Subject: RE: 'depends' directive in config files
> 
 		 	   		  
_________________________________________________________________
Nuevo Windows 7: encontrá el equipo adecuado para vos. Obtené más información.
http://windows.microsoft.com/shop

---

From: Ivan <[email-masked]>
Date: Mon, 26 Oct 2009 16:38:54 -0700 (PDT)

I do not think so.

>From what I was notified,  if test1 relies on test2, then if test1 down, there should be no
affect to test2.

If test2 down, then test1 would not even be considered to be down or not.

--- On Mon, 10/26/09, Gonzalo Perez Brun <[email-masked]> wrote:

From: Gonzalo Perez Brun <[email-masked]>
Subject: RE: 'depends' directive in config files
To: "Listado de Colsultas ARGUS" <[email-masked]>
Date: Monday, October 26, 2009, 3:32 PM

Mr. Scott:

Gonzalo.

_________________________________________________________________
Nuevo Windows 7: encontrá el equipo adecuado para vos. Obtené más información.
http://windows.microsoft.com/shop_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist