Subject: Re: Scalability

From: Jeff Weisberg <[email-masked]>
Date: Sun, 30 Jan 2005 23:03:09 -0500 (EST)

|     I'm wondering how much data Argus can reasonably be asked to 
| handle.  Does anyone know what the largest installation is to date, and 
| the type of hardware it's running on?  Can Argus run threaded?

the largest installation that I know of, is monitoring
over 10000 hosts. I don't know what they are running on.

if you want to monitor a lot of services, you'll need
to pay attention to memory (argus uses a lot) and cpu
(argus uses very little). running 'argusctl status'
and having argus graph its own memory, cpu, (etc) stats,
will be useful. see:
	http://argus.tcp4me.com/self.html

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Mon, 31 Jan 2005 00:45:20 -0500

>over 10000 hosts. I don't know what they are running on.

Wow..  Is that using DARP?

>	http://argus.tcp4me.com/self.html

*nod*  I have this already ..  :)  Copied from the samples on the site..  :P

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."