Subject: why argus is sending 2 notifications by E-mail for the same event?

From: "Rionel.J Jeudy" <[email-masked]>
Date: Tue, 6 Jun 2006 14:28:10 -0400

Argus sends 2 notifications E-mail for certain nodes, when the
specific node change state.
These notifications are random, which means sometimes it sends one
E-mail and sometimes 2  mails.
What could be the cause?

Here are some info i retrieve from syslog:
Jun  4 13:37:16 ARGUS-NET-MON insmod:
/lib/modules/2.4.29/kernel/drivers/hotplug/pciehp.o.gz: insmod pciehp
failed

Part of my proccesses:

oot       675  0.0  1.0  9768 8220 ?        Ss   Jun04   0:00 Argus
nobody     704  0.0  0.2  3884 1944 ?        S    Jun04   0:00 /usr/sbin/httpd
nobody     705  0.0  0.2  3884 1944 ?        S    Jun04   0:00 /usr/sbin/httpd
nobody     706  0.0  0.2  3884 1944 ?        S    Jun04   0:00 /usr/sbin/httpd
root     13743  0.0  0.2  5848 2076 ?        Ss   Jun05   0:00 sshd: root@pts/1
root     13749  0.0  0.2  2740 1644 pts/1    Ss+  Jun05   0:00 -bash
root     27918  0.8  3.4 28532 27084 ?       S    Jun05  12:58 Argus
root     29957  0.0  0.0  1452  552 ?        S    14:29   0:00
/usr/local/sbin/fping -r 3 -t 500 -e
root     29958  0.0  0.0  1444  532 ?        R    14:29   0:00
/usr/local/sbin/fping -r 3 -t 500 -e
root     29959  1.0  0.0  1444  528 ?        S    14:29   0:00
/usr/local/sbin/fping -r 3 -t 500 -e
root     29960  0.0  0.1  2408  844 pts/0    R+   14:29   0:00 ps aux

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 07 Jun 2006 20:06:32 -0400

> E-mail and sometimes 2  mails.

You have 2 instances of Argus running.  PIDs 9768 and 28532.

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."