Subject: fping -- "failed to return data about" after Debian Upgrade

From: Jason Azze <[email-masked]>
Date: Tue, 5 Apr 2011 12:20:29 -0400

Hi, arguslist,

After upgrading from Debian "Lenny" to the latest testing distribution,
argus shows all of my hosts as down.

The logs show that both ping and fping failed to return data. For example:

Apr  5 11:59:18 netmon01 Argus[8800]: PING failed - returned no data
Apr  5 11:59:18 netmon01 Argus[8800]: fping failed to return data about
192.168.20.43*

*However, fping and ping are both functional, as can be seen from this
sanitized output:

netmon01:/var/argus# fping host.mydomain.com
host.mydomain.com is alive
netmon01:/var/argus# echo $?
0
netmon01:/var/argus# ping host.mydomain.com
PING host.mydomain.com (192.168.1.19) 56(84) bytes of data.
64 bytes from host.mydomain.com (192.168.1.19): icmp_req=1 ttl=128
time=0.281 ms
64 bytes from host.mydomain.com (192.168.1.19): icmp_req=2 ttl=128
time=0.160 ms
^C
--- host.mydomain.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.160/0.220/0.281/0.062 ms
netmon01:/var/argus# echo $?
0

I'm assuming I broke a dependency somewhere. Can anyone nudge me in the
right direction

Thanks,
Jason

---

From: jeff weisberg <[email-masked]>
Date: Tue, 5 Apr 2011 12:59:15 -0400

> The logs show that both ping and fping failed to return data. For  

are these programs now installed in a different location?

you will need to stop argus;
	configure --upgrade; make; make install
and restart

---

From: Jason Azze <[email-masked]>
Date: Tue, 5 Apr 2011 14:05:44 -0400

>        configure --upgrade; make; make install
Thanks, Jeff. Those programs have not moved, but I recompiled anyway (with
the --upgrade) and Argus is happy again.

I'm embarrassed to say that I think I did this to myself a few years ago and
just forgot the solution. I'm documenting it this time!