Subject: Re: argusctl summary problem

From: Jeff Weisberg <[email-masked]>
Date: Wed, 10 May 2006 10:50:27 -0400 (EDT)

| Now I only have one wonder: why does it report for Top
| less then the sum of individual groups?
| I mean
| argusctl summary object=Top:Group1 +
| argusctl summary object=Top:Group2
| ...
| argusctl summary object=Top:GroupN
|
| Gives me a total of 139 services up, and 2 overriden.
| The per group summary is perfect and 100% identical to
| the one given on the webpage. But why does the Top
| report less?

the numbers are not the total number of services,
but the results of a complex algorithm (roughly,
but not quite, the number of objects 1 or 2 levels
below the specified object).

the numbers are intended to be an insightful summary
of the current status.

---

From: "Alexandru E. Ungur" <[email-masked]>
Date: Thu, 11 May 2006 08:36:32 +0300

>>> sender: "Jeff Weisberg" date: "Wed, May 10, 2006 at 10:50:27AM -0400" <<<EOQ
> 
> 
Umm, but then how insightful is this, if on a level
3 group I do have a service down, but as the Top
summary only takes level 1 and 2 into account, it
would probably say 'down: 0' for the Top summary... ?

Anyway, I am using the monitoring of this number on a
specific group, not Top, and it works there as I would
expect it to, so my problem is solved, but I was just
curious how can that complex algorythm be more useful
than a simple up: X down: Y where the algorythm is
the plain old sum ? I guess there is something I'm
missing... 

Thank you,
and great job with Argus :)
It's a really great piece of software, and I can't stop
myself telling this to everybody who mentions 'server 
monitoring'... :)

Alex