Subject: Problem with Cron and notifyalso

From: Keith Laurien <[email-masked]>
Date: Wed, 21 Feb 2007 19:00:26 +1100

Hi All,

I'm trying to set Argus, ideally, to ALSO send an email to a different
address if something goes down
outside business hours.  I then will redirect that email to an email to sms
service that
sends it to a mobile phone...

My base configuration for this (in testing mode) is as follows

--snip---

notify: mail:[email-masked]

Group "Testing" {
  autoack: yes

  Host "KeithTest" {
    hostname: 192.168.6.70
      Service TCP {
        port: 21
        info: FTP
        label: FTP
      }
  }
}

---snip--

This works like a charm just auto ack'ing and sending one email.
What I figured I could do was change it to add some cron jobs to set the
"notifyalso" param

Group "Testing" {
  autoack: yes
    #set the additional email on at 6pm
    cron "59 17 * * * 1,2,3,4,5" {
                  func:        setparam
                  param:       notifyalso
                  value:       mail:[email-masked]
    }
    #turn off additional email at 8am
    cron "01 08 * * * 1,2,3,4,5" {
                  func:        setparam
                  param:       notifyalso
                  value:
    }

  Host "KeithTest" {
    hostname: 192.168.6.70
      Service TCP {
        port: 21
        info: FTP
        label: FTP
      }
  }
}

However, it doesn't seem to want to work for me.
I've also tried using various "argusctl setparam" type entries, also to no
avail.
Any kick in the right direction here would be very much appreciated.

Thanks, Keith

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 21 Feb 2007 12:34:21 -0500 (EST)

|     cron "59 17 * * * 1,2,3,4,5" {
| 		    func:        setparam
| 		    param:       notifyalso
| 		    value:       mail:[email-masked]
|     }
| 
| However, it doesn't seem to want to work for me.
| I've also tried using various "argusctl setparam" type entries, also to no
| avail.
| Any kick in the right direction here would be very much appreciated.

'notifyalso' is the name of the parameter as you would put
it in the config file, but the setparam function wants the
name of the parameter as argus knows it internally.

internally, argus calls this parameter 'notify::notifyalso'

you can get a list of all of the parameters as argus knows
them with the command:
	argusd -E

or at:
	http://argus.tcp4me.com/debug-details.html