Subject: SNMP and Argus question

From: "Joe G" <[email-masked]>
Date: Sun, 19 Sep 2004 22:04:57 -0300 (ADT)

Is there a was to use snmp with argus and not use an oid.  I want to
monitor snmp to make sure specific processes are running and notify me if
they fail.

example cut from snmpd.conf

proc named 1 1
proc apache
proc sendmail

-- 
Joe

***
I can only please one person a day.
Today is not your day and tomorrow doesn't look good either.
***

---

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 20 Sep 2004 02:10:58 -0400

> monitor snmp to make sure specific processes are running and notify me if

you need an oid to talk snmp.  this oid may be dotted decimal, or
alphanumerical.

> proc sendmail

Assuming you're using Net-SNMP (ucd-snmp's big brother), the oid for these
objects depend on where they are in relation to other stuff in your
snmp.conf.

you'll want: .1.3.6.1.4.1.2021.2.1.5.<something>

you can figure it out by walking .1.3.6.1.4.1.2021.2.1
# snmpwalk -v 1 -c public localhost ..1.3.6.1.4.1.2021.2.1.2
(substituting public for your public community name, of course)

for example, on my system, Net-SNMP ships with 'mountd', 'ntalkd', and
'sendmail' being monitored.

mickey> snmpwalk -v 1 -c public localhost .1.3.6.1.4.1.2021.2.1.2
UCD-SNMP-MIB::prNames.1 = STRING: mountd
UCD-SNMP-MIB::prNames.2 = STRING: ntalkd
UCD-SNMP-MIB::prNames.3 = STRING: sendmail

this means:
to monitor mountd: .1.3.6.1.4.1.2021.2.1.5.1
to monitor ntalkd: .1.3.6.1.4.1.2021.2.1.5.2
to monitor sendmail: .1.3.6.1.4.1.2021.2.1.5.3

Jeremy Kister
http://jeremy.kister.net/