Subject: Graphing troubles

From: Jared Crapo <[email-masked]>
Date: Tue, 22 Jun 2004 18:13:35 -0600

I have recently installed argus, and have been quite pleased with the
results.  Today I tried to get graphing to work, and I have had no
luck.  I am using the simple config file found on
http://argus.tcp4me.com/self.html.  I get empty boxes when I look at the
web pages.  I have files in $datadir/gcache, but they all are empty, ie
length of 0.  There are no files in $datadir/gdata, which I suspect is
the problem.  I looked through the mailing list archives, and couldn't
find anything that helped me solve this problem, so I'm posting here in
the hope that someone can help.

$ argusctl status
ARGUS/2.0 200 OK
status:   running
version:  3.3
perlver:  5.8.3
osinfo:   Linux 2.4.25-2mdk i686
objects:  5
services: 3
notifies: 0
uptime:   0:07:23
idle:     99.84% 99.65% 0.00%
monrate:  0.04 0.05 0.00 per second

The $datadir/log file doesn't show any errors, just stuff about parents
and children getting SIGTERM'ed and argus restarting.  I have shut down
argus and web server (apache) and started them up again.

$ perl -e 'print "found GD\n" if(eval { require GD })'
found GD

It seems GD is getting found OK.

$ cd /var/argus
$ ls -ld gdata gcache
drwxrwxrwx  2 root root 4096 Jun 22 17:54 gcache
drwxrwxrwx  2 root root 4096 Jun 15 17:15 gdata

Shouldn't be a permissions problem either.

$ ls -l gcache
-rw-r--r--  1 apache apache 0 Jun 22 17:54 Top:Myself.days.thumb.png
-rw-r--r--  1 apache apache 0 Jun 22 17:54 Top:Myself.hours.thumb.png
-rw-r--r--  1 apache apache 0 Jun 22 17:54 Top:Myself.samples.full.png
-rw-r--r--  1 apache apache 0 Jun 22 17:54 Top:Myself.samples.thumb.png
-rw-r--r--  1 apache apache 0 Jun 22 18:06
Top:Myself:Self_tested.days.full.png
-rw-r--r--  1 apache apache 0 Jun 22 18:05
Top:Myself:Self_tested.days.thumb.png
-rw-r--r--  1 apache apache 0 Jun 22 18:06
Top:Myself:Self_tested.hours.full.png
-rw-r--r--  1 apache apache 0 Jun 22 18:05
Top:Myself:Self_tested.hours.thumb.png
-rw-r--r--  1 apache apache 0 Jun 22 18:05
Top:Myself:Self_tested.samples.full.png
-rw-r--r--  1 apache apache 0 Jun 22 18:05
Top:Myself:Self_tested.samples.thumb.png

The empty png files.

$ ls -l gdata
total 0

No stuff in gdata.

Can somebody point me in the right direction to try and get this working
right?

J

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 23 Jun 2004 08:31:18 -0400

> the hope that someone can help.

Let it run for a few minutes...  There may not be enough data to display
anything yet...

> monrate:  0.04 0.05 0.00 per second

7 Minutes uptime is most likely not enough time to have sufficient data
to show anything in the graph..

> argus and web server (apache) and started them up again.

The sigterms are normal..  They happen when the config changes..

> Can somebody point me in the right direction to try and get this working

What does the config look like for your graphing?

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."

---

From: Jared Crapo <[email-masked]>
Date: Thu, 24 Jun 2004 13:21:34 -0600

> to show anything in the graph..

OK, now we have:
$ argusctl status
ARGUS/2.0 200 OK
status:   running
version:  3.3
perlver:  5.8.3
osinfo:   Linux 2.4.25-2mdk i686
objects:  5
services: 3
notifies: 0
uptime:   1d 19:01:00
idle:     99.82% 99.71% 99.82%
monrate:  0.05 0.05 0.05 per second

The gdata directory is still empty.  <sad>No pretty pictures.</sad>
> What does the config look like for your graphing?
Here is the config I am using:

# locations of various items on web pages
bkgimage:       /icons/argus-logo.gif
icon:           /icons/smile.gif
icon_down:      /icons/sad.gif
nospkr_icon:    /icons/nospkr.gif
style_sheet:    /argus.css

# only notify once
autoack:        yes

# who should be notified when things break?
notify:         mail:NOSPAM

Group "Myself" {
        graph: yes
        Service Self/idle {
                title:  Percent Idle
                calc:   ave-rate
                scale:  0.01
                # let someone know when it is time to upgrade h/w
                minvalue:  20
                messagedn: time to buy faster server
        }

        Service Self/tested {
                title:  Monitoring Rate
                ylabel: tests per second
                calc:   ave-rate
        }

        Service Prog {
                # how much memory is argus using?
                # your ps may be different
                command:        ps -p $ARGUS_PID -o vsz | tail -1
                uname:          VSZ
                title:          Memory Use
                ylabel:         kBytes
        }
}

Guess it's time to dust off my camel book and see if I can figure out
what's wrong.

Jared