Subject: Re: "invalid entry" for the Resolv / stops responding

From: Jeff Weisberg <[email-masked]>
Date: Wed, 29 Aug 2007 21:06:21 -0400 (EDT)

| Q1) I am getting an "invalid entry" in my config for the statement:
| 
| # enable built in resolver
| Resolv

there is nothing wrong with this line by itself.
if you are getting an error, it may be related
to something in your config before this line.

| Argus seems to stop responding after a few days even though the
| processes are still running

stopped responding how? responding to what?
please explain.

---

From: "Mark Duling" <[email-masked]>
Date: Thu, 13 Sep 2007 12:11:14 -0700

>to something in your config before this line.

Sorry to take so long to reply.  I wanted to make sure I had accurate
information.
You are right.  There was a problem above that statement that I fixed.
>stopped responding how? responding to what?

I set argus to check two webservers, and as a test I set it to check a
nonexistent service on each server.  It notifies me every 5 minutes via
email (postfix) as it should for about 1.5 days and then stops notifying
me.  Yet argus is still running, and I can manually send messages via
postfix so I know it is still healthy.  Everything looks normal:

argusctl status:

ARGUS/2.0 200 OK
status:    running
version:   3.5
perlver:   5.8.8
osinfo:    Darwin 8.10.0 Power Macintosh
darpmode:  disabled
objects:   20
services:  14
notifies:  2
uptime:    1d 19:11:33
idle:      99.81% 99.81% 99.81%
monrate:   0.09 0.09 0.09 per second

ps -ax |grep Argus
 8778  ??  Ss     0:00.00 Argus                                           
                            
 8779  ??  S      5:31.99 Argus                   

This behavior is consistent over repeated tests.  ~1.5 days and no more
notifications.  But I just noticed that when I check the "notifications"
button in the web interface I don't see any recent notifications listed. 
Only some from a previous test a few weeks ago.  That is the best I can
describe it.  Any help is appreciated.

Mark