Subject: dependencies checks

From: Josef Bergmann <[email-masked]>
Date: Tue, 23 Mar 2004 10:27:30 +0100

Hello!

First of all thanks for this great piece of software. I use netsaint/nagios 
since years but I disliked all the time the structure/syntax of the config. 
Tried argus now, love it :-)

But I've small problem how should I use "dependencies". For example I have 2 
cascaded switches, on the 
first is the argus-monitor on the second a server which i want check. I also 
check both switches. When the first switch goes down, I don't need checks and 
alarms about the second switch and the server (because the couldn't be 
reached).

Could "grouping" implement this?

Thanks.

bye Josef
-- 
BERGMANN engineering & consulting  http://bec.at

---

From: "Mire, John" <[email-masked]>
Date: Wed, 24 Mar 2004 14:12:10 -0600

This worked fine in 3.3_RC-20040304 but after upgrading to 3.3-RELEASE the
following messages now appears in the log:
 
[2004/3/24 14:06:54] [42197] restart requested - HUPing
[2004/3/24 14:06:54] [42197] child caught signal SIGHUP - exiting
[2004/3/24 12:55:45] [42197] WARNING: in file
'/var/argus/cfg/015_upstream.cfg' on line 22 - additional data not permitted
here (ignored)
[2004/3/24 12:55:45] [42197] WARNING: in file
'/var/argus/cfg/015_upstream.cfg' on line 27 - additional data not permitted
here (ignored)
[2004/3/24 12:55:45] [42197] WARNING: in file
'/var/argus/cfg/015_upstream.cfg' on line 40 - additional data not permitted
here (ignored)
[2004/3/24 12:55:59] [42197] successful restart - Argus running

Here's the config:
Group "Upstream" {
    overridable: no
    notify: mail:[email-masked]
    sort:       no
Group "Internet I" {
        overridable:    yes
        sort:   no
        Host "bcn-router" {
                hostname:       155.58.86.125
                Service Ping
        }
        Host "shv1-tr1.tr16-b1.la.net" {
                Service Ping
                depends: Top:Upstream:Internet_I:bcn-router:Ping
        }
        Host "isp2-shv1.atm-vcc.la.net" {
                Service Ping
                depends:
Top:Upstream:Internet_I:shv1-tr1.tr16-b1.la.net:Ping
        }
    }
}

-----Original Message-----
From: "Jeremy Kister" <[email-masked]>
Subject: Re: dependencies checks
To: "Discussion about Argus" <[email-masked]>
Message-ID: <000501c410bb$5044ee40$0201090a@jeremy01>
Content-Type: text/plain;	charset="iso-8859-1"

> But I've small problem how should I use "dependencies". For example I have
2

see depends at http://argus.tcp4me.com/config-details.html

for example, try:
  Group "switch1" {
    hostname: 192.168.1.1
    Service Ping
  }
  Group "switch2" {
    hostname: 192.168.1.2
    Service Ping
    depends: Top:switch1:Ping
  }

Jeremy Kister
http://www.jeremykister.com/jeremy/

------------------------------

Message: 4
Date: Tue, 23 Mar 2004 14:05:09 +0100
From: Josef Bergmann <[email-masked]>
Subject: Re: dependencies checks
To: Discussion about Argus <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain;  charset="iso-8859-1"

Am Dienstag, 23. März 2004 10:43 schrieb Jeremy Kister:

> On Tuesday, March 23, 2004 4:28 AM, Josef Bergmann wrote:
> > But I've small problem how should I use "dependencies". For example I
> see depends at http://argus.tcp4me.com/config-details.html
>
> for example, try:
>   Group "switch1" {
>     hostname: 192.168.1.1
>     Service Ping
>   }
>   Group "switch2" {
>     hostname: 192.168.1.2
>     Service Ping
>     depends: Top:switch1:Ping
>   }

Sorry but that did not work.

argusd -t gives as reason:
... WARNING: in file '/var/argus/config' on line ... - additional data not 
permitted here (ignored)

I tried it with 3.2.1 and the new 3.3, but none both seems to work with any 
variation of "depends".

bye Josef

------------------------------

Message: 5
Date: Tue, 23 Mar 2004 11:47:58 -0500
From: "Giordano, Bryan" <[email-masked]>
Subject: Down View
To: "[email-masked]'" <[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain

Is there a way to setup a view so that you can see everything that is down
from all the different groups and sub groups?

So for example I have 3 groups on my Top page.  I'd like a 4th group that
shows me all items in those 3 groups that are down.

-Bryan

Please do not transmit orders or instructions regarding a UBS account by
email. The information provided in this email or any attachments is not an
official transaction confirmation or account statement. For your protection,
do not include account numbers, Social Security numbers, credit card
numbers, passwords or other non-public information in your email. Because
the information contained in this message may be privileged, confidential,
proprietary or otherwise protected from disclosure, please notify us
immediately by replying to this message and deleting it from your computer
if you have received this communication in error.  Thank you.

UBS Financial Services Inc.
UBS International Inc.

------------------------------

_______________________________________________
Arguslist mailing list
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

End of Arguslist Digest, Vol 5, Issue 12
****************************************

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 24 Mar 2004 16:52:35 -0500 (EST)

| 	  Host "shv1-tr1.tr16-b1.la.net" {
| 		  Service Ping
| 		  depends: Top:Upstream:Internet_I:bcn-router:Ping
| 	  }
[...]

| This worked fine in 3.3_RC-20040304 but after upgrading to 3.3-RELEASE the
| following messages now appears in the log:

no, it did not work fine.
such syntax has never been valid.
there was a bug reporting the error message, was which was fixed.

	--jeff

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 24 Mar 2004 16:58:34 -0500 (EST)

| But I've small problem how should I use "dependencies". For example I have 2 
| cascaded switches, on the 
| first is the argus-monitor on the second a server which i want check. I also 
| check both switches. When the first switch goes down, I don't need checks and 
| alarms about the second switch and the server (because the couldn't be 
| reached).
| 
| Could "grouping" implement this?

you could put them all into a group,
and send alerts from the group instead of the services:

	Group "Stuff" {
		sendnotify:	yes

		Service Ping {
			hostname:	switch1
			sendnotify:	no
		}
		Service Ping {
			hostname:	switch2
			sendnotify:	no
		}
		Service Ping {
			hostname:	server1
			sendnotify:	no
		}
	}

	--jeff