Subject: Re: why argus is sending 2 notifications by E-mail for the same event?

From: Jeff Weisberg <[email-masked]>
Date: Thu, 8 Jun 2006 12:10:04 -0400 (EDT)

| You have 2 instances of Argus running.  PIDs 9768 and 28532.

no. argus normally has 2 processes running.

he is really going to need to look at his argus + mail server
logfiles, as several people have already pointed out, numerous
times, over the past several weeks.

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Thu, 08 Jun 2006 22:10:12 -0400

> no. argus normally has 2 processes running.

While I would tend to agree with you, the second instance should be a
child of the first :

[friz@jake ~]$ ps -ef | grep -i argus
root     13476     1  0 May26 ?        00:00:00 Argus
root     28108 13476  1 Jun03 ?        02:39:12 Argus
root     28196 28108  0 Jun03 ?        00:15:31 /usr/bin/perl
/usr2/Argus/lib/graphd daemon
friz      4150  2227  0 22:08 pts/0    00:00:00 grep -i argus

In his case, it is not..  I think if he kills all instances of argus and
starts over, he may solve the problem...

(I had the same problem a few times..  Had one instance running as root,
one as a user..  confused me for a while)

> times, over the past several weeks.

Of course, this wouldn't hurt either..  :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."