Subject: Overrides not suppressing notifies/multiple notifications

From: William Schroeder <[email-masked]>
Date: Mon, 19 May 2014 22:40:25 +0000

When I set an override it only overrides in the website (won't show that it's down there) but email notifications still go out as well as escalations. This started at some point after upgrading to 3.7 (the upgrade may not be related but I'm not sure). I took my large config and partially re-wrote it separating it out into smaller components and changing things. The issue went away but then after a few weeks returned.

Additionally I receive 1-3 notifications for each thing that's down. I thought my disk space checks were because it was giving me a notification for each SNMP item (even though the check for total space used and total space are set to not notify), but it happens for some things on Ping.

If anyone has any insight on either issue it would be GREATLY appreciated. I had to turn off the text escalations due to this and it causes extra emails giving me kickback from colleagues.

I sent this a long time ago but I'm not sure if it went through to the list.

Will

---

From: William Schroeder <[email-masked]>
Date: Thu, 22 May 2014 13:59:36 +0000

I think I've reached a point where I may attempt to downgrade, to 3.6, to see if that will help the issue. Anyone have any gotchas in downgrading that would save me some trouble?

I didn't see any documentation but I imagine I can save my configs, remove most of the files installed and reinstall it (and I have a snapshot just in case).

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Tuesday, May 20, 2014 00:40 AM
To: [email-masked]'
Subject: Overrides not suppressing notifies/multiple notifications

Will

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: Scott Hiemstra <[email-masked]>
Date: Thu, 22 May 2014 13:18:45 -0400

Will,

Sorry for not replying before now but I have experienced a similar strange issue to the one you described with 3.7, the root cause of my issue didn't really have anything to do with Argus.  I use DARP in failover mode, My issue was my master monitoring systems was IO busy and was going through the beginning stages of a drive failure.  I kept getting strange notifications and the web interface didn't agree with what I was getting via notifies.  It turned out that I was getting notified by my DARP slaves about things which were not actually down.  

I doubt this will turn out to be your issue but just be aware that the root cause may not be what it seems to be.  As for downgrading from 3.7 to 3.6, I can't speak for those exact versions but I didn't have any issues going from argus-dev-20100109 to argus-dev-20090222 way back in the day.  I don't even think I removed the old stuff but I was definitely more of a free spirit back then.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 10:00 AM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Tuesday, May 20, 2014 00:40 AM
To: [email-masked]'
Subject: Overrides not suppressing notifies/multiple notifications

Will

---

From: William Schroeder <[email-masked]>
Date: Thu, 22 May 2014 17:24:44 +0000

Scott,

Thank you for the reply and information. While I don't have that same situation your info about it being an underlying problem outside of Argus has me thinking (and the info on the downgrade was helpful).

It's only a single server but I am running an end of life version of FreeBSD on it (9.0-RELEASE). Realized this when I had trouble with transferring the 3.6 tgz from windows to the machine and it kept saying it was corrupt (tried to install wget and found they no longer support 9). Maybe I'll like up and just moving to 9.2 will solve my issues.

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Hiemstra
Sent: Thursday, May 22, 2014 19:19 PM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will,

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 10:00 AM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Tuesday, May 20, 2014 00:40 AM
To: [email-masked]'
Subject: Overrides not suppressing notifies/multiple notifications

Will

---

From: William Schroeder <[email-masked]>
Date: Mon, 26 May 2014 23:08:16 +0000

Scott,

Time will tell for sure but tests are looking promising that the issue is resolved. Your reference to having similar problems but the cause being something not directly related to Argus was very helpful. To not get too lengthy I rebuilt the server (using the latest OS, patches, and ports) and everything is testing exactly as it should now. In trying to update the current I believe there may have been something that got messed up on the server somehow.

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 19:25 PM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Scott,

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Hiemstra
Sent: Thursday, May 22, 2014 19:19 PM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will,

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 10:00 AM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Tuesday, May 20, 2014 00:40 AM
To: [email-masked]'
Subject: Overrides not suppressing notifies/multiple notifications

Will

---

From: William Schroeder <[email-masked]>
Date: Thu, 29 May 2014 00:11:10 +0000

Spoke too soon, some notifications are sending two and the overrides don't appear to be doing any good. Is anyone else out there using FreeBSD 9 or 10 and Argus 3.7?

Will

-----Original Message-----
From: William Schroeder 
Sent: Tuesday, May 27, 2014 01:08 AM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Scott,

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 19:25 PM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Scott,

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Hiemstra
Sent: Thursday, May 22, 2014 19:19 PM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will,

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Thursday, May 22, 2014 10:00 AM
To: Discussion about Argus
Subject: RE: Overrides not suppressing notifies/multiple notifications

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of William Schroeder
Sent: Tuesday, May 20, 2014 00:40 AM
To: [email-masked]'
Subject: Overrides not suppressing notifies/multiple notifications

Will