Subject: argusctl summary problem

From: "Alexandru E. Ungur" <[email-masked]>
Date: Tue, 9 May 2006 16:38:30 +0300

Hi,

I have a minor problem with argusctl: it doesn't want to
display the summary:
# argusctl summary
ARGUS/2.0 404 Object Not Found

I need a way to have in console the numbers of up/down/override
and that seems like the perfect way to have those numbers.
Is there something I must do to make it work, have I missed
some config option... ?

Thank you in advance,
Alex

---

From: Jeremy Kister <[email-masked]>
Date: Tue, 09 May 2006 11:10:17 -0400

> ARGUS/2.0 404 Object Not Found

Hi Alexandru,

You've spelled status wrong.

# argusctl status
ARGUS/2.0 200 OK
status:    running
version:   dev-20051212
perlver:   5.8.3
osinfo:    SunOS 5.9 sun4u
objects:   3611
services:  3200
notifies:  136
uptime:    10:18:34
idle:      54.27% 55.09% 50.69%
monrate:   22.49 22.46 22.46 per second
#

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: "Alexandru E. Ungur" <[email-masked]>
Date: Tue, 9 May 2006 18:29:02 +0300

>>> sender: "Jeremy Kister" date: "Tue, May 09, 2006 at 11:10:17AM -0400" <<<EOQ
Hi :),

> You've spelled status wrong.
Yes, I agree, but I spelled summary right ;)

> monrate:   22.49 22.46 22.46 per second

# argusctl help
ARGUS/2.0 200 OK
about   return internal data fields of specified object
add_object      undocumented
annotate        add an annotation to an object--this will show on the
webpage
bye     disconnect
checknow        check now
children        return all children of specified object
console turn on console mode--session will get copies of log msgs
echo    returns its input
files   list all open file descriptors
flushpage       force cached data to be flushed
getchildrenparam        undocumented
getconf return the config data for an object
getconfigdata   return the config data for an object
getparam        undocumented
graphdata       return graphing data
help    no help at all
hup     restart the server
jiggle  undocumented
list    return all objects
log     return log data on object
loggit  add message to log
logindata       return decorations for login page
notify_ack      ack a notification
notify_detail   tell about notification
notify_getparam get per dst param
notify_list     list notifications
notify_setparam modify per dst params
override        set or remove an override
ovinfo  return override details
ovlist  return all objects in override
recycle undocumented
sched   list all scheduled tasks
setparam        undocumented
shutdown        shutdown the server
sort    undocumented
stats   return stats on object
status  returns server status
summary how many up, how many down, ...
^^^^^^^                                         <---- THAT is what I
                                                      wanted to spell ;)
svnsch  undocumented
update  set service status
webpage build webpage for object

Anyway, thank you for trying to help,
Alex

---

From: Jeremy Kister <[email-masked]>
Date: Tue, 09 May 2006 18:01:35 -0400

> ^^^^^^^                                         <---- THAT is what I

OIC, sorry about that; I tried to answer your question before leaving 
for a meeting and missed it's scope.

try argusctl summary object=Top
or argusctl summary object=Top:Group:whatever

-- 

Jeremy Kister

---

From: "Alexandru E. Ungur" <[email-masked]>
Date: Wed, 10 May 2006 08:30:47 +0300

>>> sender: "Jeremy Kister" date: "Tue, May 09, 2006 at 06:01:35PM -0400" <<<EOQ
YES! That's it! :) Thanks a lot!!!

# argusctl summary object=Top
ARGUS/2.0 200 OK
status: override
up: 40
down: 0
override: 2

Now I only have one wonder: why does it report for Top
less then the sum of individual groups?
I mean 
argusctl summary object=Top:Group1 +
argusctl summary object=Top:Group2
...
argusctl summary object=Top:GroupN

Gives me a total of 139 services up, and 2 overriden.
The per group summary is perfect and 100% identical to
the one given on the webpage. But why does the Top
report less?

Thanks again,
now I can fill my nice wmii statusbar[1] with argus summary :)

[1] http://pix.slax.no-ip.biz/wmii+argus.png