Subject: select failed: Bad file number

From: Jeremy Kister <[email-masked]>
Date: Sun, 03 Apr 2005 04:30:21 -0400

Argus told me one of my HTTP services had failed.

I logged into the box, acked the page, and did argusctl checknow

argusctl was just sitting there, not responding
I refreshed the web-page, and it eventually said that it couldnt connect
to the server.

i watched the log, and as fast as the tty could print it to me (26,635
entries in 76 seconds), i saw:
[2005/4/3 4:09:43] [17637] select failed: Bad file number

since argusctl wasnt responding, i kill -9'd the master argusd.

after everything reloaded, all seemed fine.

i re-issued the checknow, and it worked fine.

no idea if the checknow had anything to do with anything -- just FYI.

if there's extra info i can provide, let me know.

-- 

Jeremy Kister
http://jeremy.kister.net/

---

From: Jeff Weisberg <[email-masked]>
Date: Tue, 5 Apr 2005 20:05:26 -0400 (EDT)

| I logged into the box, acked the page, and did argusctl checknow
| 
| argusctl was just sitting there, not responding
| I refreshed the web-page, and it eventually said that it couldnt connect
| to the server.
| 
| i watched the log, and as fast as the tty could print it to me (26,635
| entries in 76 seconds), i saw:
| [2005/4/3 4:09:43] [17637] select failed: Bad file number
[...]
| if there's extra info i can provide, let me know.

does this happen often, or just once?

looking at the checknow code, if you do a checknow just
as argus starts the check on its own, something bad could
happen. now fixed in the current code, which I'll upload later
tonight.

	--jeff