Subject: Ping problems revisited

From: Hernández López Carlos <[email-masked]>
Date: Mon, 26 Dec 2005 16:16:52 -0600

Hello all, 
 
I´m new with Argus and have some problems configuring the ping service. I´m trying to create a group to monitoring a set of servers via ping, the problem is that "all servers start off as up and then all go down,  then stay down even though they are all up!!"
 
My fping its setuid root: 
 
$ ls -l /usr/local/sbin/fping
-rwsr-xr-x  1 root root 47301 Dec 13 12:50 /usr/local/sbin/fping

and my config file is something  like:

 .....

 .....

 .....

            Group "NetStat" {

                        frecuency: 300

                        Host "Subnet 6" {

                        hostname:170.70.6.146

                        Service Ping

                        }

                        Host "Subnet 49" {

                        hostname:170.70.49.142

                        Service Ping

                        }

                        Host "Subnet 91" {

                        hostname:170.70.91.27

                        Service Ping

                        }

}

Any ideas?

Thanks

Carlos

---

From: Jeremy Kister <[email-masked]>
Date: Mon, 26 Dec 2005 18:52:42 -0500

On 12/26/2005 5:16 PM, Hernández López Carlos wrote:
> I´m new with Argus and have some problems configuring the ping service.
[...]
> -rwsr-xr-x  1 root root 47301 Dec 13 12:50 /usr/local/sbin/fping

does argus know about this fping ?  try:

grep path_fping /usr/local/lib/conf.pl
 (substitute /usr/local/lib with whereever you put your argus libs)

>                         frecuency: 300

that's frequency: 300

>                         Host "Subnet 6" {

No point in making this Host -- change the others, also.
 Group "Subnet 6" {

> Any ideas?

can you ping 170.70.6.146 from your monitoring server?

try:
argusctl about object=Top:NetStat:Subnet_6:Ping_170.70.6.146 | grep reason

-- 

Jeremy Kister
http://jeremy.kister.net./
Got DARP? http://argus.tcp4me.com/darp.html