Subject: argus install on centos

From: "mustafa" <[email-masked]>
Date: Wed, 21 Nov 2012 22:46:03 +0530

Hi All,

I am new to argus and wished to install it on my centos server and give it a
try as I heard it can monitor asterisk server traffic also.

I am in the half way of installation. I have done everything exactly so far
according to 'INSTALL' file instructions however would anybody tell me
please what exactly do I need to do in the following step?:

8. configure your web server

      + be sure that $datadir is writable by the www user (or whatever uid
your

        web server runs as)

I mean which URL I need to access to configure the same?

Regards,

---

From: Scott Hiemstra <[email-masked]>
Date: Wed, 21 Nov 2012 13:02:45 -0500

Been a while since I have done an install on CentOS but from memory the 
gdata (directory) and the auth (file) will need to be chown'd apache or 
777 or whatever you feel is appropriate.  I don't think I have ever made 
the entire Argus data directory writable by Apache but others may have 
more input.  The Apache error log will give you all the insight you need 
into any issues you may encounter.

Scott

On 21.11.2012 12:16, mustafa wrote:
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: mustafa <[email-masked]>
Date: Thu, 22 Nov 2012 00:55:27 +0530

Gdata you mean to say what argus refers to as data directory? And what  
about file which one precisely?

Sorry for being so nerdy !!!

Sent from my iPhone

On Nov 21, 2012, at 11:32 PM, Scott Hiemstra <[email-masked]> wrote:

> Been a while since I have done an install on CentOS but from memory  
> the gdata (directory) and the auth (file) will need to be chown'd  
> apache or 777 or whatever you feel is appropriate.  I don't think I  
> have ever made the entire Argus data directory writable by Apache  
> but others may have more input.  The Apache error log will give you  
> all the insight you need into any issues you may encounter.
>
> Scott
>
>

---

From: Scott Hiemstra <[email-masked]>
Date: Wed, 21 Nov 2012 14:51:00 -0500

I happen to run Argus as root on this particular system so yours may be 
different depending on what you have going on.  This is a very 
restricted box so I honestly don't worry about running it as root.  This 
box is running CentOS 5.8 x86_64.  Argus lives in /var/argus and 
arguscgi lives in the main Apache cgi-bin.

I put these in my httpd.conf but I don't remember if the installer 
created the www directory or not:
Alias /img/ /var/argus/www/img/
Alias /sound/ /var/argus/www/sound/
Alias /css/ /var/argus/www/css/
Alias /js/ /var/argus/www/js/

Permisions of /var/argus:
drwxrwxrwx 11 root   root    4096 Oct 31 16:38 .
drwxr-xr-x 21 root   root    4096 Jan 20  2012 ..
-rw-r--r--  1 apache apache 12288 Nov  1 18:34 auth
drwxr-xr-x  2 root   root    4096 Apr 13  2011 config
-rw-r--r--  1 root   root    2982 Apr 11  2011 config.example
srwxrwxrwx  1 root   root       0 Oct 31 16:38 control
drwxrwxrwx  2 root   root    4096 Sep 29 03:59 gcache
drwxrwxrwx 28 root   root    4096 Apr 11  2011 gdata
drwxr-xr-x 28 root   root    4096 Apr 11  2011 html
drwxr-xr-x  2 root   root    4096 Apr 11  2011 locale
-rw-r--r--  1 root   root    8121 Oct 31 16:38 log
drwxr-xr-x  2 root   root    4096 Oct 31 16:39 notify
-rw-r--r--  1 root   root       5 Oct 31 16:39 notno
drwxrwxrwx  2 root   root    4096 Apr 11  2011 perl
drwxr-xr-x 28 root   root    4096 Apr 11  2011 stats
-rw-r--r--  1 root   root     106 Apr 12  2011 users
-rw-r--r--  1 root   root     144 Apr 11  2011 users.example
drwxr-xr-x  6 root   root    4096 Apr 12  2011 www

Hope that helps,
Scott

On 21.11.2012 14:25, mustafa wrote:
> Gdata you mean to say what argus refers to as data directory? And
> what  about file which one precisely?
>
>> have ever made the entire Argus data directory writable by Apache  but 
>> others may have more input.  The Apache error log will give you  all 
>> the insight you need into any issues you may encounter.
>>
>> Scott
>>
>>