Subject: Re: MySQL replication testing

From: Jeff Weisberg <[email-masked]>
Date: Fri, 24 Dec 2004 17:10:13 -0500 (EST)

Resurrecting an old thread:

| > I'm trying to monitor the replication status on my MySQL
| > server and I want to ensure that Slave_IO_Running and Slave_SQL_Running
| > are both Yes.  

[...]

| this could, possibly, yield false positives, though.  To be realy _really_
| sure, run some perl:

[...]

yes, this would work, but running an external script
to do something only slightly different than what argus
can already do, feels wrong.

it's just that no has filed the right feature request...

I don't have any MySQL servers to test with, but I just
added a feature that should get you what you want easier.

	Service DB {
		dsn:	DBI:mysql:host=hostname
		user:	username
		pass:	password
		sql:	show slave status
		rowfmt:	%{Slave_IO_Running} %{Slave_SQL_Running}
		expect:	Yes Yes
	}

notice new feature 'rowfmt'. comments welcome.

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 24 Dec 2004 19:13:23 -0500

>can already do, feels wrong.
Agreed :)

>it's just that no has filed the right feature request...
I'll have to keep that in mind..  :)

Speaking of features...  It would be really nice to see the current 
value of a test on the web page for that object.  (ping response time, 
snmp response, etc)  It would be even better if it could be viewed on 
both the web page, *AND* be included in the notify..  I haven't seen a 
way to do this thus far...  So...  Feature request!

>notice new feature 'rowfmt'. comments welcome.
Awesome!  I'll give this a shot!

This should work with any DBD?

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."