Subject: more Argus under mod_perl

From: "Jeremy Kister" <[email-masked]>
Date: Fri, 30 Jan 2004 18:35:46 -0500

I've noticed that the browser i have arguscgi running in suddenly skips from
the Top page to a seemingly random sub-object page .. on automatic or
manually refresh, it usually goes back to the top page.

seems to me there's a variable that leaked out into one of the httpds -- how
can i help track this down?

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Jeff Weisberg <[email-masked]>
Date: Sat, 31 Jan 2004 11:38:42 -0500 (EST)

| I've noticed that the browser i have arguscgi running in suddenly skips from
| the Top page to a seemingly random sub-object page .. on automatic or
| manually refresh, it usually goes back to the top page.
| 
| seems to me there's a variable that leaked out into one of the httpds -- how
| can i help track this down?

hmmm, odd.

are you running anything else under mod_perl?
is it always the same random page?
is the random page one that someone else is viewing at the same time?

try today's dev code. does it help?

---

From: Jeff Weisberg <[email-masked]>
Date: Sat, 31 Jan 2004 11:51:56 -0500 (EST)

is your mod_perl compiled into apache, or is it
a dynamically loaded module?

there are known issues using mod_perl as a
dynamically loaded module

	--jeff

---

From: "Jeremy Kister" <[email-masked]>
Date: Sat, 31 Jan 2004 23:41:59 -0500

> are you running anything else under mod_perl?
no

> is it always the same random page?
no

> is the random page one that someone else is viewing at the same time?
it appears to be, but since we have so many browsers watching argus, it'd be
very diffucult to be sure.

> try today's dev code. does it help?
I installed it this afternoon, and the Top page has stayed as Top so far...
perhaps you got it.

Jeremy Kister

---

From: "Jeremy Kister" <[email-masked]>
Date: Sat, 31 Jan 2004 23:45:58 -0500

> a dynamically loaded module?
loaded dynamically, not compiled in.  I never took the time to figure out
how to make mod_perl configure apache with my configure options :)

> dynamically loaded module

oh...   then i'll take the time now to figure it out :)

Thanks again

Jeremy Kister