Subject: A question and advise request

From: "Selin Ece Bozkurt, Radore" <[email-masked]>
Date: Thu, 21 Jul 2016 12:42:15 +0000

Hello,

Given configuration is below:

        Service UDP/SNMP {
        label:XMR02-TTI-IN
        calc:ave-rate-bits
        hostname:31.210.9.186
        oid:.1.3.6.1.2.1.31.1.1.1.6.5
        community:RH
        snmpversion:2c
        autoack:no
        maxvalue:500000000
        messagedn:XMR02-TTI-ATTACK-ABOVE-500Mb
        messageup:XMR02-TTI-ATTACK-END
        minvalue:100000000
        messagedn:XMR02-TTI-TRAFFIC-DECREASE-UNDER-100Mb
        messageup:XMR02-TTI-TRAFFIC-NORMAL

        notify:         mail:[email-masked]
        escalate: 10 notify:         mail:[email-masked]
        }

It is able to send email for bold parts ( for maxvalue conditions)

However, I want to identify yet another messageup and messagedn texts for minvalue for download traffic decrease under the same service above.
Since the code hasn't got if-else structure , I couldn't do this. So this situation may lead complexity.
Is there any way to do such a thing? ( It will send a separate mail for maxvalue and yet another separate mail for minvalue)

Very thanks,

Saygılarımla,
Selin Ece Bozkurt
Ağ Operasyon Merkezi
Uzman Yrd.

Network Operations Center
Asst. Specialist

RADORE
Metrocity AVM Levent, İstanbul - TÜRKİYE
T: 0212 344 04 04
http://www.radore.com<http://www.radore.com/>

[Radore] <http://www.radore.com/startup>

RADORE VERİ MERKEZİ HİZMETLERİ A.Ş.

---

From: [email-masked]
Date: Thu, 21 Jul 2016 14:01:02 -0400

Selin,

I'm not sure if what you specifically asked is possible, the author or 
someone else may chime in and say otherwise.  This doesn't meet your 
goal exactly but it should at least let you get your point across in the 
notification.  This will cause your notification to say either 
"XMR02-TTI-TRAFFIC SNMP TEST less than min" OR "XMR02-TTI-TRAFFIC SNMP 
TEST more than max" depending on what failed.

Service UDP/SNMP {
	label:XMR02-TTI-IN
	calc:ave-rate-bits
	hostname:31.210.9.186
	oid:.1.3.6.1.2.1.31.1.1.1.6.5
	community:RH
	snmpversion:2c
	autoack:no
	maxvalue:500000000
	minvalue:100000000
	messagedn:XMR02-TTI-TRAFFIC %r
	messageup:XMR02-TTI-TRAFFIC-NORMAL

Let me know if it helps,
Scott

On 2016-07-21 08:42, Selin Ece Bozkurt, Radore wrote:
> However, I want to identify yet another messageup and messagedn texts
> for minvalue for download traffic decrease under the same service
> above.
> Is there any way to do such a thing? ( It will send a separate mail
> for maxvalue and yet another separate mail for minvalue)
> 
> Very thanks,
> 
> 
> Saygılarımla,
> Selin Ece Bozkurt
> Ağ Operasyon Merkezi
> Uzman Yrd.
> 
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: [email-masked]
Date: Thu, 21 Jul 2016 14:05:29 -0400

You could take it one step further by adding the current value to the 
message with something like this.

         messagedn:XMR02-TTI-TRAFFIC %r - Current Rate: %v

Scott

On 2016-07-21 14:01, [email-masked] wrote:
> goal exactly but it should at least let you get your point across in
> the notification.  This will cause your notification to say either

---

From: "Selin Ece Bozkurt, Radore" <[email-masked]>
Date: Sat, 23 Jul 2016 07:32:55 +0000

Thanks for your reply.

I applied the following command you sent. If successful or not, I will inform you.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 21, 2016 9:05 PM
To: Discussion about Argus
Subject: Re: A question and advise request

You could take it one step further by adding the current value to the message with something like this.

Scott