Subject: Background image and sound not working

From: "Allen Miller" <[email-masked]>
Date: Fri, 2 Jun 2006 08:45:06 -0500

I have been using Argus for a number of years and love it.  From my first
install to my most recent upgrade to 3.4, I have never been able to get the
background image or sound to work.  While this is a trivial matter, I have
been unsuccessful at getting even the argus.logo.gif image to appear.

I installed Argus on a Red Hat 9 computer in the folder /netmon/argus.  I
have tried various arrangements in my Argus config file to point to the gif
location, but nothing works.  What am I doing wrong?

Here's the top portion of my config file:

# locations of various items on web pages

# info comment note

sirensong:      /sounds/whoopwhoop.wav
bkgimage:       /imgs/argus.logo.gif
icon:           /imgs/smile.gif
icon_down:      /imgs/sad.gif
nospkr_icon:    /imgs/nospkr.gif

I created the folders imgs and sound off root "/".  I have also created
these folders under /netmon/argus and changed the config file to point
directly to these files: bkgimage: /netmon/argus/imgs/argus.logo.gif  Of
course, I restart Argus after each config file change.  What am I missing?

Any help would be greatly appreciated.

Regards,

Allen Miller

---

From: Jeremy Kister <[email-masked]>
Date: Fri, 02 Jun 2006 13:55:11 -0400

> course, I restart Argus after each config file change.  What am I missing?

We usually dont deal with web server problems, but your case seems 
simple. Without seeing your relevant apache config, I'll take a stab:

your /imgs/ directory has to be at the same level as your /cgi-bin/ 
directory.

in other words if you have your argus web server root as:
  /web/argus/
and you have your arguscgi in
  /web/argus/cgi-bin/
then your images should be in
  /web/argus/imgs/
and your sound shoud be in
  /web/argus/sounds/

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: "Erni Juniati" <[email-masked]>
Date: Wed, 20 Sep 2006 19:00:12 -0000

Jeremy,
I realize you don't deal with web server problem but I have tried to put the
background image and sound in many possible ways but they are not working.
Here is how I install it:
config file and all other web files are is in /var/argus/
arguscgi is in /usr/local/apache/cgi-bin/
I tried putting "imgs" folder in /var/argus/ as well as /usr/local/apache/,
but both are not working.
Other than that Argus has been great. Your help is greatly appreciated!

Tks,
Erni

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jeremy Kister
Sent: Friday, June 02, 2006 1:55 PM
To: Discussion about Argus
Subject: Re: Background image and sound not working

--

Jeremy Kister
http://jeremy.kister.net./
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: "Gonzalo Perez Brun" <[email-masked]>
Date: Wed, 03 Jan 2007 12:21:38 -0300

Mr. Erni
    Here is how i change the argus "look like". Good luck!!!

Example in config file:
-----------------------------
# First declare in the httpd.conf (apache config file) where de "decoration" 
path is, and be carefull with de permissions of this files.
bkgimage:      /decoration/Logo.jpg
icon:             /decoration/smile.gif
icon_down:   /decoration/sad.gif
nospkr_icon  /decoration/animated_speaker.gif

Example whith CSS file:
-------------------------------
#in config file
style_sheet:    /decoration/argus.css
-------
#The css file example:
/******************************************
Hoja de Estilo por Gonzalo Perez Brun.
******************************************/
/* GROUPCHILD es el primer grupo a izquierda */
/* GRAPHS es el referente a la seccion de los gráficos */
*.GROUPCHILD a:hover, *.GRAPHS a:hover{
/*      color:  #FFFFFF; */
        color:#CCFFCC;
        background-color: #669966;
        text-decoration: blink;
        font-stretch:ultra-condensed
}
*.GROUPCHILD {
border-bottom-width:thick;
}
/* Es el cuerpo de toda la página */
body {
        background-image: url(/decoration/Logo.jpg);
}
/* Es el marco de toda la página */
*.MAIN {
border: outset;
}

head {
        text-align:right;
}
/* Esta es la barra donde figura el usuario */
*.TOPBAR {
        border:#669966;
        background-image:url(/decoration/bandera.gif);
        background-repeat:repeat-x;
        background-position:bottom;
        background-color: #666666;
        color:#CCCCCC;
        font-weight: bolder;
        font-style:italic;
        text-transform:uppercase;
        vertical-align:middle;

}
/* --------------------------------------------------------
GROUPDATA es la seccion donde está el nombre y el estado del grupo
        donde estás situado (arriba a la izquierda) */
table.GROUPDATA {
border:hidden;
/*      text-transform:uppercase;
        font-stretch:semi-expanded;
        font-size:medium; */
}

/* es la parte de estadísticas */
table.STATS{
        border-style:hidden;
}
/* Estilo de bononera lateral izquierda */
*.BUTTON {
border: 2px outset grey;
text-decoration:none;
text-align: center;
font-variant: normal;
}
*.BUTTON a:hover{
    text-decoration: blink;
        font-style:oblique;
        color:#FF0000;
}

>From: "Erni Juniati" <[email-masked]>
>Reply-To: [email-masked], Discussion about Argus 
><[email-masked]>
>To: "'Discussion about Argus'" <[email-masked]>
>Subject: RE: Background image and sound not working
>Date: Wed, 20 Sep 2006 14:58:36 -0400
>
>Jeremy,

_________________________________________________________________
Regístrate en el nuevo Windows Live Messenger beta. 
http://imagine-msn.com/minisites/messenger/default.aspx?locale=es-ar

---

From: "Erni Juniati" <[email-masked]>
Date: Wed, 3 Jan 2007 12:11:24 -0500

Hi Gonzalo,
Thank you so much! This works.

Ms Erni

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Gonzalo Perez Brun
Sent: Wednesday, January 03, 2007 10:22 AM
To: [email-masked]
Subject: RE: Background image and sound not working

Mr. Erni

Example in config file:

Example whith CSS file:

head {
        text-align:right;
}

}