Subject: config file incompatibility

From: Jeff Weisberg <[email-masked]>
Date: Mon, 15 Jan 2007 21:45:06 -0500 (EST)

I changed a bunch of parameters which previously
were not inheritable to now be inheritable.

if your config file depended on them not being
inherited, you may need to adjust your config.

Q: but jeff, how do I know which parameters have changed?

A: using the new argus code, you can run
	argusd -DS version

  if you replace the word version, with the version
  you are currently using, argus will spit out a
  list of new and changed parameters.

  a few of the more important params which have changed
  are: overridable, sendnotify, messageup/dn, depends

Q: but jeff, my config depended on the non-inheritance
   of a certain parameter, how can I change my config?
   what can I do?

A: using the new argus code, you can now say
	parameter!: value

  adding the ! will prevent this value from being inherited.
  and, yes, you can specify both 'param' and 'param!' 
  and have one value inherited and one not.

  Group "foo" {
    sendnotify!:  yes   # this group will send notifies
    sendnotify:   no    # children will not
    [...]

---

From: Jeremy Kister <[email-masked]>
Date: Wed, 17 Jan 2007 12:02:46 -0500

>     sendnotify:   no    # children will not

but jeff, you've made my head hurt, and i have no advil :(

In order not to receive notifications of simple Group objects, is the 
preferred configuration to now use a sendnotify!: no inside every group ?

61836 Top:Essential_Services is UP - 17/Jan 09 -> 07

-- 

Jeremy Kister
http://jeremy.kister.net./