Subject: /var/argus/config' on line 33 - Cannot depend on self (ignored)

From: "Frank van den Diepstraten" <[email-masked]>
Date: Wed, 14 Feb 2007 08:45:44 +0100

Hi,

I've just installed argus to a new machine but with the same configs i get
an error:

monitor:/home/frank# tail -f /var/log/syslog |grep argus
Feb 14 08:38:44 monitor Argus[1928]: shutting down - rc.argusd stop
Feb 14 08:38:46 monitor Argus[1944]: ERROR: in file '/var/argus/config' on
line 33 - Cannot depend on self (ignored)
Feb 14 08:38:46 monitor Argus[1944]: Control server: listening on
unix//var/argus/control
Feb 14 08:39:09 monitor Argus[1944]: shutting down - rc.argusd stop
Feb 14 08:39:15 monitor Argus[1963]: ERROR: in file '/var/argus/config' on
line 33 - Cannot depend on self (ignored)
Feb 14 08:39:15 monitor Argus[1963]: WARNING: in file '/var/argus/config' on
line 33 - Cannot resolve dependency:
Top:Servers_Nikhef:conceptsfa.nl:Ping_213.197.28.2
Feb 14 08:39:15 monitor Argus[1963]: ERROR: in file '/var/argus/config' on
line 33 - Cannot depend on self (ignored)
Feb 14 08:39:15 monitor Argus[1963]: WARNING: in file '/var/argus/config' on
line 33 - Cannot resolve dependency:
Top:greenvalley:GV_Racinginfo:Ping_213.197.29.155
Feb 14 08:39:15 monitor Argus[1963]: ERROR: in file '/var/argus/config' on
line 33 - Cannot depend on self (ignored)
Feb 14 08:39:15 monitor Argus[1963]: WARNING: in file '/var/argus/config' on
line 33 - Cannot resolve dependency:
Top:greenvalley:GV_Gemeente_Brunssum:Ping_213.197.29.158
Feb 14 08:39:15 monitor Argus[1963]: Control server: listening on
unix//var/argus/control

my config looks like this:

debug:  no

syslog:         local1
notify:         mail:<emailadress>
escalate:       17 sms3:storingsdienst
frequency:      300
community:      public
renotify:       3600

header_all:     <H2>Monitoring</H2>
icon:           /argus/smile.gif
icon_down:      /argus/sad.gif
nospkr_icon:    /argus/nospkr.gif

Method "sms" {
        command:        /usr/bin/putsms -d /dev/ttyS0 number "%O %S %E"
}
Method "sms2" {
        command:        /root/sendsms %R
        send:           %O\n%o\n%S\n%E
}
Method "sms3" {
        command:        /usr/local/bin/sendsmsstoring
        send:           %O\n%o\n%S\n%E
}
Include "/var/argus/config.d/concepts-breda"
Include "/var/argus/config.d/concepts-nikhef"
Include "/var/argus/config.d/dedicated-breda"
Include "/var/argus/config.d/routers"
Include "/var/argus/config.d/switches"
Include "/var/argus/config.d/greenvalley"
Include "/var/argus/config.d/adslcheck"

When I login to argus everything seems to work but the red message that
there are errors is still there.

Idea's?

Regards,

Frank van den Diepstraten
Systeembeheerder

Concepts ICT
St. Ignatiusstraat 265
4817 KK Breda
tel: 076-5221555
fax: 076-5310531
www.concepts-ict.nl / www.supersneladsl.nl / www.hostingtotaal.nl /
www.fiberenwireless.nl

Disclaimer
De informatie verzonden met dit emailbericht is uitsluitend bestemd voor de
geadresseerden.Gebruik van deze informatie door anderen dan de geadresseerde
is
verboden. Openbaarmaking, vermenigvuldiging, verspreiding en/of verstrekking
van deze informatie aan derden is niet toegestaan. Concepts ICT en/of de aan
haar gelieerde ondernemingen staat niet in voor juiste en volledige
overbrenging van de inhoud van een verzonden e-mail, noch voor tijdige
ontvangst daarvan. U wordt verzocht, indien het bericht niet voor u bestemd
is,
het retour te sturen naar de afzender. Wij wijzen iedere aansprakelijkheid
af
in verband met mogelijke gevolgen en/of schade van een juiste en volledige
verzending en ontvangst van de inhoud van deze e-mail. Overeenkomsten en
andere
verplichtingen kunnen Concepts ICT slechts binden indien deze schriftelijk,
per
brief of telefax zijn aangegaan. Uit dit emailbericht kunnen derhalve géén
contractuele) verplichtingen voor Concepts ICT ontstaan.

---

From: "Scott Hiemstra" <[email-masked]>
Date: Wed, 14 Feb 2007 06:41:19 -0500

I Have no idea what the real problem is but to assist yourself in debugging
I would highly recommend not using "Include" statements.  Instead of having
a file named config, create a directory named config and put a bunch of
files in there which have numeric leading names.

This is what I would do if I was the one fixing your install.

Stop Argus

Edit your config and remove all of the Include statements.

cd /var/argus/
mv config config.orig
mkdir config
mv config.orig config/001-General
cp config.d/concepts-breda config/002-concepts-breda
cp config.d/concepts-nikhef config/003-concepts-nikhef
cp config.d/dedicated-breda config/004-dedicated-breda
cp config.d/routers config/005-routers
cp config.d/switches config/006-switches
cp config.d/greenvalley config/007-greenvalley
cp config.d/adslcheck config/008-adslcheck

Start Argus

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Frank van den Diepstraten
Sent: Wednesday, February 14, 2007 2:46 AM
To: [email-masked]
Subject: /var/argus/config' on line 33 - Cannot depend on self (ignored)

Hi,

debug:  no

syslog:         local1

Method "sms" {

Idea's?

Regards,

Concepts ICT
St. Ignatiusstraat 265
4817 KK Breda
tel: 076-5221555
fax: 076-5310531

Disclaimer

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist