Subject: Thanks for the help with depends:

From: "Chris Stith" <[email-masked]>
Date: Tue, 30 Mar 2004 13:57:11 -0600

Jeremy hit it pretty much on the head. I wasn't
_quite_ assuming that depends: is inherited, but
I was making the wrong assumption that members of
a group were checked as subbranches of that group.
Not quite the same thing, but the same effect in
this case.

I'll move my dependencies into the services. Too
bad that'll cause so much more text to be handled
in the config. I've already got over 130 kilobytes
worth of config file to keep straight. Time to
automate I guess.

Speaking of inheritance, is it possible to override
a notify: in a smaller scope? I have a notify: at
the tope of my config, then another notify: inside
a particular group. The one inside that group isn't
being used.

    notify: mail:[email-masked]

    Group "testgroup" {
        hostname: 10.0.0.3
        Service Ping
        notify: mail:[email-masked]
    }

When that service fails, the address(es) for the
out notify: get email, but not the inner one. So I
tried just moving the notify to the top, which I
didn't think would make a difference:

    notify: mail:[email-masked]

    Group "testgroup" {
        notify: mail:[email-masked]
        hostname: 10.0.0.3
        Service Ping
    }

...and now it says it's transmitting to all the
addresses from both places.

-- 
Chris S.
[email-masked]
Family Online, 888-332-6843

---

From: Jeff Weisberg <[email-masked]>
Date: Tue, 30 Mar 2004 16:27:54 -0500 (EST)

| Speaking of inheritance, is it possible to override
| a notify: in a smaller scope? I have a notify: at
| the tope of my config, then another notify: inside
| a particular group. The one inside that group isn't
| being used.
| 
|     notify: mail:[email-masked]
| 
|     Group "testgroup" {
| 	  hostname: 10.0.0.3
| 	  Service Ping
| 	  notify: mail:[email-masked]
|     }

this is not a valid syntax. you should be seeing errors
in your logs when you start argus.

data must be put before objects.
watch:

	Group "name" {
		data

		objects
	}

and not:

	Group "name" {
		objects

		data
	}

	--jeff

---

From: "Jeremy Kister" <[email-masked]>
Date: Wed, 31 Mar 2004 01:34:44 -0500

> addresses from both places.

Also, at least in the current version, i beleive your group notify overrides
your general notify --
if your "testgroup" goes down, only [email-masked] will be notified.

if you want both addresses to be notified, you can use:
  Group "testgroup" {
    notifyalso: mail:[email-masked]
    ...

Jeremy Kister
www.jeremykister.com/jeremy/