Subject: Re: Diskspace monitoring using SNMP

From: Jeff Weisberg <[email-masked]>
Date: Tue, 22 Jul 2008 11:08:45 -0400 (EDT)

| this should work - but not tested:
| 
|   Service UDP/SNMP {
|     # data for behind the scenes
|     hidden: yes
|     oid: .1.3.6.1.2.1.25.2.3.1.6.2
|     uname: disk_used_c
|   }
|   Service Compute {
|     # n.b. the 10000000000, below, is total disk size in bytes
|     expr: ( %{Top:Servers:machine:disk_used_c} / 10000000000 ) * 100
|     gr_range: 0-100
|     ylabel: percent used
|     graph: yes
|     label: disk usage on C:
|     uname: disk_usage_c
|     maxvalue: 90
|     messagedn: disk usage percent at %v on %o{ip::hostname} C:
|     messageup: disk usage better on %o{ip::hostname} C:
|   }

since this compute is just scaling the result, it may be easier to
just specify a scale parameter instead of a compute service:

   Service UDP/SNMP {
     oid:      .1.3.6.1.2.1.25.2.3.1.6.2
     scale:    100000000
     uname:    disk_used_c
     maxvalue: 95
     # ...
   }

alternatively, if you are using ucd snmpd, there is
a 'dskPercent' oid: .1.3.6.1.4.1.2021.9.9.<disk>

and using the current dev argus code, you can simply say:

	oid:  dskPercent[/usr]

---

From: "Scott Hiemstra" <[email-masked]>
Date: Tue, 22 Jul 2008 11:41:16 -0400

Thank you both, these definitely give me a better direction to go than I was
heading.  I wasn't aware of the 'dskPercent' oid and the new argus feature
is even easier.

Thanks,
Scott