Subject: How to setup argus as a interface error alarm ?

From: "Mr. James W. Laferriere" <[email-masked]>
Date: Wed, 6 Feb 2008 10:05:33 -0900 (AKST)

Hello All ,
 		I am attempting to setup argus to allow me to monitor 'interface 
errors' .  But every time I get an error & identify the cause & correct it . 
Without rebooting the device (ie: cisco switch/router) .  I have to edit the 
config file to set an 'expect: 1' or whatever the value is .  Is there a method 
to say 'if this counter increases alarm' ?

 		Tia ,  JimL
-- 
+------------------------------------------------------------------+
| James   W.   Laferriere | System    Techniques | Give me VMS     |
| Network&System Engineer | 2133    McCullam Ave |  Give me Linux  |
| [email-masked] | Fairbanks, AK. 99701 |   only  on  AXP |
+------------------------------------------------------------------+

---

From: RayC <[email-masked]>
Date: Wed, 06 Feb 2008 14:39:02 -0500

Mr. James W. Laferriere wrote:
>     Hello All ,
>         I am attempting to setup argus to allow me to monitor 
> 'interface errors' .  But every time I get an error & identify the 
> cause & correct it . Without rebooting the device (ie: cisco 
> switch/router) .  I have to edit the config file to set an 'expect: 1' 
> or whatever the value is .  Is there a method to say 'if this counter 
> increases alarm' ?
>
>         Tia ,  JimL
This works for me on my C2801s. Try:

    Group "Errors-F0/0-LAN" {
        community:    private
        details:   
        drawgrid:    yes
        graph:    yes
        hostname:    10.192.8.1
        Group "Errors-IN" {
            info:     Errors-F0/0-LAN IN
            title:     Errors-F0/0-LAN IN
            ylabel:    Errors INPUT
            Service UDP/SNMP {
                calc:    ave-rate-bits
                label:    Errors-IN
                maxvalue:    10
                messagedn:     Errors-F0/0-LAN INPUT EXCEEDED
                messageup:     Errors-F0/0-LAN INPUT Normal
                note:   
                oid:    ifInErrors.1
            }
        }

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: "Mr. James W. Laferriere" <[email-masked]>
Date: Sat, 9 Feb 2008 18:20:03 -0900 (AKST)

Hello RayC ,  Below works like a charm .  Thank you .  JimL

On Wed, 6 Feb 2008, RayC wrote:
>> errors' .  But every time I get an error & identify the cause & correct it 
>> . Without rebooting the device (ie: cisco switch/router) .  I have to edit 
>> the config file to set an 'expect: 1' or whatever the value is .  Is there 
>> a method to say 'if this counter increases alarm' ?
>>
>>         Tia ,  JimL
>       details:          drawgrid:    yes
>               note:                  oid:    ifInErrors.1