Subject: maxvalue logic

From: "Jeremy Kister" <[email-masked]>
Date: Thu, 15 Jan 2004 19:20:28 -0500

i purposely broke my perl config on one of my mail servers today. (I moved
/usr/local/lib/perl5/ to /usr/local/lib/perl5.old/)

to my suprise, argus did not detect some of the perl-required services on
that machine as down.  further investigation shows that they were all
'maxvalue' tests.  debugging shows:

status up
test unprintable data structure
test::alpha 1
test::currvalue BEGIN failed--compilation aborted at
/usr/local/script/qmqtool line 14.
test::maxvalue 1200
test::rawvalue BEGIN failed--compilation aborted at
/usr/local/script/qmqtool line 14.
test::testedp 1

is this test passing because the regex goes something like /(\d+)/ instead
of something like /^(\d+)$/ ?

what is the recommeded solution to this problem?

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Jeff Weisberg <[email-masked]>
Date: Fri, 16 Jan 2004 11:13:24 -0500 (EST)

| i purposely broke my perl config on one of my mail servers today. (I moved
| /usr/local/lib/perl5/ to /usr/local/lib/perl5.old/)
| 
| to my suprise, argus did not detect some of the perl-required services on
| that machine as down.  further investigation shows that they were all
| 'maxvalue' tests.  debugging shows:
| 
| status up
| test unprintable data structure
| test::alpha 1
| test::currvalue BEGIN failed--compilation aborted at
| /usr/local/script/qmqtool line 14.
| test::maxvalue 1200
| test::rawvalue BEGIN failed--compilation aborted at
| /usr/local/script/qmqtool line 14.
| test::testedp 1

well, this makes sense.

the value of "BEGIN failed--compilation aborted at /usr/local/script/qmqtool line 14"
is less than 1200

| is this test passing because the regex goes something like /(\d+)/ instead
| of something like /^(\d+)$/ ?

what regex?

| what is the recommeded solution to this problem?

when setting up monitoring, it is important to determine
what you should monitor and how those things can fail.

in the above case, if you are in an environment where
people might be breaking perl, and you use perl for
critical things, maybe you should have a
"perl is properly installed" test.

	--jeff