Subject: Argus 3.4_RC-20050419 SNMP graphing problem

From: Andy <[email-masked]>
Date: Thu, 5 May 2005 17:39:40 +0100

While doing some testing, and playing with the graphing of SNMP data
I've come across a odd problem.
The graphing produces the graphs (always a good start) but seems to
pull no data in causeing the element to go straight into alert. Graphs
themselves show no data flowing in either direction.
The Linux box in question is talking fine to the router using the
listed mib's using a quick bit of perl from the examples in the
Net::SNMP pod.

The slice of the config is included below.

Group "Router" {
        drawgrid:       yes
        graph:  yes
        title:  Bandwidth
        ylabel: bits per second
        Group "My Router" {
                Service UDP/SNMP {
                        calc:   ave-rate-bits
                        frequency:      5
                        hostname:       192.168.7.1
                        label:  In
                        maxvalue:       2000000
                        oid:    .1.3.6.1.2.1.2.2.1.10.6
                }
                Service UDP/SNMP {
                        calc:   ave-rate-bits
                        frequency:      5
                        hostname:       192.168.7.1
                        label:  Out
                        maxvalue:       2000000
                        oid:    .1.3.6.1.2.1.2.2.1.16.6
                }
        }
}

---

From: Jeff Weisberg <[email-masked]>
Date: Thu, 5 May 2005 22:56:23 -0400 (EDT)

| While doing some testing, and playing with the graphing of SNMP data
| I've come across a odd problem.
| The graphing produces the graphs (always a good start) but seems to
| pull no data in causeing the element to go straight into alert. Graphs
| themselves show no data flowing in either direction.
| The Linux box in question is talking fine to the router using the
| listed mib's using a quick bit of perl from the examples in the
| Net::SNMP pod.

it doesn't sound like a graphing problem, it sounds like
you aren't getting any snmp response from your router.

wrong community string?

what does the debugging page show as 'srvc::reason'?

	--jeff