Subject: Questions regarding overrides and Resolver (BUG?)

From: <[email-masked]>
Date: Fri, 7 Jul 2006 11:14:08 +0200

Hi,

Thank you for a great product.

We are trying to launch our argus-based monitoring services, but are having a couple of issues.

First of all, we've discovered something I can't call anything but a bug. We are using a general notify-method on our entire range of monitored services.

If we specify in the config-header
 Resolver 
 notify: mail:someone@host
We simply don't get any notifications (and debugging aren't showing the value has been set), whilst if we specify it like
 notify: mail:someone@host
 Resolver
We will get the results fine.

Is there some explanation for this/patch to fix it?

Secondly, we have a problem with how overrides work. In our Top-node, we are using a mix of hosts and groups as children.
* If we override a host within a group, our top-view shows a couple of overridden tests immediately, even if the tests are not failed tests.
* However, if we override the entire group of hosts, we don't see anything in the main-view, and if one of the tests fails, it shows up as a downed service (not override).
* If we override a host that is directly specified in the Top-node, it won't show up as overridden, and if it's services fails, it shows up as down (not under override).
So, to summarize, the web-views of Argus seems to be a bit inconsistent in how an overridden host/group is interpreted, at least from my POV. Notifications behave like expected, though. Any explanation for this?

Regards
/ Ulrik

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 10 Jul 2006 13:54:41 -0400 (EDT)

| First of all, we've discovered something I can't call anything but a bug. We are 
| using a general notify-method on our entire range of monitored services.
| 
| If we specify in the config-header
|  Resolver 
|  notify: mail:someone@host
| We simply don't get any notifications (and debugging aren't showing the value has
|  been set), whilst if we specify it like
|  notify: mail:someone@host
|  Resolver
| We will get the results fine.
| 
| Is there some explanation for this/patch to fix it?

if you click on your 'Error Log', you should see
a bunch of errors complaining about your config.

your config file must be of the format:
	data
	methods and resolvs
	groups and services

there is no bug. there is no patch.
your 'notify' must be before your 'resolv'.

---

From: <[email-masked]>
Date: Tue, 11 Jul 2006 09:04:08 +0200

Allright.

That explains it. Thank you!

Regards
/ Ulrik 

-----Ursprungligt meddelande-----
Från: [email-masked] [mailto:[email-masked]] För Jeff Weisberg
Skickat: den 10 juli 2006 19:55
Till: [email-masked]
Ämne: Re: Questions regarding overrides and Resolver (BUG?)

| First of all, we've discovered something I can't call anything but a 
| bug. We are using a general notify-method on our entire range of monitored services.
| 
| If we specify in the config-header
|  Resolver
|  notify: mail:someone@host
| We simply don't get any notifications (and debugging aren't showing 
| the value has  been set), whilst if we specify it like
|  notify: mail:someone@host
|  Resolver
| We will get the results fine.
| 
| Is there some explanation for this/patch to fix it?

if you click on your 'Error Log', you should see a bunch of errors complaining about your config.

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist