Subject: RE: 'depends' directive in config files

From: Scott Hiemstra <[email-masked]>
Date: Mon, 26 Oct 2009 20:10:19 -0400

Gonzalo,

I try to think of it like this...

Argus <-> test1 <-> test2

If test1 is  a router and test2 is a host on the other side of that router, there is no route to test2 if test1 goes down.  I would then setup a dependancy statement where all tests to test2 depend on test1 being up.

Psuedo-code  for the logic process would be:
If test1 is down then
	do nothing
Else
	perform tests for test2
Endif

Something like this would go into the config for test2:
depends: Top:test1

I can't really think of any other way to explain it, perhaps someone else can jump in if this doesn't answer your question.

Thanks,
Scott

-----Original Message-----
From: Gonzalo Perez Brun <[email-masked]>
Sent: Monday, October 26, 2009 6:32 PM
To: Listado de Colsultas ARGUS <[email-masked]>
Subject: RE: 'depends' directive in config files

Mr. Scott:
          Sorry for asking this but, i need to figureout how this works. If I have a test1 for example, and test1 depends on test2. If the test1 falldown, test2 stop being tested and assume that is down too?
          Thanks.

Gonzalo.

> From: [email-masked]
> To: [email-masked]
> Date: Wed, 21 Oct 2009 21:21:25 -0400
> Subject: RE: 'depends' directive in config files
> 
> The only real documentation I ever found for it was http://argus.tcp4me.com/config-details.html but it is very simple to use.
> 
> Service TCP/URL {
>      url:            http://someurl.somedomain.com
>      label:          Some Friendly URL Name
>      browser:        Mozilla/5.0 (compatible; Argus - just testing)
>      depends:        Top:Servers:ServerName:Ping_servername.somedomain.com
> }
> 
> This would assume that http://someurl.somedomain.com was hosted on a serv

[The entire original message is not included]

---

From: Gonzalo Perez Brun <[email-masked]>
Date: Thu, 29 Oct 2009 21:36:28 -0200

Thanks Scott. I hope that this behavior is what jeff writes in argus code.
Sombody check this with tcpdump?

> From: [email-masked]
> Date: Mon, 26 Oct 2009 20:10:19 -0400
> To: [email-masked]
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist
 		 	   		  
_________________________________________________________________
Revisá tus correos de Hotmail en tu BlackBerry - Clic Aquí
http://www.windowsliveentublackberry.com