Subject: new features

From: Jeff Weisberg <[email-masked]>
Date: Fri, 24 Dec 2004 17:15:41 -0500 (EST)

| notice new feature 'rowfmt'. comments welcome.

today's dev code also adds tests for
TCP/SIP, UDP/SIP, and UDP/IAX2
for anyone running VOIP

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 24 Dec 2004 19:13:54 -0500

>TCP/SIP, UDP/SIP, and UDP/IAX2
Excellent!  Now I just need to get VoIP going :)

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."

---

From: Darren Ellis <[email-masked]>
Date: Fri, 24 Dec 2004 19:20:01 -0500

Hi,

I use Argus to monitor our network, which has xDSL, wireless and 
dialup.  One feature that I haven't found out how to configure is event 
correlation.  Is there a way to set up a hierarchy of nodes such that we 
get alerted only when a parent node goes down, and the other nodes 
"behind" it, from Argus' view, are simply marked unreachable?

Thanks much.

Darren Ellis

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 24 Dec 2004 19:30:29 -0500

Darren Ellis wrote:

> dialup.  One feature that I haven't found out how to configure is 
> event correlation.  Is there a way to set up a hierarchy of nodes such 
> that we get alerted only when a parent node goes down, and the other 
> nodes "behind" it, from Argus' view, are simply marked unreachable?

Yeah, you need to set up a dependency tree... 

I'm not sure where it is in the documentation, but you set it up like 
this : (note the depends keyword)

Group "UPS" {
   Host "UPS 1" {
      hostname: 10.1.0.11
      graph: yes
      Service Ping
      Service UDP/SNMP {
         depends: Top:UPS:UPS_1:Ping_10.1.0.11
         label: On Battery
         community: dream-on
         oid: .1.3.6.1.4.1.318.1.1.1.4.1.1.0
         eqvalue: 2
         graph: no
      }
}

Not sure if you can set up multiple or circular dependencies..  I never 
tried...  :)

---

From: Darren Ellis <[email-masked]>
Date: Fri, 24 Dec 2004 19:42:27 -0500

Jason,

Thanks for the clue.  I'll give it a whirl.

Darren

Jason 'XenoPhage' Frisvold wrote:

>> event correlation.  Is there a way to set up a hierarchy of nodes 
>> such that we get alerted only when a parent node goes down, and the 
>> other nodes "behind" it, from Argus' view, are simply marked 
>> unreachable?
>
>
> Not sure if you can set up multiple or circular dependencies..  I 
> never tried...  :)
>
>> Thanks much.
>>
>> Darren Ellis
>
>
>

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 24 Dec 2004 19:48:24 -0500

> Thanks for the clue.  I'll give it a whirl.

No problem, happy holidays!