Subject: GRAPHICS

From: rajeshkanna gk <[email-masked]>
Date: Tue, 1 Dec 2009 17:20:12 +0530

Hi,

 Am facing problem in installing GD.pm. can any one guide me in a simple
way?.
even i installed GD.pm. argus in not finding GD.pm. have followed the below
procedure.

Graphing
Graphing support was added in version 3.2
Additional Prerequisites
GD.pm is needed. this module in turn requires libgd, libjpeg, libpng, and
possibly more.
Additional Directories
2 additional directories need to be created to contain graph data:
$datadir/gcache - needs to be writable by the web server. will contain
cached graph images.
$datadir/gdata - needs to be writable by argusd and readable by the web
server. will contain graph data, one ~100k file per item.
Enabling Graphing

Regards,
Rajesh Kanna G K

---

From: yary <[email-masked]>
Date: Tue, 1 Dec 2009 08:30:07 -0800

What platform are you using?

perl -MCPAN -e shell
> install GD

should work on unix-y ones. On ActiveState, use their "ppm" (perl
package manager).

-y

---

From: Jeremy Kister <[email-masked]>
Date: Tue, 01 Dec 2009 14:20:47 -0500

> even i installed GD.pm. argus in not finding GD.pm. have followed the below

After installing GD and all of it's prerequisites, did you go into your 
argus source tree and ./Configure; make ; make install; stop argus and 
start argus?

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: Ivan <[email-masked]>
Date: Tue, 1 Dec 2009 17:39:14 -0800 (PST)

I wonder if you need to either:

1) have GD installed before installing argus
or
2) add the line    use GD::Graph;  into the argusd  file

--- On Tue, 12/1/09, Jeremy Kister <[email-masked]> wrote:

From: Jeremy Kister <[email-masked]>
Subject: Re: GRAPHICS
To: "Discussion about Argus" <[email-masked]>
Date: Tuesday, December 1, 2009, 11:20 AM

> even i installed GD.pm. argus in not finding GD.pm. have followed the below

After installing GD and all of it's prerequisites, did you go into your argus source tree and ./Configure; make ; make install; stop argus and start argus?

-- 
Jeremy Kister
http://jeremy.kister.net./
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist