Subject: perl installation issues

From: Denis Nikitin <[email-masked]>
Date: Sun, 8 Feb 2004 18:06:51 +0000

Hi All,
I've just installed Argus and did very basic initial config for our web 
applications monitoring.
Everything work fine apart from cgi part.
I don't know perl and therefore one can find my problems very newbish.
I am running redhat 8, Apache/2.0.40
Here my config in brief:
Link has been created from 
/var/www/cgi-bin/arguscgi -> /usr/local/sbin/arguscgi
Config for Argus in httpd.conf done as recommended in docs for a virtual site:
<VirtualHost x.x.x.x>
        ServerAdmin [email-masked]
        DocumentRoot /var/www/html/
        ServerName x.x.x.x
        <Location />
                SetHandler   perl-script
                PerlHandler  Argus::Web
                allow from all
        </Location>
</VirtualHost>

When trying to access argus url I've got Internal Server Error page and
most interesting part is in apache log files.
First it couldn't find Argus::Web.pm
Can't locate Argus/Web.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/
i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/
i386-linux-thread-multi ... ) 
etc.
After I made a link 
ln -s /usr/local/lib/argus /usr/lib/perl5/site_perl/5.8.0/Argus
assuming it can't find Argus modules logs started to show different errors:
Undefined subroutine &Control::command_install called at /usr/lib/perl5/
site_perl/5.8.0/Argus/Web.pm line 550.!Compilation failed in require at (eval 
1) line 3.!

etc. etc.
I understand that this is probably Perl cannot find all the necessary Argus 
modules, but as I am not a Perl expert, I have no idea how to improve that 
situation.
Any help and advice are very much appreciated.
Denis.

---

From: Jeff Weisberg <[email-masked]>
Date: Sun, 8 Feb 2004 13:43:20 -0500 (EST)

| I've just installed Argus and did very basic initial config for our web 
| applications monitoring.
| Everything work fine apart from cgi part.
| I don't know perl and therefore one can find my problems very newbish.

it looks like you are try to configure for mod_perl,

were you able to get it working correctly using cgi first?

| When trying to access argus url I've got Internal Server Error page and
| most interesting part is in apache log files.

no. not interesting.

you are missing the 'PerlRequire' line.

| After I made a link 
| ln -s /usr/local/lib/argus /usr/lib/perl5/site_perl/5.8.0/Argus

your on your own here, but I can't see that being a very good idea.

	--jeff