Subject: Install Argus 3.6 on Fedora 14

From: Allen Miller <[email-masked]>
Date: Mon, 22 Aug 2011 07:38:36 -0500

I've had Argus installed on a RedHat 9 machine for years and feel it's time to upgrade.  I'm attempting to install Argus on Fedora 14 and receive the following error message in my browser:

	Can't locate object method "TIEHASH" via package "0" at /var/www/cgi-bin/arguscgi line 330.

The machine is fully patched and all programs appeared to install correctly.  Here are my version numbers:

Argus 3.6
httpd-2.2.17-1.fc14.i686
BerkleyDB-5.2
fping-2.4b2-10.fc12.i686
qpage-3.3
perl-5.12.3-143.fc14.i686
sendmail-8.14.4-10.fc14.i686

Has anyone experienced this problem before?  Will Argus run on Fedora 14?  Any help would be greatly appreciated.

Best regards,

Allen Miller

---

From: Jason Azze <[email-masked]>
Date: Wed, 31 Aug 2011 11:45:10 -0400

On Mon, Aug 22, 2011 at 8:38 AM, Allen Miller
<[email-masked]>wrote:

> I've had Argus installed on a RedHat 9 machine for years and feel it's time
> to upgrade.  I'm attempting to install Argus on Fedora 14 and receive the
> following error message in my browser:
>
> Hi, Allen,

This is a total WAG, but you may need to install the Perl module Tie::Hash.
It may not be part of the Perl distribution you are running.

--Jason

---

From: Allen Miller <[email-masked]>
Date: Wed, 31 Aug 2011 11:01:47 -0500

Hi, Jason.

I believe my error occurred due to a typo on my part when I installed Argus.  When compiling, I typed ./Configure --data-dir=/usr/local/BerkleyDB.5.2 --db_type=DB_FILE instead of ./Configure --data-dir=/usr/local/BerkleyDB.5.2 --db_type=DB_File (note the change in case of word DB_File)  That made all the difference.

Now, on a different note, I'm using the same config file I used in version 3.4, but now Argus seems to tally the number of services monitored.  For instance, If I monitor 10 routers by ping and service sshd, the number of routers in this group is 20, not 10.  Is this by design?

Thanks for the response.

Al

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jason Azze
Sent: Wednesday, August 31, 2011 10:45 AM
To: Discussion about Argus
Subject: Re: Install Argus 3.6 on Fedora 14

--Jason
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist