Subject: how do I capture whole argus variable without truncation ?

From: Ivan <[email-masked]>
Date: Thu, 2 Apr 2009 15:47:30 -0700 (PDT)

Hello,

In argus,  after I've run 'check now' on a sensor two or three times; I'd like
to get the whole string returned by the object.

Most often the GUI output of   test::currvalue will truncate the output like:

stats::yearlyunprintable data structure
statusup
testunprintable data structure
test::alpha1
test::currvalue******************************************************************************~x. . .
test::expect5
test::rawvalue******************************************************************************~x. . .
test::spike_supress1
test::testedp1
timeout0
transtimeThu  2 Apr 13:55:11 2009
typeService
unameblaaaaaaaaaaaaaaaa 

How could I get the absolute whole value for  test:currvalue ?  even if it is 30 lines long or more ??

Thanks
-IvanG.

---

From: Jeff Weisberg <[email-masked]>
Date: Thu, 9 Apr 2009 15:32:31 -0400

On 2 Apr, 2009, at 18:47, Ivan wrote:

> How could I get the absolute whole value for  test::currvalue ?   
> even if it is 30 lines long or more ??

argusctl getparam object=Top:Foo param=test::currvalue

or

argusctl about object=Top:Foo