Subject: How to access Argus in the browser?

From: Roberto Schuster <[email-masked]>
Date: Sun, 12 May 2013 21:00:42 -0300

Hi,

I'm trying to use argus, but without success.  :(

I have followed all the steps in the Docs > Installing section and
everything was intalled ok. However, I didn't figured out how to access the
Argus login interface...

So, I was wondering if anyone could help me on this situation. :)

Argus version: 3.7
OS: Ubuntu 10.04

Thanks

---

From: Scott Hiemstra <[email-masked]>
Date: Mon, 13 May 2013 08:54:52 -0400

I run CentOS so my setup is a bit different but I'll assist if I can.  If you haven't figured it out yet please sent the output of "grep ^INSTALL_ Makefile" from within the Argus src directory, this will provide all of your install paths.  Are you using Apache or some other webserver?  Are you planning to run Argus under a VirtualHost or as the main site on the machine?

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roberto Schuster
Sent: Sunday, May 12, 2013 8:01 PM
To: [email-masked]
Subject: How to access Argus in the browser?

Hi,

I have followed all the steps in the Docs > Installing section and everything was intalled ok. However, I didn't figured out how to access the Argus login interface...

Argus version: 3.7
OS: Ubuntu 10.04

Thanks
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: Roberto Schuster <[email-masked]>
Date: Mon, 13 May 2013 10:19:43 -0300

Hi Scot,

I'm using Apache as web server, on a virtual machine running on virtualbox.

A apreciate your help, but I just made it work! I had to ask some help to a
friend and we did some weird stuff:
 - set permission to www-data (apache) user in some sub directories in the
$datadir (ok, it was in the tutorial...)
 - set permission to argus user in some sub directories in the $datadir
 - rename arguscgi script file to arguscgi.pl, so it can run

Well, I'm going slow, but going on... :)

Now I can access the argus interface, but some errors still persist:
- *Error: cannot load argus javascript*
*- **Error: cannot load argus style_sheet*
*
*
I followed the instructions below, but the error remains....
- make sure you copy the file misc/argus.js to your htdocs directory and
configure a javascript: /correct/url/argus.js in your argus config
- make sure you copy the file misc/argus.css to your htdocs directory and
configure a style_sheet: /correct/url/argus.css in your argus config.

Thankss

2013/5/13 Scott Hiemstra <[email-masked]>

> I run CentOS so my setup is a bit different but I'll assist if I can.  If
> you haven't figured it out yet please sent the output of "grep ^INSTALL_
> Makefile" from within the Argus src directory, this will provide all of
> your install paths.  Are you using Apache or some other webserver?  Are you
> planning to run Argus under a VirtualHost or as the main site on the
> machine?
>
> Scott
>
>

---

From: Scott Hiemstra <[email-masked]>
Date: Mon, 13 May 2013 09:42:24 -0400

Glad you got further along.  If you send the output of "grep ^INSTALL_ Makefile" from within the Argus source directory, I should be able to send you pretty much exact commands to fix the problem.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roberto Schuster
Sent: Monday, May 13, 2013 9:20 AM
To: Discussion about Argus
Subject: Re: How to access Argus in the browser?

Hi Scot,

A apreciate your help, but I just made it work! I had to ask some help to a friend and we did some weird stuff:
 - set permission to www-data (apache) user in some sub directories in the $datadir (ok, it was in the tutorial...)
 - set permission to argus user in some sub directories in the $datadir
 - rename arguscgi script file to arguscgi.pl, so it can run

Now I can access the argus interface, but some errors still persist:
- *Error: cannot load argus javascript*
*- **Error: cannot load argus style_sheet*
*
*
I followed the instructions below, but the error remains....
- make sure you copy the file misc/argus.js to your htdocs directory and configure a javascript: /correct/url/argus.js in your argus config
- make sure you copy the file misc/argus.css to your htdocs directory and configure a style_sheet: /correct/url/argus.css in your argus config.

Thankss

> I run CentOS so my setup is a bit different but I'll assist if I can.  
> If you haven't figured it out yet please sent the output of "grep 
> ^INSTALL_ Makefile" from within the Argus src directory, this will 
> provide all of your install paths.  Are you using Apache or some other 
> webserver?  Are you planning to run Argus under a VirtualHost or as 
> the main site on the machine?
>
> Scott
>
>
> From: [email-masked] 
> [mailto:[email-masked]]
> On Behalf Of Roberto Schuster
> everything was intalled ok. However, I didn't figured out how to 
> access the Argus login interface...
>