Subject: Re: Problems with login page

From: Jeff Weisberg <[email-masked]>
Date: Tue, 13 Apr 2004 14:50:06 -0400 (EDT)

I also get valid functioning cookies if I POST:

    telnet argus.ayustar.net 80
    POST /argus HTTP/1.0
    Host: argus.ayustar.net
    Content-Length: 21
    
    func=login;name=guest

or even:

    telnet argus.ayustar.net 80
    POST /argus?func=login HTTP/1.0
    Host: argus.ayustar.net
    Content-Length: 21
    
    func=login;name=guest

	--jeff

---

From: Jeff Weisberg <[email-masked]>
Date: Tue, 13 Apr 2004 14:54:16 -0400 (EDT)

| I also get valid functioning cookies if I POST:

no, sorry. I do not.
I see almost valid cookies.

today is 13 April 2004.
fix your clock.

	--jeff

---

From: "Jeremy Kister" <[email-masked]>
Date: Tue, 13 Apr 2004 15:26:48 -0400

On Tue Apr 13 14:41:21 EDT 2004, Jeff Weisberg wrote:
> | server does not even attempt to give me a cookie -- it just seems to
refresh
> | the login page upon submit.

> hmmm. how do you know you aren't getting a cookie?
>
>if I get rid of the browser, and do a:

well I have confirmed IE does not deem the receiving of an already expired
cookie "receiving a cookie".
in order for IE to say "hey, you just got a cookie", the cookie's expiration
date must be in the future.

i'd call that a bug, but that's another converstation.

Jeremy Kister
www.jeremykister.com/jeremy/