Subject: my config file is not working properly take a look!

From: "Rionel.J Jeudy" <[email-masked]>
Date: Tue, 23 May 2006 21:02:31 -0400

I am having a hard time putting together a consistent config file.

some nodes are shown down when they re supposed to be up
and if i type the same info in my config , it works:

if someone had a good script to generate the config file, you can
e-mail it to me

here is a sample of my config file

2) my script generate the config as follow:
although each Ip is pingable argus marked IP 10.64.24.14 red
if i manually type the Ip on top of my config, it markes it as red and
it marks 10.64.24.13 as read

##################################################################
####                       ARGUS CONFIGURATION FILE
####
#########################################################################

# locations of various items on web pages
sirensong:      /sound/whoopwhoop.wav
bkgimage:       /img/argus.logo.gif
icon:           /img/smile.gif
icon_down:      /img/sad.gif
nospkr_icon:    /img/nospkr.gif
style_sheet:    /argus.css

# send messages to syslog
syslog:         daemon

# who should be notified when things break?
#notify:         mail:[email-masked]
notify:         mail:[email-masked]

# don't summarize notifications
nolotsmsgs:     yes

# enable built in tcp test port
test_port:      3074

# enable built in resolver
Resolv
######################################################################################
#####
#####                                MAIL FORMAT
######################################################################################

 Method "mail" {
               command:        sendmail -t
               send:           To: %R\nFrom:%F\nSubject: %O{note} is %S\n\%M\n
              }

######################################################################################

Group "Terminal Servers" {
                                frequency: 20
                                renotify: 86400
 service: Ping {
                                hostname: 10.205.1.228
                                messageup: Host: term01 IP: 10.205.1.228  IS %s
                                messagedn: Host: term01 IP: 10.205.1.228  IS %s
                                note: term01
				                                }
 service: Ping {
                                hostname: 10.205.1.229
                                messageup: Host: term03 IP: 10.205.1.229  IS %s
                                messagedn: Host: term03 IP: 10.205.1.229  IS %s
                                note: term03
                                }
 service: Ping {
                                hostname: 10.205.1.230
                                messageup: Host: term04 IP: 10.205.1.230  IS %s
                                messagedn: Host: term04 IP: 10.205.1.230  IS %s
                                note: term04
                                }
 service: Ping {
                                hostname: 10.205.1.231
                                messageup: Host: term06 IP: 10.205.1.231  IS %s
                                messagedn: Host: term06 IP: 10.205.1.231  IS %s
                                note: term06
                                }
 service: Ping {
                                hostname: 10.205.1.232
                                messageup: Host: term10 IP: 10.205.1.232  IS %s
                                messagedn: Host: term10 IP: 10.205.1.232  IS %s
                                note: term10
                                }
 service: Ping {
                                hostname: 10.205.1.233
                                messageup: Host: term14 IP: 10.205.1.233  IS %s
                                messagedn: Host: term14 IP: 10.205.1.233  IS %s
                                note: term14
                                }
 service: Ping {
                                hostname: 10.205.1.234
                                messageup: Host: term16 IP: 10.205.1.234  IS %s
                                messagedn: Host: term16 IP: 10.205.1.234  IS %s
                                note: term16
                                }
 service: Ping {
                                hostname: 10.205.1.235
                                messageup: Host: term17 IP: 10.205.1.235  IS %s
                                messagedn: Host: term17 IP: 10.205.1.235  IS %s
                                note: term17
                                }
 service: Ping {
                                hostname: 10.205.1.236
                                messageup: Host: term19 IP: 10.205.1.236  IS %s
                                messagedn: Host: term19 IP: 10.205.1.236  IS %s
                                note: term19
				                                }
 service: Ping {
                                hostname: 10.64.24.11
                                messageup: Host: term01 IP: 10.64.24.11
%s
                                messagedn: Host: term01 IP: 10.64.24.11
%s
                                note: term01
                                }
 service: Ping {
                                hostname: 10.64.24.12
                                messageup: Host: term02 IP: 10.64.24.12
%s
                                messagedn: Host: term02 IP: 10.64.24.12
%s
                                note: term02
                                }
 service: Ping {
                                hostname: 10.64.24.13
                                messageup: Host: term03 IP: 10.64.24.13
%s
                                messagedn: Host: term03 IP: 10.64.24.13
%s
                                note: term03
                                }
 service: Ping {
                                hostname: 10.64.24.14
                                messageup: Host: term04 IP: 10.64.24.14
%s
                                messagedn: Host: term04 IP: 10.64.24.14
%s
                                note: term04
                                }
 service: Ping {
                                hostname: 10.64.24.15
                                messageup: Host: term05 IP: 10.64.24.15
%s
                                messagedn: Host: term05 IP: 10.64.24.15
%s
                                note: term05
                                }
}

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 24 May 2006 15:04:25 -0400 (EDT)

| some nodes are shown down when they re supposed to be up
| and if i type the same info in my config , it works:

I do not understand what this means.

you are doing something and it doesn't work, but you
are doing something else (?) it does work?

| if someone had a good script to generate the config file, you can
| e-mail it to me

I suggest that you create your config files by hand and get
everything working before trying anything more advanced.

| here is a sample of my config file

  >				    messagedn: Host: term01 IP: 10.64.24.11

this is not valid. you probably meant for the '%s' to be
on the same line as the messageup/messagedn.