Subject: Trouble with expect

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 19 Jan 2005 15:56:00 -0500

Hi all,

    I'm sure there's a quick and easy answer to this, but I can't find 
it....  I'm trying to monitor the Team Cymru bogon list for updates.  
So, I set up my config like this :

   Service TCP/URL {
      url:     http://www.cymru.com/Documents/bogon-list.html
      browser: Team Cymru Bogon List - Version 2.5
      expect:     The\ Team\ Cymru\ Bogon\ List\ v2\.5\ 02\ AUG\ 2004
      label:      Bogon List Version
      messagedn:  Cymru Bogon List Updated!
      frequency:  86400
      retries: 5
      retrydelay: 600
   }

Ok, all good, it's showing up.  But I wanted to make sure it was 
working, so I changed the version in the expect line.  Specifically, I 
changed it to this :

      expect:     The\ Team\ Cymru\ Bogon\ List\ v2\.6\ 02\ AUG\ 2004

I hupped Argus, waited for it to restart, and then issued a checknow for 
that object :

./argusctl checknow 
"object=Top:World_Reachability:URL_www.cymru.com:80/Documents/bogon-list.html"

No dice.  It listed as up and stayed up...

Any idea what I'm missing here?  I'm definitely no regex expert, but I 
thought that expression would work fine ?

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Wed, 19 Jan 2005 16:44:51 -0500

> No dice.  It listed as up and stayed up...

I may have spoken prematurely..  This has now moved into a down state..  
Not sure why it took so long though...  Any ideas?

---

From: "Gonzalo Perez Brun" <[email-masked]>
Date: Wed, 19 Jan 2005 20:18:53 -0300

please trie:

frequency: 86400
retries: 4
retrydelay: 600
timeout: 10

>From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
>Reply-To: Discussion about Argus <[email-masked]>
>To: Discussion about Argus <[email-masked]>
>Subject: Trouble with expect
>Date: Wed, 19 Jan 2005 15:56:00 -0500
>
>Hi all,
>
>it....  I'm trying to monitor the Team Cymru bogon list for updates.  So, I 
>set up my config like this :
>
>   Service TCP/URL {
>Ok, all good, it's showing up.  But I wanted to make sure it was working, 
>so I changed the version in the expect line.  Specifically, I changed it to 
>this :
>
>"Something mysterious is formed, born in the silent void. Waiting alone and 
>unmoving, it is at once still and yet in constant motion. It is the source 
>of all programs. I do not know its name, so I will call it the Tao of 
>Programming."
>
>_______________________________________________
>http://argus.tcp4me.com/
>[email-masked]
>http://www.tcp4me.com/mailman/listinfo/arguslist

_________________________________________________________________
MSN Amor: busca tu ½ naranja http://latam.msn.com/amor/