Subject: Re: Ignoring Downs during certain times

From: "Jeremy Kister" <[email-masked]>
Date: Sun, 17 Oct 2004 16:56:06 -0400

On Sun, 17 Oct 2004 15:15:51 -0400, Jason 'XenoPhage' Frisvold wrote:

>     I would like to be able to tell Argus that between 12:00 and12:30am,
> ignore the down.  Better yet, I would love to be able to say to use a

take a look at "cron jobs" on http://argus.tcp4me.com/config-new.html

inside your service,
  cron "0 0 * * * *" {
    func: override
    text: we know backups excede normal threshold
    expires: 1800
    mode: manual
    quiet: yes
  }

-- 

Jeremy Kister
http://jeremy.kister.net/

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Sun, 17 Oct 2004 21:04:21 -0400

>    text: we know backups excede normal threshold
Excellent...

I have one more for you ...

Which directive was it to have the system do the laundry?  And can I 
choose water temp, load size, etc?

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Sun, 17 Oct 2004 21:37:26 -0400

>take a look at "cron jobs" on http://argus.tcp4me.com/config-new.html
Is this legal?  Argus didn't choke on it, but I want to make sure it 
does what I think it does...  It should set the maxvalue to 35 except 
between the hours of 1am and 4am where it would be set to 40.  Will this 
work ok when argus starts up, or do I need to put a maxvalue outside of 
the crons?

         Service SYS/disk {
            uname: home
            label: home
            arg: /home
            graph: yes
            cron "0 1 * * * *" {
               func: setparam
               param: maxvalue
               value: 40
            }
            cron "0 4 * * * *" {
               func: setparam
               param: maxvalue
               value: 35
            }