Subject: Schedule Checking

From: Steve Smith <[email-masked]>
Date: Thu, 16 Jun 2016 12:34:39 -0700

Hello all,

I'm trying to include schedule checking but everywhere I place the
following it returns an error:

Service Prog {
                Schedule checking {
                        * 0000 - 0600 => no
                }
        }

I've tried this, it doesn't work:

Group "Server Process MSAccess" {
	autoack:	yes
	frequency:	15min
	messagedn:	Peachtree Access is DOWN
	messageup:	Peachtree Access is UP
	sendnotify:	no
Schedule checking {
                        * 0000 - 0600 => no
                } Service Prog {
		command:	cat  /home/steve/data/2015proc.txt
		debug:	yes
		expect:	\bMSACCESS\b
	}

Would someone kindly show me an example of a working config?

Thanks.

-- 
Fallbrook, CA.
92028

---

From: Jeremy Kister <[email-masked]>
Date: Mon, 20 Jun 2016 01:12:02 -0400

> I've tried this, it doesn't work:

can you write/screenshot an error you're getting or what you see that's 
wrong?

> Would someone kindly show me an example of a working config?

syntax in the config is very important.  esp. new lines and { }

i'm not sure if your mail just came through garbled or if that was your 
actual config, but a clean version of what you posted is at

http://pastebin.com/raw/a6t9FfvD

-- 

Jeremy Kister
http://jeremy.kister.net/

---

From: Steve Smith <[email-masked]>
Date: Tue, 21 Jun 2016 11:50:38 -0700

Hi Jeremy,

Thanks for the reply. I got it figured out (below). I'm a "learn by
example" guy and the links to the docs for schedules are unavailable.
Luckily I was able to find an (almost working) example in the archives.

----

Group "Server MS Access" {
	autoack:	yes
	frequency:	15min
	messagedn:	Peacht Access is DOWN
	messageup:	Peacht Access is UP
	sendnotify:	yes
	Service Prog {
		command:	cat  /home/steve/data/2015proc.txt
		debug:	yes
		expect:	\bMSACCESS\b
		Schedule testing {
			mon 0500 - 1900 => yes
			tue 0500 - 1900 => yes
			wed 0500 - 1900 => yes
			thu 0500 - 1900 => yes
			fri 0500 - 1900 => yes
			sat 0500 - 1400 => yes
			all 0000 - 2400 => no
		}
	}
}

On Sun, Jun 19, 2016 at 10:12 PM, Jeremy Kister <[email-masked]>
wrote:

> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist
>

-- 
Fallbrook, CA.
92028