Subject: DARP settings

From: Andrei Raileanu <[email-masked]>
Date: Wed, 23 Jul 2008 06:24:04 -0700 (PDT)

Hello, 
 
I have Argus running on a large data center. I thought it would be much more easy for the monitoring system to use DARP. I tried to use DARP with a simple config, but Argus ignores the settings related to DARP master/slave systems: 
ERROR: in file '/usr/local/argus/var/config' on line 24 - Huh? This does not look like a vaild config entry: 'DARP "master0" {' 
This is the DARP entry from the config file: 
DARP "master0" { 
            # parameters common to all 
            # slaves can appear up here 
 
            slave "slave1" { 
                hostname:       10.1.1.15 
                secret:         passwd01 
            } 
            slave "slave2" { 
                hostname:       10.1.1.16 
                secret:         passwd02 
            } 
} 
I am using perl version 5.8.0/5.8.5 and I have tested Argus dev-20080721 and 3.5. 
What causes this error?

---

From: Jeremy Kister <[email-masked]>
Date: Wed, 23 Jul 2008 09:57:43 -0400

> This is the DARP entry from the config file: 

do you have the darp_mode parameter in your main config?

  like:
darp_mode: failover
  or
darp_mode: redundant

?

http://argus.tcp4me.com/darp.html

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: Andrei Raileanu <[email-masked]>
Date: Wed, 23 Jul 2008 07:09:37 -0700 (PDT)

--- On Wed, 7/23/08, Jeremy Kister <[email-masked]> wrote:
From: Jeremy Kister <[email-masked]>
Subject: Re: DARP settings
To: "Discussion about Argus" <[email-masked]>
Date: Wednesday, July 23, 2008, 4:57 PM

On 7/23/2008 9:24 AM, Andrei Raileanu wrote:
> I have Argus running on a large data center. I thought it would be much
more easy for the monitoring system to use DARP. I tried to use DARP with a
simple config, but Argus ignores the settings related to DARP master/slave
systems: 
> ERROR: in file '/usr/local/argus/var/config' on line 24 - Huh?
This does not look like a vaild config entry: 'DARP "master0"
{' 

  like:
darp_mode: failover
  or
darp_mode: redundant

?

Yes.
darp_mode: failover
For some reasons same config file works on SuSE 11.0 with perl 5.10.0, but I have upgraded perl (to 5.10.0) on one of my systems with SuSE 10.3 and I get the same error, so I got the conclusion that it's not a problem with perl version.

-- 

Jeremy Kister

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist