Subject: Re: dependencies checks

From: "Jeremy Kister" <[email-masked]>
Date: Tue, 23 Mar 2004 18:23:01 -0500

On Tue Mar 23 08:05:09 EST 2004, Josef Bergmann wrote:

> >   Group "switch2" {
> >     hostname: 192.168.1.2
> >     Service Ping
> >     depends: Top:switch1:Ping
> >   }
>
> Sorry but that did not work.

Hrm.. perhaps we're suffering from an i-suck error.  instead, try:
  Group "switch2" {
    hostname: 192.168.1.2
    Service Ping {
      depends: Top:switch1:Ping
    }
   }

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Josef Bergmann <[email-masked]>
Date: Wed, 24 Mar 2004 08:47:52 +0100

>       depends: Top:switch1:Ping

Doesn't work either ...
WARNING: in file '/var/argus/config' on line ... - Cannot resolve dependency: 
Top:switch1:Ping

But that gave me a few ideas and i tried 
Group "switch2" {
	depends: Top:switch1
	hostname: 192.168.1.2
	Service Ping
}

Bingo!

I found depends should stay bevor any services-definitions and it could not 
depend on services (with V 3.2.1).

bye Josef
-- 
BERGMANN engineering & consulting  http://bec.at