Subject: Re: Server Monitoring

From: Jeff Weisberg <[email-masked]>
Date: Thu, 14 Oct 2004 19:58:07 -0400 (EDT)

|     Is anyone out there using Argus to monitor servers?  I'm looking to 
| monitor the CPU and Hard Drive space on the servers ( and maybe other 
| stuff ), but I'm not sure how to do this with Argus.  I started looking 
| into using net-snmp, but I'm a little overwhelmed with the config for 
| this.  In addition, it looks to only monitor load average, and not cpu.
| 
|     Is SNMP the only way to do this, or is there something easier?

alternatively, if you look in the argus src directory, there is a
'sys_agent.pl' that you can run from inetd on all of your servers
(you will probably need to modify it to work on your system).

you can then copy the 'SysAgent.pm' file into your $libdir
(modifications may be needed), restart argus. adjust your config file
to use it:

	Host "server1" {

		Service SYS/load
		Service SYS/netstat {
			calc:   ave-rate-bits
			arg:    eth0 in
		}
		Service SYS/disk {
			arg:	/usr
		}
	}

	--jeff

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Thu, 14 Oct 2004 23:27:05 -0400

>(you will probably need to modify it to work on your system).
Perfect..  This will handle exactly what I need..  :)  At least until I 
can get SNMP working properly..  :)

>(modifications may be needed), restart argus. adjust your config file
So I can create new tests simply by creating a .pm file, eh?  I'll have 
to look into this..  May have a use for it....  :)

>	--jeff
Thanks for the info!

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone and unmoving, it is at once still and yet in constant motion. It is the source of all programs. I do not know its name, so I will call it the Tao of Programming."