Subject: Re: Problems with login page.

From: Jeff Weisberg <[email-masked]>
Date: Mon, 12 Apr 2004 16:20:23 -0400 (EDT)

| I go to the login page, I type in the username guest and as soon as it
| tries to redirect it sends me back to the login page.
| 
| The URL is the following: http://argus.ayustar.net/argus?func=login
| No password required.
| 
| The browser accepts cookies, and there is no errors or msgs on the webserver
| error_log nor the argus log.

works for me.

are you sure your browser is accepting cookies?

	--jeff

---

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 12 Apr 2004 22:28:53 -0400

> | The URL is the following: http://argus.ayustar.net/argus?func=login
[...]
> are you sure your browser is accepting cookies?

Hrm... I just loaded the above url, and it does not work for me.  The web
server does not even attempt to give me a cookie -- it just seems to refresh
the login page upon submit.

I do see, however
<form method="post" action="/argus?func=login"
in the html source

i've seen some versions of CGI.pm only work with either Get or Post, and
specifically not both -- this could lead to the problem of CGI parsing
func=login and ignoring the post...  although I have only had experience
visa-versa -- CGI reading the Post and not paying attention to the Get.

This wouldnt make sense though, if it works for Jeff/Neil.

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 12 Apr 2004 22:38:13 -0400

> <form method="post" action="/argus?func=login"

and i also see

<INPUT TYPE=HIDDEN NAME=func VALUE=login>

ignore my chatter.

Jeremy Kister

---

From: "Jeremy Kister" <[email-masked]>
Date: Mon, 12 Apr 2004 22:47:34 -0400

On Monday, April 12, 2004 10:29 PM, I wrote:
> Hrm... I just loaded the above url, and it does not work for me.

I have noted that if I enter invalid credentials (foo/bar) argus prints:
<H2><FONT COLOR="#FF0000">ERROR: Authentication Failed</FONT></H2>

Argus clearly understands 'guest' is a valid username.

Jeremy Kister

---

From: Jeff Weisberg <[email-masked]>
Date: Tue, 13 Apr 2004 14:41:21 -0400 (EDT)

| > | The URL is the following: http://argus.ayustar.net/argus?func=login
| > | No password required.
| [...]
| > works for me.
| > are you sure your browser is accepting cookies?
| 
| Hrm... I just loaded the above url, and it does not work for me.  The web
| server does not even attempt to give me a cookie -- it just seems to refresh
| the login page upon submit.

hmmm. how do you know you aren't getting a cookie?

if I get rid of the browser, and do a:
	telnet argus.ayustar.net 80
	GET /argus?func=login;name=guest HTTP/1.0
	Host: argus.ayustar.net

I see a cookie.

and a:
	telnet argus.ayustar.net 80
	GET /argus?object=Top;func=page;top=1 HTTP/1.0
	Host: argus.ayustar.net
	Cookie: argus=the_cookie_i_was_given

gives me a valid webpage.

	--jeff