Subject: Problems with Ping Showing as DOWN

From: "Hill, Martin \(HQ\)" <[email-masked]>
Date: Tue, 16 Aug 2005 15:41:55 +0100

I am running Argus to ping a host of servers in different groups.

Most groups/ servers are pinging correctly and showing as up, however
some groups are not: within these groups all servers start off as up and
then all go down then stay down even though they are all up!!

Can anybody help with this?

Basic config:

Group "Servers 1" {

                        Host "Server 01"

                                    Hostname: 192.168.1.1

                                    Service Ping

                        }

            }

Group "Servers 2" {

                        Host "Server 02"

                                    Hostname: 192.168.2.1

                                    Service Ping

                        }

            }

Martin Hill

Sumitomo Electric Wiring Systems (Europe) Ltd

All inbound and outbound e-mails are scanned by BT Net VirusScreen on behalf of SEWS-E. This service quarantines e-mails containing viruses, unsuitable material and any password protected or encrypted attachments. 

Confidential information may be contained in this message.  If you are not the addressee indicated (or responsible for delivery of the message), you may not copy or deliver this message to anyone. In such case, you should destroy this message and notify the sender. Please advise immediately if you or your employer does not consent to Internet email for messages of this kind.  Opinions, conclusions and other information in this message that do not relate to the official business of SEWS-E shall be understood as neither given nor endorsed by it.

---

From: Jeremy Kister <[email-masked]>
Date: Tue, 16 Aug 2005 13:54:45 -0400

> then all go down then stay down even though they are all up!!

is your fping setuid root?

to setuid root, try:
chown root /usr/local/bin/fping
chmod u+sx /usr/local/bin/fping
	
(assuming you installed fping in /usr/local/bin/)

i'm also not sure that the parameters in the config are case sensitive -
 try changing "Hostname: 192.168.1.1" to "hostname: 192.168.1.1"

-- 

Jeremy Kister
http://jeremy.kister.net/