Subject: Repost: SSL issue: set options failed: Operation now in progress

From: Tom Lisjac <[email-masked]>
Date: Sun, 23 Sep 2012 21:50:01 -0500

Hi all,

I'm using the development version of Argus (argus-dev-20120107) to
monitor about 30 machines. Most of it is working impressively well but
I'm seeing the following errors in the log when any https, imaps or
smtps tests are enabled:

[2012/08/19 17:21:23.1117] [11871] TCP/SSL set options failed: Operation now in progress
[2012/08/19 17:21:12.9232] [11871] TCP/SSL set options failed: Operation now in progress
[2012/08/19 17:20:34.2391] [11871] TCP/SSL set options failed: Illegal seek
[2012/08/19 17:20:18.4513] [11871] TCP/SSL set options failed: Illegal seek

I haven't been able to find any references from google or the docs, but
suspect that something is hanging during the initial ssl cert
negotiation. The operation in progress errors continue, but the illegal
seeks stop when I disable imaps and smtps checking. Here is the output from
the argus build:

found db type: DB_File
Socket6 not found - no IPv6 support for you 
found GD - including graphing support
found DBI - including Database testing support
found Net::SSLeay - including extended SSL testing support
found Digest::HMAC
found Digest::MD5
found Digest::SHA1
found Crypt::DES
including SNMPv3 authentication support
including SNMPv3 privacy support
including DARP support

Any suggestions to get this resolved would be greatly appreciated.

Thanks,

-Tom

---

From: Jeremy Kister <[email-masked]>
Date: Mon, 24 Sep 2012 09:00:51 -0400

> [2012/08/19 17:20:18.4513] [11871] TCP/SSL set options failed: Illegal seek

I had the same problem, seems to be an incompatibility with newer ssl.

my temporary hack was to comment out the line in SSL.pm:
  problem( $me, "set options failed: $!" ) if $i;

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: Scott Hiemstra <[email-masked]>
Date: Mon, 24 Sep 2012 09:02:28 -0400

Tom,

I can't offer anything about imaps or smtps but I ran into this with https on a version of Argus from several years ago.  I'm running dev-20111102 so I can't speak directly to dev-20120107.  Based on my internal notes it seems I had this issue when trying to use TCP/HTTPS, switching over to TCP/URL resolved the issue.  Also I have encountered problems between Argus and some of my IIS servers not negotiating SSL properly if I don't specify a browser string, I use "browser:        Mozilla/5.0 (compatible; Argus)".  I believe this has been a distinct issue with IIS7 for me.

Using TCP/HTTPS:
	Group "HTTPS Test" {
		hostname: secure.domain.com
		Service TCP/HTTPS
	}

Using TCP/URL:
	Group "URL Test" {
		Service TCP/URL {
			url: https://secure.domain.com
			label: My secure test target
		}
	}

Others may offer more insight but hope this helps in the interim,
Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Lisjac
Sent: Sunday, September 23, 2012 10:50 PM
To: [email-masked]
Subject: Repost: SSL issue: set options failed: Operation now in progress

Hi all,

I'm using the development version of Argus (argus-dev-20120107) to monitor about 30 machines. Most of it is working impressively well but I'm seeing the following errors in the log when any https, imaps or smtps tests are enabled:

I haven't been able to find any references from google or the docs, but suspect that something is hanging during the initial ssl cert negotiation. The operation in progress errors continue, but the illegal seeks stop when I disable imaps and smtps checking. Here is the output from the argus build:

found db type: DB_File
Socket6 not found - no IPv6 support for you found GD - including graphing support found DBI - including Database testing support found Net::SSLeay - including extended SSL testing support found Digest::HMAC found Digest::MD5 found Digest::SHA1 found Crypt::DES including SNMPv3 authentication support including SNMPv3 privacy support including DARP support

Thanks,

-Tom

_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---

From: Scott Hiemstra <[email-masked]>
Date: Mon, 24 Sep 2012 09:05:54 -0400

Even better, you win Jeremy.  :)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jeremy Kister
Sent: Monday, September 24, 2012 9:01 AM
To: Discussion about Argus
Subject: Re: Repost: SSL issue: set options failed: Operation now in progress

-- 

Jeremy Kister

---

From: Tom Lisjac <[email-masked]>
Date: Mon, 24 Sep 2012 23:00:37 -0500

Hi Scott,

Many thanks to you and Jeremy for the replies.

The url approach you suggested worked, but still produced the Argus log
errors with Apache and mod_ssl. All along I'd been making the erroneous
assumption that the log errors were also giving flawed results, but that
doesn't seem to be the case. Commenting out the error generating code,
per Jeremy's suggestion, is a good workaround for this issue.

After playing with this for awhile, I noticed more connection noise from
Argus in the logs for these machines then I was willing to accept, so I
opted for this scaled down approach:

Service Prog {
  command: nmap -p 993 10.78.44.9 | grep -q "993/tcp open"
  label: IMAPS-Repo1
}

It's a little tedious, but nmap's default syn mode verifies the port is
open without propagating a full connection to the logs. Downside is it
also doesn't do any ssl or imap functionality testing, but I'm willing
to live with that. Only remaining problem is figuring out how to make
the notification emails a little less cryptic for our management. :)

9184 24/Sep 21:45 - Prog_nmap -p 993 10.78.44.9 | grep -q "993/tcp open" is DOWN/critical

Thanks again,

-Tom

---

From: Scott Hiemstra <[email-masked]>
Date: Tue, 25 Sep 2012 08:52:39 -0400

Tom,

If it is only one or 2 items you need to clean up the notifications for 
then you could simply specify the up/down messages for the individual 
service.  You wouldn't want to do this for all services as it does get 
very tedious to maintain.

Simply throw this into your Prog definition:
messagedn: IMAPS is down
messageup: IMAPS is up

Scott

On 25.09.2012 00:00, Tom Lisjac wrote:
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Jeremy Kister