Subject: arithmetic on oids

From: Jeremy Kister <[email-masked]>
Date: Thu, 20 Dec 2007 01:57:48 -0500

I need to use maxvalue on the (quotient of two oids)*100.

rather than run a script, it'd be nice if argus could do this for me.

like

Service SNMP {
	oid1:	.1.3.6.1
	oid2:	.1.3.6.2
	formula:	(oid1/oid2)*100
	maxvalue: 85
}

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: [email-masked]
Date: Thu, 20 Dec 2007 07:24:42 -0800

You can do this without a script (sort of - at least the script isn't
external).  Change from an SNMP Service to a Prog service and use something
like

command: bash -c "snmpget .1.3.6.1 .1.3.6.2 | awk -F' ' '{print ((\$1 *
\$2)/100)}"

...Matt Cleveland
...Web Architect
...Health Net Inc
...916.935.1248
[email-masked]

* There's no place like 127.0.0.1

             Jeremy Kister                                                 
             <argus-02@jeremyk                                             
             ister.com>                                                 To 
             Sent by:                  Discussion about Argus              
             arguslist-bounces         <[email-masked]>              
             @tcp4me.com                                                cc 
                                                                           
                                                                   Subject 
             12/19/2007 10:57          arithmetic on oids                  
             PM                                                            

             Please respond to                                             
             Discussion about                                              
                   Argus                                                   
             <arguslist@tcp4me                                             
                   .com>                                                   

like

Service SNMP {
             oid1:             .1.3.6.1
             oid2:             .1.3.6.2
             formula:          (oid1/oid2)*100
             maxvalue: 85
}

--

Jeremy Kister
http://jeremy.kister.net./
_______________________________________________
http://argus.tcp4me.com/
[email-masked]
http://www.tcp4me.com/mailman/listinfo/arguslist

---------------------------------------------------------------------
This message, together with any attachments, is
intended only for the use of the individual or entity
to which it is addressed. It may contain information
that is confidential and prohibited from disclosure.
If you are not the intended recipient, you are hereby
notified that any dissemination or copying of this
message or any attachment is strictly prohibited. If
you have received this message in error, please notify
the original sender immediately by telephone or by
return e-mail and delete this message, along with any
attachments, from your computer. Thank you.

---------------------------------------------------------------------