Subject: Memory leak ?

From: Fire <[email-masked]>
Date: Thu, 14 Apr 2005 11:38:21 -0600

I am using  argus-3.4_RC-20050408.
When I add more that 2 or 3 hosts that use custom up and down messages.
Argus sucks up all the memory and swap with in a few mins and locks up
the box.

Group "Webservers" {
        frequency: 600
                Host "WebServer2" {
                        hostname: WebServer2.example.com
                        graph:  yes
                        depends: Top:Routers:DataCenter-
Cisco:Ping_192.168.5.254
                        Service Ping {
                                depends:
Top:Webservers_Monitor:Webservers:WebServer2
                                messagedn:      Ping DOWN WebServer2
                                messageup:      Ping UP WebServer2
                        }
                        Service TCP/HTTP {
                                depends:
Top:Webservers_Monitor:Webservers:WebServer2
                                messagedn:      HTTP DOWN WebServer2
                                messageup:      HTTP UP WebServer2
                        }
                        Service TCP/SMTP {
                                depends:
Top:Webservers_Monitor:Webservers:WebServer2
                                messagedn:      SMTP DOWN WebServer2
                                messageup:      SMTP UP WebServer2
                        }
                        Service TCP/POP {
                                depends:
Top:Webservers_Monitor:Webservers:WebServer2
                                messagedn:      POP3 DOWN WebServer2
                                messageup:      POP3 UP WebServer2
                        }
                        Service TCP/SSH {
                                depends:
Top:Webservers_Monitor:Webservers:WebServer2
                                messagedn:      SSH DOWN WebServer2
                                messageup:      SSH UP WebServer2
                        }
                 }

---

From: Jeff Weisberg <[email-masked]>
Date: Wed, 20 Apr 2005 21:03:12 -0400 (EDT)

| Yes I cut my config down to just the one file and started from one host
| and increased by one with a  restart after each addition restarted.
| normally Argus (in Top) takes 10 -12 M
| I watched top skyrocket
| It eventually consumes all 512 RAM and 1G swap

ok. I was able to reproduce the problem.
The problem is your recursive depends (the
services depending on their parent).

I just uploaded a new tarball which fixes
the issue (it won't crash), but I'm not sure
what you're trying to do with those depends--
and there is probably a better way to do it.

	--jeff