Subject: DARP TCP slave issue

From: Jeremy Kister <[email-masked]>
Date: Fri, 29 Jul 2005 03:15:07 -0400

I've got DARP-3.4_RC20050419 running on my master and slave, both
running Argus 3.4.

on the master, all of the objects have slave status "unknown" -- I'm
trying to fix this.

interesting data:

on the slave, I can connect to the master on port 2055
on the slave, I cannot connect to localhost on port 2055
on the master, I can connect to localhost on port 2055
on the master, I cannot connect to the slave on port 2055

on the slave, argusctl status shows:
version:   3.4
perlver:   5.8.6
osinfo:    SunOS 5.7 sun4m
darpmode:  slave
objects:   323
services:  208
notifies:  0
uptime:    0:08:01

argusctl status shows just about the same on the master:
darpmode:  master
objects:   349
services:  210
notifies:  67
uptime:    21d 9:28:34

relevant config entries on the master:
darp_mode:  failover
DARP "master" {
   slave "slave1" {
      hostname:   slave.example.com
      secret:     secret
   }
}

relevant config entries on the slave:
darp_mode:  failover
DARP "slave1" {
   master "master" {
      hostname:   master.example.com
      secret:     secret
   }
}

any ideas why all the slave statuses on the master are all unknown?

-- 

Jeremy Kister
http://jeremy.kister.net./

---

From: Jeff Weisberg <[email-masked]>
Date: Fri, 29 Jul 2005 09:51:00 -0400

> on the master, I cannot connect to the slave on port 2055

this is normal. only the master listens for connections.

> [...]

this is normal.
in failover mode, the slaves will not monitor anything until the master 
dies.
since they aren't doing any monitoring, they have no statuses to report.

---

From: Jeremy Kister <[email-masked]>
Date: Fri, 29 Jul 2005 14:59:03 -0400

[...]
> since they aren't doing any monitoring, they have no statuses to report.

Ah-ha.  Glad you were paying attention.

I love DARP, and hope everyone gets it.   Highly recommended.

maybe my new sig for this list will be:

-- 

Jeremy Kister
http://jeremy.kister.net/
Got DARP?  http://argus.tcp4me.com./darp.html

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Mon, 01 Aug 2005 10:00:47 -0400

>maybe my new sig for this list will be:

I asked about DARP some time ago..  What's the cost?  How do I get it???

Thanks!

Jason

---

From: "Gonzalo Perez Brun" <[email-masked]>
Date: Wed, 03 Aug 2005 14:11:16 -0300

Mr. Kister:
      I asked the same things. Do you obtain it?
Gonzalo.

>From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
>Reply-To: Discussion about Argus <[email-masked]>
>To: Discussion about Argus <[email-masked]>
>Subject: Re: DARP TCP slave issue
>Date: Mon, 01 Aug 2005 10:00:47 -0400
>
>Jeremy Kister wrote:
>
>_______________________________________________
>http://argus.tcp4me.com/
>[email-masked]
>http://www.tcp4me.com/mailman/listinfo/arguslist

_________________________________________________________________
MSN Amor: busca tu ½ naranja http://latam.msn.com/amor/

---

From: Jeremy Kister <[email-masked]>
Date: Wed, 03 Aug 2005 16:25:10 -0400

On 8/3/2005 1:11 PM, Gonzalo Perez Brun wrote:
>> On 8/1/2005 10:00 AM, Jason 'XenoPhage' Frisvold wrote:

Just send an email to [email-masked], requesting the price for DARP.
You'll probably have to kiss-up, too.  A message that would probably get
the author's attention below:

--

Subject: DARP purchase

Hi Jeff,

I think your DARP idea kick ass.  I love Argus and you're certainly the
best perl programmer I have ever known.  If I were a woman, I'd want you.

Please provide pricing information for DARP [and optionally some of your
time for helping to get it going].

-- 

Jeremy Kister
http://jeremy.kister.net/
Got DARP?  http://argus.tcp4me.com/darp.html

---

From: "Scott Hiemstra" <[email-masked]>
Date: Wed, 3 Aug 2005 18:20:31 -0400

> best perl programmer I have ever known.  If I were a woman, I'd want you.

Too funny...

Not the Perl programming portion as I wouldn't want to offend the author in
case I ever need assistance with DARP.  :)  It may also be wise to entice
Jeff with alcohol (Vodka maybe?), if I remember correctly that works well.

Scott

-----------------
Scott Hiemstra
Scott.hiemstra.us

---

From: Jeff Weisberg <[email-masked]>
Date: Mon, 15 Aug 2005 13:14:44 -0400

> the author's attention below:

You also needed to wait until I got back from vacation.
I have been away, and just got back.

an email to [email-masked],  and a little bit of
patience, will suffice.