Subject: Re: Database Testing

From: "Jeremy Kister" <[email-masked]>
Date: Fri, 12 Mar 2004 12:12:22 -0500

On Fri Mar 5 12:42:31 EST 2004, Christopher Ferry wrote:
> Is there something I'm missing?
> Does replication not stop on certain transactional errors??

According to documentation at
http://www.mysql.com/doc/en/Replication_Problems.html, admins should check
that both the Slave_IO_Running and Slave_SQL_Running colums report 'Yes'.

also, as posted by Mallikarjun BM on June 25 2003 10:46pm (via the above
url)
> Mysql replication suddenly stops. When i check this command mysql>show
slave status
>
> It shows SLAVE_IO_RUNNING is NO but SLAVE_SQL_RUNNING is YES.

I'm no MySQL expert, but just looking for 'Yes' may be bad.

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Christopher Ferry <[email-masked]>
Date: Fri, 12 Mar 2004 13:11:50 -0500

Jeremy,

That must be for MySQL 4(I've never worked with replication on 4)
We are using MySQL 3.23.56 and a show slave status produces:
mysql> show slave status;
+----------------+------------------+-------------+---------------+---------------+-----------+---------------+-----------------+---------------------+------------+------------+--------------+
| Master_Host    | Master_User      | Master_Port | Connect_retry |
Log_File      | Pos       | Slave_Running | Replicate_do_db |
Replicate_ignore_db | Last_errno | Last_error | Skip_counter |

So we only need to check for slave_running.
I think this makes sense, right?

Thanks

Chris

On Fri, 2004-03-12 at 12:12, Jeremy Kister wrote:
> _______________________________________________
> http://argus.tcp4me.com/
> [email-masked]
> http://www.tcp4me.com/mailman/listinfo/arguslist