Subject: Setting up Dependencies

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 21 May 2004 09:07:29 -0400

Hi all,

	I've gotten Argus up and running with little or no problems ..
(excellent product, works great!)  However, I'd like to start working on
some dependencies ...  But I can't figure out what I'm doing wrong
here...  (dependencies aren't mentioned in the docs ?  I found it
mentioned in the mailing list) ...

Here's my little example :

Group "RAS Boxes" {
   Host "Patton 2" {
      hostname: 1.2.3.4
      graph: yes
      Service Ping
      Service UDP/SNMP {
         label: Temperature
         oid: .1.3.6.1.4.1.1768.20.1.31.0
         maxvalue: 45
         sendnotify2: no
         depends: Top:RAS_Boxes:Patton_2:Ping
      }
      Service UDP/SNMP {
         label: Active Calls
         oid: .1.3.6.1.4.1.1768.5.25.0
         sendnotify2: no
         depends: Top:RAS_Boxes:Patton_2:Ping
      }
   }
}

I need the temperature and active users tests to be dependent on the
ping test...  I tried putting in the depends lines as indicated above,
but I get this error :

[2004/5/21 9:05:30] [31981] WARNING: in file '/usr2/Argus/data/config'
on line 7 - Cannot resolve dependency: Top:RAS_Boxes:Patton_2:Ping

Can anyone help me out with this?  Is this even supported yet?

Thanks!

-- 
---------------------------
Jason 'XenoPhage' Frisvold
Engine / Technology Programmer
[email-masked]
RedHat Certified - RHCE # 803004140609871
MySQL Pro Certified - ID# 207171862
MySQL Core Certified - ID# 205982910
---------------------------
"Something mysterious is formed, born in the silent void. Waiting alone
and unmoving, it is at once still and yet in constant motion. It is the
source of all programs. I do not know its name, so I will call it the
Tao of Programming."

---

From: Dariush Forouher <[email-masked]>
Date: Fri, 21 May 2004 15:47:31 +0200

> on line 7 - Cannot resolve dependency: Top:RAS_Boxes:Patton_2:Ping

Are you sure that "Top:RAS_Boxes:Patton_2:Ping" is the right object?
AFAIK it is "Top:RAS_Boxes:Patton_2:Ping_1.2.3.4" instead.  How calls 
arguscgi this object?

ciao
Dariush

---

From: "Jason 'XenoPhage' Frisvold" <[email-masked]>
Date: Fri, 21 May 2004 10:00:45 -0400

> AFAIK it is "Top:RAS_Boxes:Patton_2:Ping_1.2.3.4" instead.  How calls 

Well, Jeremy beat you to the puncch, but that was the exact problem ...

Thanks!