Subject: Argus Notifications Help (%O{param})

From: "rblake3" <[email-masked]>
Date: Mon, 17 Jun 2013 21:23:47 -0400

Hello everyone,

Was hoping someone could give me a little assistance with configuring 
notifications.

I reviewed the documentation found on: http://argus.tcp4me.com/notif.html

However, I am unable to figure out how to get %O{param} to show the name of 
the “Host” instead of having to show the entire entry with %O.  I have 
attempted to use %O{name} but that shows me the name of the service (e.g. 
Ping).  Instead, I would like to show the name of the host one level above 
it.  I would be ok with “hostname” or with the name of the Host (or simply 
the item one level above the name of the service).  Ok, let me show an 
example (might be easier for me to explain):

Example:

Host “TCP4Me” {
        hostname: argus.tcp4me.com
        Service TCP/HTTP
        Service Ping
}

In this situation, I would like to show both the Service that was affected 
(can use %O{name}) and the name of the host one level above it.  If Host 
were Group, I would like to show the name of the group (I want this to 
essentially show on the subject line of an e-mail notification).

How do I go about accomplishing this?

Any help would be greatly appreciated.  Also, thank you very much for such 
an excellent tool!

Thanks,
Ryan

---

From: sokhna diouf <[email-masked]>
Date: Tue, 24 Sep 2013 18:11:08 +0100 (BST)

Hello,
 
Excuse for
my bad english
You had to
use « label » in parameters like %O{label}
Service TCP/Asterisk
{
               
# make sure PRI is up
               
cmd:            pri show
span 2
               
expect:         Provisioned, Up, Active
               
label:Span2  of  192.168.2.3
       
}
 
And
 
Method
"mail" {
       
send:           To: %R\n\
       
From: %F\n\
       
Content-Type: text/plain; charset=utf-8\n\
       
Subject: Asterisk%Y\n\n\
       
%O{label}\n%S\n
}
 
Best
regards