Subject: argusd cpu usage

From: "Jeremy Kister" <[email-masked]>
Date: Thu, 25 Mar 2004 15:18:42 -0500

my Service Self/ide is alarming using Argus-3.3_RC-20040312.  top shows one
of the argusd processes taking about 100% of my cpu0, and none of my cpu1
(expectedly).

Is there any good debugging i can do to find out why argusd is taking so
much CPU?

I am graphing Self/idle as per http://argus.tcp4me.com/self.html.  It shows
~90% idle... should the title of this graph and yvalue be "percent not idle"
?

debugging Self/idle shows:
      srvc::reason SELF TEST less than min
      srvc::result 11.5655998585034

unix11> argusctl status
ARGUS/2.0 200 OK
status:   running
version:  3.3_RC-20040312
perlver:  5.8.3
osinfo:   SunOS 5.8 sun4u
objects:  1062
services: 854
notifies: 125
uptime:   1:28:57
idle:     11.72% 11.71% 11.51%
monrate:  6.07 6.21 6.24 per second

I stopped and started argus, and it is behaving more correctly now (taking
3% of cpu0), although since this will likely happen again, hints are
appreciated.

Jeremy Kister
www.jeremykister.com/jeremy/

---

From: Jeff Weisberg <[email-masked]>
Date: Thu, 25 Mar 2004 16:14:57 -0500 (EST)

| my Service Self/ide is alarming using Argus-3.3_RC-20040312.  top shows one
| of the argusd processes taking about 100% of my cpu0, and none of my cpu1
| (expectedly).
| 
| Is there any good debugging i can do to find out why argusd is taking so
| much CPU?
| 
| I am graphing Self/idle as per http://argus.tcp4me.com/self.html.  It shows
| ~90% idle... should the title of this graph and yvalue be "percent not idle"?
| 
| debugging Self/idle shows:
| 	srvc::reason SELF TEST less than min
| 	srvc::result 11.5655998585034

I don't understand.
'srvc::result' is the value that is graphed.
above you show '11.56'. where are you getting 90%?

| status:   running
| version:  3.3_RC-20040312
| perlver:  5.8.3
| osinfo:   SunOS 5.8 sun4u
| objects:  1062
| services: 854
| notifies: 125
| uptime:   1:28:57
| idle:     11.72% 11.71% 11.51%
| monrate:  6.07 6.21 6.24 per second

11% idle does seem wrong for so few services being monitored.

I recall there being some performance problems with certain
versions of perl under Solaris. do you have another version
of perl to try?

the only solaris box I have looks like:
    
    version:  dev-20040204
    perlver:  5.6.1
    osinfo:   SunOS 5.8 sun4u
    darpmode: master/slave
    objects:  368
    services: 333
    notifies: 147
    uptime:   22d 4:18:52
    idle:     96.33% 95.99% 96.31%
    monrate:  1.85 1.69 1.63 per second

	--jeff