Subject: Upgrade works with one issue.

From: "Charles Tweedy" <[email-masked]>
Date: Tue, 24 Jun 2008 07:33:12 -0400

Hello all. I enjoy watching your posts and never really have posted before. I have used Argus for 3 years now, and never touched it. It just works, and my perceived uptime has been 100%. I decided to move the system to a new box and use the new version. I copied my config over and it all works, however there are several web page related issues. For some background the older system was SUSE 8, and the new is version is Ubuntu 8.04. I am no expert in Apache, and this seems to be were the issue is. What happens is that I do not see the smiley icon, background, siren, and no speaker icon. Is this a style sheet thing or is the new version doing this different? I should be able to put all those items anywhere and point the config to them. Any help would be appreciated. Looks simple enough.

Charles T.
Network Manager

---

From: Jeremy Kister <[email-masked]>
Date: Tue, 24 Jun 2008 09:47:50 -0400

On 6/24/2008 7:33 AM, Charles Tweedy wrote:
 > to be were the issue is. What happens is that I do not see the smiley
> icon, background, siren, and no speaker icon. Is this a style sheet

Those things need to be copied manually from the misc directory.

assuming your webfolder for argus is /home/www/argus.example.com/

cd argus-* # the argus source code dir
cp misc/*.gif /home/www/argus.example.com/images/
cp misc/*.wav /home/www/argus.example.com/sounds/
cp misc/*.css /home/www/argus.example.com/
cp misc/*.js /home/www/argus.example.com/

then in your argus config:
sirensong:      /sounds/whoopwhoop.wav
bkgimage:       /images/argus.logo.gif
icon:           /images/smile.gif
icon_down:      /images/sadred.gif
nospkr_icon:    /images/nospkr.gif
style_sheet:    /argus.css
javascript:     /argus.js

-- 

Jeremy Kister
http://jeremy.kister.net./