Subject: ACLs: am I doing something wrong?

From: Roberto Alsina <[email-masked]>
Date: Sat, 29 Mar 2008 01:45:57 -0300

Hello, I have used argus for a while, but recently decided to start using ACLs 
and I just can't make them work. Am I doing something wrong?

Here's the relevant fragment of my users and config files (modified to protect 
the inocent ;-):

username      xxxxxxxxxxx   Top:Company                          company

Group "Company" {
	acl_root:       company
:
:
}

I nuke var/auth and restart argus to be sure I have no leftovers from other 
sessions, and when I login I get this:

ERROR     
	Access Denied

You do not have page permission on the requested object 

I tried also adding a

       acl_page:      company

but there's no difference.

This is running 20080304 on a Centos 4 linux with perl v5.8.8.

I'd try to debug it but perl is really not my forte.

-- 
 ("\''/").__..-''"`-. .         Roberto Alsina
 `9_ 9  )   `-. (    ).`-._.`)  KDE Developer (MFCH)
 (_Y_.)' ._   ) `._`.  " -.-'  http://lateral.netmanagers.com.ar 
  _..`-'_..-_/ /-'_.'     The 6,855th most popular site of Slovenia   
(l)-'' ((i).' ((!.'       according to alexa.com (27/5/2007) 
                    
Debugging is twice as hard as writing the code in the first place. 
Therefore, if you write the code as cleverly as possible, you are, 
by definition, not smart enough to debug it. --Brian W. Kernighan

---

From: Roberto Alsina <[email-masked]>
Date: Sat, 29 Mar 2008 23:45:42 -0300

On Saturday 29 March 2008 01:45:57 Roberto Alsina wrote:
> Hello, I have used argus for a while, but recently decided to start using
> ACLs and I just can't make them work. Am I doing something wrong?
>
> Here's the relevant fragment of my users and config files (modified to
> protect the inocent ;-):
>

I think I narrowed what's broken: acl_root.

If I just use acl_page and the others, inside a group, it works just fine.
But if I try to use acl_root, it doesn't.

Also, if I use acl_root outside groups, it logs this:

WARNING: in file '/opt/argus/var/config' on line 43 - additional data not 
permitted here (ignored)