Graphing troubles

Jared Crapo jared at
Fri Jun 25 18:08:42 EDT 2004

On Thu, 2004-06-24 at 13:58, Jeff Weisberg wrote:
> | The gdata directory is still empty.  <sad>No pretty pictures.</sad>
> [...]
> | Group "Myself" {
> |         graph: yes
> is "graphd" running?
> if not, does it complain if you run it by hand?
>   > prompt%  $libdir/graphd
graphd was not running; running it by hand gave:

$ perl $libdir/graphd
GRAPHD: restarted

I did notice that the perms on graphd were 644.  I changed them to 755,
and argus seemed to be able to start graphd by itself.  Now that graphd
is running, I have files in $datadir/gdata.  One step closer.  Although
~100k in size, the files seemed to be quite empty, ie binary files with
"holes" (od is my friend).  I let argus run overnight, and they filled
up with data.

I still didn't get any graphs.  $datadir/gcache had png files of 0
length.  I tried deleting them, hoping they would get regenerated.  They
did, but they are still 0 length.  After browsing the cgi program, I saw
that the graphs get generated by a program, appropriately named,
picasso.   It didn't have execute permissions.  Changing perms to 755,
and voila, pretty graphs.

Just for the record, larry wall would be pleased with the argus source
code, for it's artistic merits.  For those on the list who may not be
inclined to read perl code, please indulge me for posting a couple of
tasty snippets.


# What is the air-speed velocity of an unladen swallow?
sub air_speed_velocity {
    my $swallow = shift;

guido van rossum would be pleased.

Also from

# some cleaning down the tables with wet sponges
#   -- Homer, Odyssey
sub janitor {

# they could hear Circe within, singing most beautifully as she worked
# at her loom, making a web so fine, so soft, and of such dazzling
# as no one but a goddess could weave.
#   -- Homer, Odyssey

sub web_build {

And lastly, my personal favorite, from

# Computers are useless. They can only give you answers.
#   -- Picasso


More information about the Arguslist mailing list